-   Linux - Newbie (
-   -   intel 536ep modem with suse 9.3 pro (

pcandpc 05-13-2005 07:05 PM

intel 536ep modem with suse 9.3 pro

I am trying to make the Intel 536EP modem
in SuSE 9.3 Professional. This modem is automatically
detected by 9.3, but when configured correctly, the
modem does not work.

The same modem works great under SuSE 8.2 Pro
and FC3.

Has anybody using SuSE 9.3 made this modem work?

I even tried Intel's latest modem driver, but failed. Actually,
9.3 already comes with the latest Intel driver.


nawwar 05-28-2005 06:21 PM

I have the same problem, the modem worked well on SuSe 9.1 with intel driver ver:4.69 (which is the latest). now SuSe 9.3 already comes with the same driver but it's not working. -frustrating :(
Any idea?

pcandpc 05-29-2005 02:28 PM

Hi nawwar,

Thanks for your supportive feedback.

So, it wasn't me alone who's having the issue
on SuSE 9.3 Pro with Intel 536EP modem.

I suppose Intel should update their current driver
accordingly for SuSE 9.3 Pro, but does anybody have
any idea on resolving this issue meanwhile?

Again, the same 4.69.1 driver works great on SuSE 8.2 Pro,
FC3, and Mandrake PowerPack 10.1.


nawwar 05-30-2005 05:55 PM

Hi pcandpc,
no, you're not only facing this problem, it looks like a common problem, I know a couple of freinds having the same problem too.

The current driver doesn't work with linux kernel ver 2.6.11.* , I hope someone finds a way to hack around it or make a patch to the driver.

I don't really count on Intel to update their driver, because they're very lazy in this area, it took them a really long time (something like a year) before they updated the driver to the current one to make it work with linux 2.6.*

Although I'm new here, but I was wondering whether this is the proper forum to place this thread, isn't the Hardware forum more suitable for such topics? (Admins?)

pcandpc 05-30-2005 06:47 PM

Hi nawwar,

Thanks for your confirmation.

Actually, I was trying to understand the mechanics of Intel's
driver, but their coding was not very well documented for
readers to follow through and understand.

So, someone needs to update the Intel modem driver. Sad.

I'll be looking forward to the updated driver.


Emmanuel_uk 05-31-2005 02:05 AM


What is the kernel version in suse 9.3?

I know of at least 1 person using 9.3 and a 536ep

See my post, that should be applicable to you.

I only really have introduced disbling pm_access
- pm_access(power_dev);
+ //pm_access(power_dev);

The original patch is from "Vedran"

Please let us know how this goes

nawwar 05-31-2005 04:35 PM

Thank you Emmanuel_uk very much for your help, I'll try the patch and tell you what happens.

SuSe 9.3 uses kernel version 2.6.11

I wonder if there is any difference between the UP and the SMP drivers, the patch depends on the UP version, but I'm using the SMP versin of the kernel (my CPU is Intel Pentium 4 3.0 GHz/HT).

Edit: I've just understood that there is no UP and SMP in the uncompiled version of the driver. The difference is, when it's compiled, whether it's compiled for UP kernel or SMP kernel. Right?

pcandpc 05-31-2005 05:54 PM

Hi Emmanuel_uk,

Thanks for your tips.

Great! I'll be looking forward to your bright outcome
and thanks for getting back to Emmanuel_uk for the
SuSE 9.3 Pro kernel info.


Emmanuel_uk 06-01-2005 01:35 AM

2.6.11 is the "right" answer. The patch applies to this version.

I am curious to know if you need or not to disable

for the patch to work. Can you let us know, if you ever get a chance.

Normally, the guy from Intel in charge of the driver should
know by now about these problems. But some more users
confirmation would be good.

pcandpc 06-01-2005 10:38 AM

Hi Emmanuel_uk,

I'll try to work with your suggestion, but by then,
Intel might have already officially released a new
driver, I hope.

Anyway, great suggestion and resource, Emmanuel_uk!


Emmanuel_uk 06-02-2005 01:32 AM


but by then,
I would not count on this for now. Personal opinion here, but
from what I read "modem companies" do not keep up very well
with Kernel updates. So if I were you I would not wait,
I would try asap. Personally, my 536ep board has a physical defect,
it is still under guarantee, that is nothing to say about any other 536ep,
it is just a random thing I suppose,
and yes it was great to learn a bit about drivers and patches,
and help other people, but as soon as I can I will buy a hardware modem.

pcandpc 06-02-2005 09:30 PM

Hi Emmanuel_uk,

Following your patch 1 and 2, I changed the ".../coredrv/softserial.h"
and ".../coredrv/softserial_io.c" files accordingly but during the "make
install" stage where the Intel driver is supposed get installed, I get
the following script errors:


chgrp: cannot access `/dev/536ep`: No such file or directory
chmod: cannot access `/dev/536ep`: No such file or directory


But, the /dev/536ep has been created and exists properly. So, I went
ahead and tried to initiate the dial-up account but the connection failed.

Do you have any further suggestions?


Emmanuel_uk 06-03-2005 01:17 AM

These are not my patch :-), only a minor contribution
I wish I was that good!

Possibly look like you did not do the
make clean
make 536ep
make install
as root

Be root (type su in a terminal windows
then cd /where/ever/thepatchedfiles are)

Please try that, if it does not work, post the whole make session,
and ls -l /dev/5*; ls -l /dev/m*

On my system I also have /dev/536ep0
Never digged out why or even if it is normal

By the way, I am not clear how the patching process went.
If you used the patch command you should have had 3 lines
saying basically that it went well.

pcandpc 06-03-2005 02:39 AM

Hi Emmanuel_uk,

Yes, of course! If the scripting process went successful,
one'll have a clean "done" script response at the end of
three makes.

And surely, I've run the make scripts as "root", but it's
a puzzle to you and me why I'm getting "chgrp" and "chmod"
access errors on /dev/536ep.

I think the /dev/536ep is the result from compiling the Intel's
driver where as /dev/536ep0 is SuSE's default pre-compiled
module. And, the /dev/modem is a symbolic link that points
to the /dev/536ep, and this link is the result from the driver

So, it appears important to figure out the access errors first
in solving this issue, Emmanuel_uk.

Do you know of anyone who successfully compiled the patches
on SuSE 9.3? I thought you stated in your previous replies that
you know of someone who made the 9.3 working.


Posting the whole make session is just too long. Perhaps, you
should just look at it yourself from your own compiling.

Emmanuel_uk 06-03-2005 02:54 AM

sorry I suggested newbee stuffs
wanted to be sure the modem link was there
my compiling was in mandy 10.2

Klaus is the man with suse 9.3

All times are GMT -5. The time now is 04:29 PM.