-   Linux - Newbie (
-   -   Installting ATI drivers on openSUSE 10.2 and Desktop Effects problem (

willrix 01-09-2007 09:01 PM

Installting ATI drivers on openSUSE 10.2 and Desktop Effects problem
(I am aware there is a similar thread dealing with ATI driver installation on Fedora, but I felt it proper to start a new thread [sorry]).

I decided to see what Linux was about (I use Windows primarily) so I decided on openSUSE as the distro and Gnome as the desktop. To me, the first order of business was to install the display drivers for my ATI Radeon x800xl so I went to and went to the driver download area ( I have three options here:

1) Download "ATI Driver Installer" which is an "Automated installer and Display Drivers for XFree86 4.3 and X.Org 6.7, 6.8, 6.9, 7.0, 7.1"
2) Download "XFree86 4.3 Drivers"
3) Download "X.Org 6.8 Drivers"

I'd prefer not to download the first as it's about 55MB, so I'd like to download one of the last two but I don't know whether I am running/using XFree or X.Org, and I don't know how to find out.

How can I find out what I am running?

Additionally, when I access the Control Center and go to "Desktop Effects" it says...

Your graphics card is not known to be supported. It might or might not support Xgl, and it might or might not be able to run Xgl at full speed.

However, in order to use Xgl, you need to first install a special video driver for your video card. Press the button below to run the Software Updater tool to install this driver.
It seems strange that my graphics card is not supported as it's not too old, so I run "Star Software Updater" and it returns with...


Your graphics card is not known to be supported by Xgl, and it is not currently configured for 3D acceleration. Xgl cannot be enabled. However, if 3D acceleration can be enabled on this card, then it might be possible to run Xgl.

If you are having trouble fixing this, the openSUSE wiki may be able to help you.
I go to the openSUSE wiki but I am quickly lost. I cannot scroll smoothly and so I'd greatly like to have working drivers so I can continue to use openSUSE as I am liking it so far. Any ideas?

JimBass 01-09-2007 09:14 PM

You'll probably need to download the big file. Reason being, Suse uses Xorg (as almost every distro does now), but it is unlikely that it still runs version 6.8 when version 7.1 is out.

The update tool looks within the repositories you have configured for it, and since ATI and NVidia drivers aren't open source, they generally can't be installed through the built in apps. You need to finish what you started, and manually downlaod and install the drivers, then all the XGL stuff will most likely work.


willrix 01-09-2007 09:44 PM

I downloaded the file, opened Terminal, ran "su root" so I could install the program, and then accessed the file. Two things happen while it runs:

1) A directory is created on the desktop, "fglrx-install," with an icon of a folder with an orange lock on it. Haven't messed with it yet.
2) A window comes up prompting me to choose between "Install Driver 8.32.5 on Unknown X Window" and "Generate Distribution Specific Driver Package." I assume using a distro-specific driver is preferable, so I click on that option, and I am presented with a ton of SuSE package options. Here's a screenshot (don't wanna type out the options):

Again, I have no idea what I should choose. No clue what SLES, SLED or NLD means. Sorry for being so dumb, but I'd really like to get this working because Linux seems pretty neat thus far.

JimBass 01-09-2007 09:59 PM

No, you want to "Install Driver 8.32.5 on Unknown X Window".

The choice you made is to compose a driver package for your distrobution, which is not what you want, you just want to install it.


willrix 01-09-2007 10:32 PM

Excellent, got it installed (I guess, everything went smoothly). However, I still can't scroll smoothly and Desktop Effects is still disabled. This is confounding!

Also, why is it that everything I download makes me install many other things to get it working? I had problems with an FTP program and now I am trying to get WINE set up and evidently WINE has no idea where a C compiler is (although I have gcc on the system). Is this a problem in openSUSE? Should I use a different distro?

JimBass 01-09-2007 10:40 PM

Just installing the driver only gives you the ability to have a pretty picture. You still need to reconfigure the xorg server to have the greater resolution and a few modules to allow smooth scrolling.

Debian has a utility to reconfigure the xserver, and I suspect Suse has one too, I just don't know the name of the command to get it started.

There is no problem with Suse. Changing distros won't help. And generally, avoid wine. There is probably a linux equivalent that will work much better. Trying to run say microsoft office under linux is better accomplished by open office. If you're a gamer, cedega is supposed to be a vast improvement over wine, although I won't know firsthand.

I don't know why wine would have problems looking for the compiler, that is fairly strange.


willrix 01-09-2007 10:49 PM

I did not know about cedega, thanks for the hookup. I want to use Photoshop (SuSE comes with Gimp, but I'm far too used to PS and I use it in my work) so maybe I can find something else. Thanks for all of this; I'm off to find out what xorg server is and how to access/use/open it. Thanks for everything, I'll reply if I have any more problems.

JimBass 01-09-2007 11:06 PM

The config file for me is in /etc/X11/xorg.conf. You'll have to be root to edit that file. You should check and see if Suse has a graphical tool to play with the settings, you'll find that much easier to deal with. Check the Mandriva forums, or the wiki/knowledgebase on the mandriva site.


willrix 01-09-2007 11:58 PM

I have opened the file -- is this the "xorg server"? Also, why do I need to look at the Mandriva sites, I don't run Mandriva Linux (I searched anyway and found nada). In any event, I looked into the config file and I don't see anything having to do with smooth-scrolling modules.

Sorry to break the topic for a moment, but is this what I can expect from working with Linux? The drivers were tough enough and so far I've not been able to install any actual programs. I seem to be missing programs and binaries and compilers and whatever else at every turn. I've been working with this for about 5 hours now and I haven't really been able to do anything. (Also, as I expected, I'm having difficulties with Cedega right out of the gate: What on earth does "umount: /media/STARCRAFT is not in the fstab" mean?).

I'm sure this isn't as irritating for me as it is for you, and thanks for your patience and help, but I'm just so bewildered by this.

JimBass 01-10-2007 12:23 AM

Well man, the module name isn't going to be something like "smooth scrolling". If you have the default driver changed from whatever the default is the whatever the AVI install says it should be, it should be cool.

You don't have to install every single dependency. I forget how backwards windows is! In linux you use the package manager to handle all of that. In Suse, the package manager is Yast. You would simply start yast, and tell it you want it to install whatever program, say football. Then Yast will install every required package to get football to work. It will do all the dirty work. On the Suse forum page, they have Yast repositories to make sure you get access to the most software.

That error message means for some reason it can't eject the starcraft CD. Try issuing the command eject as root, that should do it. You do need to learn new syntax. The programs communicate in a given language, and it isn't what you're used to, so your vocabulary needs to expand a little to deal with it.

I'm sorry about the Mandriva mention. I just got crossed up. You should be looking at the Suse pages, not Mandriva.


trrex 02-13-2007 11:41 AM

Hey will,
I got my ati x200 to do 3d in gnom, cant get it to work in kde. I had gone through so many steps [me = newbie] that when I finally got it to work [using terminal] by hitting "enter" and code zipped through, I jumped for joy and screamed "IT WORKED". My son asked what I did and I answered "I forget, but now I got 3d".
All of us windows converts will soon be suse10.2 programmers by the time we get this os set. I still need to get my wireless working........... I'm past ripping out my hair, got lots of patience and time.

Good Luck, and ty to all that post solutions.

kenbo 03-06-2007 12:14 PM


Originally Posted by JimBass
No, you want to "Install Driver 8.32.5 on Unknown X Window".

The choice you made is to compose a driver package for your distrobution, which is not what you want, you just want to install it.


Actually you do want to create a distro specific package. This makes it much easier to install and uninstall if the need arises.

Your best bet is to follow the steps you find here:

That will get you going nicely!

deloptes 03-31-2007 01:11 PM

There is always problem with the ATI proprietary installer.

This is a discussion that we recently had on:

for me it works perfect ... the patch and the driver installation procedure IS NOT SUSE specific.

best regards

aiman 10-09-2007 02:52 PM

hi every1, aim using a geforce 6100 on AMD athlon, presently working on fc6
, i have installed the driver fr nviddia n its working fyn but i want to enable the desktop effects,plz help me how to go about it. One more thing opotion "Enable Desktop Effects" is missing in the system->prefrences menu, plz help.

aiman 10-09-2007 11:56 PM

hi once again, iam able to enable the 3d effects with help of beryl but the problenm is my mouse pointer is a little jurky to move on screen, it just pauses for a fraction of sec every tym u try to move it, what shud i do plz help.

All times are GMT -5. The time now is 09:08 AM.