LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Installing X (in Gentoo) (https://www.linuxquestions.org/questions/linux-newbie-8/installing-x-in-gentoo-156752/)

n5k 03-12-2004 12:04 PM

Installing X (in Gentoo)
 
Ok...here we go again :D

I decided to install X on my Gentoo 2004.0 box, and so I wrote:

# emerge xfree

The process went on, but when it was done, I discovered some errors:

Quote:

!!! ERROR: x11-base/xfree-4.3.0-r5 failed
!!! Function src_compile, Line 590, Exitcode 2
!!! (no error message)

---- ACCESS VIOLATION SUMMARY ----
LOG FILE="/tmp/sandbox-x11-base_-_xfree-4.3.0-r5-23926.log"

unklink: /xkbtext.o
open_wr: /texteroids.o
unlink: /xditview.o
unlink: /ucs2any
-----------------------------
I am not sure what this is...what should I do? Can I just continue with

# env-update && source /etc/profile

and continue my install/config-stuff?

n5k 03-13-2004 05:35 AM

Ok...I got some help at #gentoo, and emerged another version of xfree.
I got an error saying that I had 22 config-files that needed to be updated. Is this really neccecary? Some people tells me there's no point in doing it...i don't know.

Well anyway. I figured I could do that later, so I continued emerging gnome, but then I got the error x11-libs/gtk+-2.2.4-r1 failed
Hmm...I tried to emerge Xfce4, and got the same error.

How come I get these errors? I've included both gnome and gtk in my USE-variable.

Then I emerged Fluxbox, just to see if that worked, and it did...kind of :)
My resolution won't match.
When I go out to the edges of the screen, I scroll a bit further. That's really annoying. Why is this? I answered "NO" when the xf86config asked me if I wanted a larger virtual screen or whatever...

So...to sum it up:
- Do I need to update the config-files? Why/Why not? How? Must I re-emerge the stuff I've emerged after xfree if I update them?
- How do I fix the gtl-error?
- How do I fix the virtual screen-size-error?
...AND: is there a way to "unemerge" appz that I don't want anymore?

Please don't nag me for asking too many questions :9 I am nothing but a n00bie, trying my best :D


All times are GMT -5. The time now is 06:58 AM.