LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   installing tls (https://www.linuxquestions.org/questions/linux-newbie-8/installing-tls-133807/)

drknow 01-11-2004 07:13 PM

installing tls
 
I have to install tls to run amsn. How do i install it. The files I got (all in /root/tls1.4) were libtls.so, pkgindex.tcl, and tls.tcl. I am using redhat 9. How do I install them or move them to where they will work with amsn.

Thymox 01-11-2004 07:54 PM

The tls.tcl file... set it to executable (chmod +x tls.tcl) and run it... see if that works out.

drknow 01-11-2004 07:56 PM

How do i run it once ive set it to executable?

Thymox 01-11-2004 08:04 PM

./tls.tcl

Do not forget the dot-forwardslash... that tells your console session to run the file tls.tcl from the current directory.

DarkVenger 03-14-2004 07:00 PM

Hello, when I try to make the ./configure for the tls instalation I get

Quote:

configure: error: /usr/local/openssl is not a valid directory
This resolves just by making this directory or I have to point configure to the real directory were I have openssl?? If the last option is the soluction, how do I do that?

Komakino 03-14-2004 08:22 PM

You shouldn't need to install tls manually...when I ran aMsn (the installer version) for the first time it told me it needed it, asked me my architecture and then installed it for me.

DarkVenger 03-15-2004 04:03 AM

It work, I do not knew that aMsn could preform the instalation by it-self

maxstradamus 07-01-2006 08:21 PM

Quote:

configure: error: /usr/local/openssl is not a valid directory
is there any way to fix this manually?

Komakino 07-02-2006 04:39 PM

do
Code:

./configure --help
and see if there is a command you can pass it to tell it the location of openssl

maxstradamus 07-03-2006 12:46 PM

Code:

Configuration:
  --cache-file=FILE      cache test results in FILE
  --help                  print this message
  --no-create            do not create output files
  --quiet, --silent      do not print `checking...' messages
  --version              print the version of autoconf that created configure
Directory and file names:
  --prefix=PREFIX        install architecture-independent files in PREFIX
                          [/usr/local]
  --exec-prefix=EPREFIX  install architecture-dependent files in EPREFIX
                          [same as prefix]
  --bindir=DIR            user executables in DIR [EPREFIX/bin]
  --sbindir=DIR          system admin executables in DIR [EPREFIX/sbin]
  --libexecdir=DIR        program executables in DIR [EPREFIX/libexec]
  --datadir=DIR          read-only architecture-independent data in DIR
                          [PREFIX/share]
  --sysconfdir=DIR        read-only single-machine data in DIR [PREFIX/etc]
  --sharedstatedir=DIR    modifiable architecture-independent data in DIR
                          [PREFIX/com]
  --localstatedir=DIR    modifiable single-machine data in DIR [PREFIX/var]
  --libdir=DIR            object code libraries in DIR [EPREFIX/lib]
  --includedir=DIR        C header files in DIR [PREFIX/include]
  --oldincludedir=DIR    C header files for non-gcc in DIR [/usr/include]
  --infodir=DIR          info documentation in DIR [PREFIX/info]
  --mandir=DIR            man documentation in DIR [PREFIX/man]
  --srcdir=DIR            find the sources in DIR [configure dir or ..]
  --program-prefix=PREFIX prepend PREFIX to installed program names
  --program-suffix=SUFFIX append SUFFIX to installed program names
  --program-transform-name=PROGRAM
                          run sed PROGRAM on installed program names
Host type:
  --build=BUILD          configure for building on BUILD [BUILD=HOST]
  --host=HOST            configure for HOST [guessed]
  --target=TARGET        configure for TARGET [TARGET=HOST]
Features and packages:
  --disable-FEATURE      do not include FEATURE (same as --enable-FEATURE=no)
  --enable-FEATURE[=ARG]  include FEATURE [ARG=yes]
  --with-PACKAGE[=ARG]    use PACKAGE [ARG=yes]
  --without-PACKAGE      do not use PACKAGE (same as --with-PACKAGE=no)
  --x-includes=DIR        X include files are in DIR
  --x-libraries=DIR      X library files are in DIR
--enable and --with options recognized:
  --enable-bsafe  Use RSA BSAFE SSL-C libraries instead of the default OpenSSL l ibraries.
  --with-ssl-dir=DIR  SSL root directory
  enable or disable patented code.  Default is patented code enabled.
  --enable-gcc            allow use of gcc if available [--disable-gcc]
  --with-gcclib        link with libgcc to resolve symbols in a gcc-built opens sl library
  --with-tcl              directory containing tcl configuration (tclConfig.sh)
  --enable-threads        build with threads
  --enable-shared        build and link with shared libraries [--enable-shared]
  --enable-symbols        build with debugging symbols [--disable-symbols]

this is what i get


All times are GMT -5. The time now is 10:35 PM.