LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Installing programs on linux (https://www.linuxquestions.org/questions/linux-newbie-8/installing-programs-on-linux-23017/)

Kompressor 06-09-2002 10:46 PM

Installing programs on linux
 
i just downloaded limewire for linux, and all i have now is a bin file, and i have no idea what to do to install it

rshaw 06-09-2002 10:57 PM

Open a shell and cd (change directory) to the directory where you downloaded the installer. At the prompt type: sh ./LimeWireLinux.bin

Kompressor 06-09-2002 11:20 PM

Thank you so much one last question,is there a helpful guide online to learn all this stuff with the shell, any website anyone knows of

Kompressor 06-09-2002 11:32 PM

Now that i have installed limewire, how do i run it?

willieho 06-10-2002 04:29 AM

Find out what directory the executable is. You might be able to do this by typing "whereis limewire". When it shows you where it is, just type that into the prompt (probably something like "/usr/local/bin/limewire &" or something).

If whereis doesn't work, type "cd /", and then "find . -name limewire" to locate the executable.

Matt Phelps 10-20-2002 12:28 PM

I'm having the same problem here and followed the instructions for sh ./LimeWireLinux.bin but I'm getting this message:

Preparing to install...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...
No Java virtual machine could be found from your PATH
environment variable. You must install a VM prior to
running this program.

I can't find one under PACKAGES to install. Where do I need to go to get one of these!

Mara 10-20-2002 12:44 PM

You can get Java for example from java.sun.com

Matt Phelps 10-20-2002 12:58 PM

OKay I have it and I'm trying desperately to install it. I managed to extract the bin and I now have a RPM file in my home directory.

I get stuck at the bit where I have to 'Uninstall kaffe' with the command 'urpme kaffe' I have no idea what Kaffe is and this doesn't work.

bash: urpme: command not found

Anyway I plowed on and was also stumped by:

Create a file called 'java.sh' as 'root' in '/etc/profile.d' containing these lines:

JAVA_HOME=/usr/java/j2sdk1.4.0
export JAVA_HOME
PATH=$PATH:$JAVA_HOME/bin
export PATH


I can't do this. I am told that 'the file cannot be saved.'

Trying a different tack I double clicked the freshly extracted RPM and it started to look like it was going to install something. Hoping for the best I then tried to install limewire again but got the same message about java not being installed.

I know I'm new with all this but everytime I try and do something I discover it to be hideously complex and even simple how-to guides seem to assume you have a degree in programming! I guess I'll get there in the end....

Mara 10-23-2002 01:34 PM

I guess it's not 'urpme', but 'urpmi'.
The command (JAVA_HOME .... and later) you can simply add to /etc/profile.


All times are GMT -5. The time now is 07:48 PM.