LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-08-2006, 06:14 AM   #1
sgaucho
LQ Newbie
 
Registered: Nov 2002
Posts: 15

Rep: Reputation: 0
Installing Parted


Hi,

I downloaded the latest version of Parted - parted-1.6.10.tar.gz and compiled the same as follows:
#./configure
#make
#make install

On trying to execute Parted, I get the fwg error:

[deli@deli:/opt/software]# /usr/local/sbin/parted
/usr/local/sbin/parted: can't load library 'libparted-1.6.so.0'

What am I missing here ?

thnx,
sg
 
Old 08-08-2006, 10:35 AM   #2
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
Hello,
You should check the LD_LIBRARY_PATH environment variable and locate libparted-1.6.so.0 (with find or locate).
 
Old 08-08-2006, 10:38 AM   #3
sgaucho
LQ Newbie
 
Registered: Nov 2002
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Agrouf
Hello,
You should check the LD_LIBRARY_PATH environment variable and locate libparted-1.6.so.0 (with find or locate).
Meanwhile, I downloaded the parted-1.6.9-3.i386.rpm and executed it and now I get a different error:

libc.so.6: aborted attempt to load /usr/local/sbin/parted!

Guess I screwed up the installation

any ideas on how to resolve this!?

thnx
 
Old 08-08-2006, 10:55 AM   #4
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
make uninstall && rpm -i parted-1.6.9-3.i386.rpm
 
Old 08-08-2006, 11:12 AM   #5
sgaucho
LQ Newbie
 
Registered: Nov 2002
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Agrouf
make uninstall && rpm -i parted-1.6.9-3.i386.rpm

Thanks,

But I still cant run rpm as it already ran once and giving errors on running again...

I tried compiling the tar.gz version but on running it I get the other error:

[deli@deli:/opt/software/parted-1.6.10]# /usr/local/sbin/parted
libc.so.6: aborted attempt to load /usr/local/sbin/parted!

 
Old 08-08-2006, 11:15 AM   #6
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
try :
make uninstall && rpm -e parted-1.6.9-3.i386.rpm && rpm -i parted-1.6.9-3.i386.rpm
 
Old 08-08-2006, 11:16 AM   #7
sgaucho
LQ Newbie
 
Registered: Nov 2002
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Agrouf
try :
make uninstall && rpm -e parted-1.6.9-3.i386.rpm && rpm -i parted-1.6.9-3.i386.rpm
Dont have any rpm -e option:

[deli@deli:/opt/software]# rpm -e parted-1.6.9-3.i386.rpm
rpm: illegal option -- e
BusyBox v1.1.0 (2006.04.01-08:00+0000) multi-call binary

Usage: rpm -i -q[ildc]p package.rpm

Manipulates RPM packages

Options:
-i Install package
-q Query package
-p Query uninstalled package
-i Show information
-l List contents
-d List documents
 
Old 08-08-2006, 11:18 AM   #8
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
You are running BusyBox!
That explains everything.
Which mini distro are you using?
 
Old 08-08-2006, 11:24 AM   #9
sgaucho
LQ Newbie
 
Registered: Nov 2002
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Agrouf
You are running BusyBox!
That explains everything.
Which mini distro are you using?
Yes! glad it explains.. I am running DeLi (www.delilinux.de/)
 
Old 08-08-2006, 11:41 AM   #10
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
"The test computer is a 486 laptop with 16 MB RAM, and all apps which comes with DeLi Linux are running smoothly."
That is impressive.
kernel is 2.2 I saw.

libc.so.6 is for glibc and I think you don't have glibc but uClibc and you need to compile against libc.so.0
 
Old 08-08-2006, 11:45 AM   #11
sgaucho
LQ Newbie
 
Registered: Nov 2002
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Agrouf
"The test computer is a 486 laptop with 16 MB RAM, and all apps which comes with DeLi Linux are running smoothly."
That is impressive.
kernel is 2.2 I saw.

libc.so.6 is for glibc and I think you don't have glibc but uClibc and you need to compile against libc.so.0
argh.. guess I am better off installing another version of linux.. any suggestions of other "Lite" distros !?

thanks,
sg
 
Old 08-08-2006, 11:50 AM   #12
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
You need this patch : cvs.pld.org.pl/SOURCES/parted-uClibc.patch
Apply the patch to the sources and compile again.

Installing another distro is the easy away if you have a strong computer, but have you got one?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I need some help now, using Parted Ofvitinn Linux - Hardware 3 09-19-2004 09:28 PM
Using Parted Mathiasdm Linux - Software 7 08-23-2004 04:10 AM
Using parted jdmml Linux - Newbie 5 07-08-2004 09:39 PM
Can parted do this? szf2 Linux - Newbie 1 10-24-2003 04:03 PM
Installing PARTED problem newbe45 Linux - Software 0 08-13-2003 03:57 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration