LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-10-2002, 12:21 AM   #1
PhilipW
LQ Newbie
 
Registered: Feb 2002
Posts: 3

Rep: Reputation: 0
Installing new sound driver


Caldera Openlinux eDesktop 2.4 detected my soundcard during installation, but I get no sound. My mainboard installation cd has Linux sound drivers. How can I install them to my system?
 
Old 02-10-2002, 08:23 PM   #2
finegan
LQ Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 59
What soundcard do you have?

Really, we need to know what chipset. The drivers will most likely be on your harddrive in /lib/modules/2.2.x/kernel/sound or something like that. From the output of 'lspci' and 'cat /proc/pci' we can figure out what module you need to be using. However, is this an old ISA sound card?

Cheers,

Finegan
 
Old 02-11-2002, 01:37 PM   #3
finegan
LQ Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 59
Funny, there's another thread I'm on with another guy dealing with the Intel 810 mobo built in sound and Debian, but right around the same kernel version, which is all that matters. "uname -i" would tell you the running kernel version. There are 3 modules for the i810 sound somewhere in /lib/modules/2.2.x/misc which pertain to the board. I think you'll need to try:

modprobe i810_audio

I'm pretty certain that's the right module for the job, also, you might need to 'modprobe soundcore' as I don't remember if Caldera made that part of the kernel or not. If it errors, could you post the output?

Cheers,

Finegan
 
Old 02-12-2002, 07:15 PM   #4
PhilipW
LQ Newbie
 
Registered: Feb 2002
Posts: 3

Original Poster
Rep: Reputation: 0
sound problems

Thanks guys my sound problems are fixed. I'm not sure what I did to fix the problem but going into the files you suggested did something & now I have sound.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing sound driver for Intel 865GBF ssprr Linux - Hardware 2 12-16-2008 04:05 AM
help installing sound driver jag Slackware 6 09-16-2004 11:25 PM
after installing modem driver my computer freezes when sound is played! randyriver10 Linux - Software 2 03-12-2004 05:30 PM
I'm having problems installing my sound card driver.. Jedah Linux - Hardware 2 08-31-2003 09:16 PM
RedHat installing wrong driver for sound @ boot peeples Linux - Hardware 3 09-08-2002 12:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration