-   Linux - Newbie (
-   -   Installing my first program (

thort 12-18-2003 09:16 AM

Installing my first program
I'm new to Linux and now I'm trying to install my first program. It's a game by the name Frozen Bubble.

The install instruction reads as follows:


SDL_mixer >= 1.2.2

SDL perl >= 1.19.0

If you compile by hand, double-check you first compile SDL, then SDL_image
and SDL_mixer, then SDL perl, otherwise you might get the error that is not found.

Installation instructions

[*] First, build Frozen-Bubble and provide the prefix where the
game will be installed (most probably /usr or /usr/local).

make OPTIMIZE="my_arch_opt_flags" PREFIX="my_prefix"

[*] Second, install the files on the system.

- if you're root (case when you build a Debian package, or
when you build it locally on your own machine), you will
choose the same prefix location than for previous step

make install PREFIX="my_prefix"

- if you're not root (case when you build a RPM package), you
need to install to a temporary directory where you have
write access

make install PREFIX="/home/my_home/tmp/my_buildroot"

Then an external program such as RPM will collect the
installed files and write the package.

My first attemp to install ends up whith this:

[thor@localhost Frozen Bubble]$ make
Can't locate in @INC (@INC contains: /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 .) at -e line 1.
BEGIN failed--compilation aborted at -e line 1.

*** I need perl-SDL installed
make: *** [dirs] Error 1

Excuse me for knowing so little. But I would be thankful if someone could help me come a bit further, and if I would succeed in installing this program I would be very glad.

bigjohn 12-18-2003 09:52 AM

I've never really played with redhat much, but presuming that you've got the disc's that you installed from, I'm thinking that there must be a software manager facility of some kind (with mandrake it's within a facility called the mandrake control centre - which isn't the kde control centre, if you're using kde).

I am then thinking that if you could find that, you should be able to find a subcategory for either "available packages/software" or even games. If so, then just go down the list and see if you can either find the frozen buble game or just install all the available games.

That's one way.


go to google's linux section and search for "frozen bubble+rpm", I had a look and came up with this which as far as I can tell, is the very latest version ( just look at the date ) and it seems to be a redhat rpm (some rpm app's are distro specific - if it's got mdk in the title then it's a mandrake rpm, suse rpm's are obvious, they usually have either suse in the title or there's a bit that mentions that the package is for suse, and so on, if you stay with redhat, then you need the ones for redhat 9).

If you download that, then you SHOULD, be able to just click on it and it should install (though it's possible that you will either get a prompt to put in your root password, or, it will say that you have to be root to install.

You could also search LQ for install or installing, stuff like that, because there's more than one way (there's also the different systems for the different types of distro i.e. rpm = redhad, mandrake, SuSE, etc there's apt-get = debian, knoppix and other debian based distro's, gentoo uses "portage" (but then again, I'm still learning how to configure my gentoo - a total f****r :D) Slackware has some other ways - or of course there's the dreaded "tarball" method, which seems to be pretty common to most distro's - a command line install, that you'd need to read up on).

As a suggestion, IMO, redhat isn't as suitable for a mega n00b, it's more directed towards commerce/business, though lots of peoople do get on with it Ok, I would suggest that you try mandrake, as it's more desktop orientated, and I feel more n00b friendly - plus if you've only just got used to getting away from windows, you can also get some easy to install mega eye candy to be looking into.




thort 12-18-2003 11:17 AM

Thanks John !


go to google's linux section and search for "frozen bubble+rpm", I had a look and came up with this which as far as I can tell, is the very latest version ( just look at the date ) and it seems to be a redhat rpm
I downloaded the rpm-file found in your link, and tried to doubleclick it. This error message occured: rpm.png

Then I tried the prompt and got this message:

[thor@localhost Frozen Bubble]$ rpm -i --test
warning: V3 DSA signature: NOKEY, key ID e42d
error: Failed dependencies:
perl(SDL) is needed by
perl(SDL::App) is needed by
perl(SDL::Cursor) is needed by
perl(SDL::Event) is needed by
perl(SDL::Font) is needed by
perl(SDL::Mixer) is needed by
perl(SDL::Surface) is needed by
perl-SDL >= 1.19.0 is needed by
[thor@localhost Frozen Bubble]$

How do I go on solving this?

XavierP 12-18-2003 01:57 PM

Did you run it as root?

I think your best bet would be to obtain Apt4RPM.

That way you just need to type in (as root) apt-get install frozen bubble and it will install all of your needed dependencies. If your first install is Synaptic, you get a graphical interface for apt-get.

su (then enter)
enter root's password
apt-get install synaptic (then hit enter)

and lo, problem solved!

thort 12-18-2003 04:34 PM

Thanks XavierP !


Did you run it as root?
No, but trying to do so makes no difference. The same error messages.


I think your best bet would be to obtain Apt4RPM.
I have downloaded Apt4RPM.

Doubleclicking directly on the file gives this result: error.png

Trying to install Apt4RPM on the command line gives this result:

[thor@localhost thor]$ su
[root@localhost thor]# cd /home/thor/Program/apt4rpm
[root@localhost apt4rpm]# rpm -i --test apt4rpm-0.65.3-0.noarch.rpm
error: Failed dependencies:
apt-server is needed by apt4rpm-0.65.3-0
perl-XML-LibXML is needed by apt4rpm-0.65.3-0
[root@localhost apt4rpm]#

I would appreciate some more assistance.

What is wrong?

How do I solve this?

bigjohn 12-18-2003 04:49 PM

XavierP is correct, when I was playing with debian based knoppix on a hard disc install, the "apt-get" system used by debian based distro's seemed better/easier to use.

And what XavierP is explaining is a way of installing the debian "apt-get" system onto your redhat "rpm" based system. IMO the "apt-get" system is better than rpm, but because I'm still suffering "growing pains" (read that as stress) of learning how to install and use a gentoo system as well, my mandrake default's will have to suffice (erm, I seem to recall that frozen bubble is a mandrake default, either that or it's a "cinch" to install it via the software manager called "rpmdrake" available as a default in mandrake) it's up to you.

Personally, I would try installing mandrake, cos if you just search for "frozen bubble" a lot of the info seems to originate from mandrake (hence the mdk identifier of the available rpm's), plus as I said, it's more "desktop and n00b" oriented - if you had a look at the plf and texstar , they both have lots of unofficial packages for mandrake, and between then and mandrake official sources, there's shit loads of linux games that you could install and have a play with - I've been getting into amphetamine recently, I'm sure it's available for redhat 9 as well, but it's been sooooo easy to install it under mandrake.

So, that's the "sales pitch", if youlook at the "failed dependency" problem that got "thrown up" you will see that as with the first one, it is lacking the "Perl" application. I don't know much about any of that kind of stuff (I'm basically just a "user" who doesn't want to use MS app's), but if you installed the perl facilities that should be on your install disc's (again presuming that there's some sort of software manager), you should be able to install the perl problem and then try re-installing the frozen-bubble rpm (try doing it as root - if you open konqueror or whatever as root, then navigate it to /home/thor/ -whatever your home directory for user is called, then if that's where you downloaded the frozen-bubble rpm too, you are then effectively root, looking into your user account and telling it to do something).

sorry I can't advise you about doing it via the CLI, but even after 2 or so years of meddling with linux, I've still got too much windows shit sloshing around in my brain, and in any case, what I know about CLI, you could write on the back of a very small postage stamp :D




XavierP 12-18-2003 04:55 PM

the apt server can be obtained from the same place as apt4rpm. The perl module can be obtained from either Redhat or rpmfind.

Install perl, then aptserver then apt4rpm and hopefully that should be the last you ever see of rpm dependency hell.

Hangdog42 12-18-2003 04:58 PM

The error messages you're getting are telling you that you haven't properly install the SDL perl module. You can download that module at CPAN. Unpack the file you download, then follow the installation instructions that are in the directory that is created when you unpack. Note that you have to be root or su to do the make install.

Of course you have to have perl installed in the first place (you probably do but you might want to check). You can check that with a simple perl -version in a console.

thort 12-19-2003 02:43 PM

Thanks everyone for helping me !

This installation seems to complicated to me.

I give it up and I'm seriously thinking about follow Bigjohns advice to install Mandrake instead of Red Hat.

Once again, Thanks ! :)

Hangdog42 12-19-2003 03:23 PM

Installing Mandrake is a pretty extreme solution to not being able to compile Frozen Bubble. I mean, if you have reasons to install OTHER than Frozen Bubble, then fine. Mandrake is a bit easier on new users, but if your RH system is up and running, getting Frozen Bubble to run isn't that much of a hassle.

thort 12-19-2003 03:54 PM

Hi Hangdog !


but if your RH system is up and running, getting Frozen Bubble to run isn't that much of a hassle
I appreciate your concern. But I'm confused by all these "perl", "apt" and "apt4rpm". It seems to complicated for me to manage to install all these packages just to succed in installing Frozen Bubble. I will make a brake whith this installation. Things must be pleasant. This is a hobbie, not a hard work.


Installing Mandrake is a pretty extreme solution to not being able to compile Frozen Bubble
Maybe you are right.

All times are GMT -5. The time now is 05:07 PM.