LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Installing LISA by a simple mind = possible? (https://www.linuxquestions.org/questions/linux-newbie-8/installing-lisa-by-a-simple-mind-%3D-possible-410590/)

rdekruif 02-01-2006 06:34 PM

Installing LISA by a simple mind = possible?
 
Hello all,
Here another question from a simple newbie that is exploring linux and wants all at the same time..... ;-)
I have an installed version of knoppix 4.0 on HD and am trying to get to know this interesting phenomena.
Ofcourse I want it to work seamlessly with my existing XP network so i run into some problems.
To start I want to access the network, xp-pc's and the printer attached to one of them.

The first... i can not install the printer attached to an XP-pc, tried smb but it fails at some password problem while i tried every known password of that pc..... any idea?

Then browsing the network.... Ofcourse a bad idea because MS has some complicated ideas about that. I foundout that I should use LISA. So I downloaded her and after an evening searching and trying i found that i should do ./CONFIGURE then MAKE then MAKE INSTALL then MAKE CLEAN...... Okay, fine, works good so far.
Then the script ends with a remark that i should add something to some path............. You lost me friend!!:study:

The path mentioned in the installation section of the website mentions /ETC/RC.D/RC.LOCAL and that does not exist on this calculation wonder. Something i missed?

Can anybody with a lot of patience start to help?
Lets assume that I am one types that holds the mouse against the screen when prompted by software.....my programming skills are from 15 years ago so this linux is total magic so far.

I have so many other questions but decided to tackle each problem as one at a time.

Thanks for your understanding and time!!

Have a nice day! :newbie:

bosewicht 02-01-2006 07:08 PM

that was telling you to start lisa at boot time add /opt/kde/bin/lisa -q to /etc/rc.d/rc.local. it would have prob been easier for you to apt-get install lisa, but anyways on debian based distros, i think it is /etc/init.d/rc.local

JimBass 02-01-2006 08:31 PM

Debian does not have an rc.local file in /etc/ or /etc/init.d/. You need to make use of one of the ways to autostart the program. I see that LISA is installable by apt-get, that would have been much easier, but it is always good to learn how to compile your own software and get it working like you want. The shortcut for getting LISA to start would be to create a symbolic link to the LISA executable file in ~/.kde/Autostart/. That would only work when you sign in under the username of the account you created the symbolic link from. Another way to do it is to use the command update-rc.d. That is good, but I believe for that to work, you need to have a start/stop file in /etc/init.d/. You may have the option of creating a file like /etc/init.d/lisa in the installation of lisa. Read all the docs, and find out if that file exists. If /etc/init.d/lisa exists, then just doing something like:
Code:

update-rc.d lisa start 75 2 3 4 5 .
should start lisa for all users anytime the system is booted.

Peace,
JimBass


All times are GMT -5. The time now is 11:58 AM.