LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Installing HTOP. (https://www.linuxquestions.org/questions/linux-newbie-8/installing-htop-4175466623/)

adumith 06-19-2013 12:06 PM

Installing HTOP.
 
Hello everyone;

Im try to install the HTOP app, this one is for server monitoring.

The step to install it are:
1.-
Code:

wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.x86_64.rpm
2.-
Code:

rpm -ihv rpmforge-release*.rf.x86_64.rpm
Whats wrong?
The problem is when I run the secod step, the server return to me this error:
Code:

error: Failed dependencies:
        rpmlib(FileDigests) <= 4.6.0-1 is needed by rpmforge-release-0.5.2-2.el6.rf.x86_64
        rpmlib(PayloadIsXz) <= 5.2-1 is needed by rpmforge-release-0.5.2-2.el6.rf.x86_64

Can you help me to resolved it?

Thanks in advance.

TB0ne 06-19-2013 12:21 PM

Quote:

Originally Posted by adumith (Post 4974838)
Hello everyone;
Im try to install the HTOP app, this one is for server monitoring. The step to install it are:
1.
Code:

wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.x86_64.rpm
2.
Code:

rpm -ihv rpmforge-release*.rf.x86_64.rpm
Whats wrong? The problem is when I run the secod step, the server return to me this error:
Code:

error: Failed dependencies:
        rpmlib(FileDigests) <= 4.6.0-1 is needed by rpmforge-release-0.5.2-2.el6.rf.x86_64
        rpmlib(PayloadIsXz) <= 5.2-1 is needed by rpmforge-release-0.5.2-2.el6.rf.x86_64

Can you help me to resolved it?

First, what version/distro of Linux are you running, and what version of htop??? The latest version of rpmforge is 0.5.3-1 for Red Hat/CentOS 6, so you're installing an old version. Second, why are you using the rpm command, rather than "yum install <package name>", which will resolve dependencies for you? And the messages are clear...the package you're trying to install, requires version numbers <= what you already have. So, installing the latest package will probably work.

And more importantly, if you had looked at the htop webpage, you can enable the EPEL repository, which has htop already in it.

acid_kewpie 06-19-2013 12:23 PM

kind of helps if you tell us what system you're doing this on. it should go on fine with centos or rhel 6, so I'm presuming it's not that. At the same time though, that's not the latest release file, so get the 0.5.3 version instead - http://pkgs.repoforge.org/rpmforge-release/ I would also recommend installing it with yum, not rpm directly as that will resolve any possible dependencies for you automatically - "yum localinstall whatever.rpm"

Also, note that your question has *nothing* to do with htop itself, so your title was less than ideal.

adumith 06-19-2013 03:58 PM

I am very ashamed with you because I have bothered without having made prior research.
The problem is that the version that I have installed Centos on my server is 5 and I tried installing the HTOP for version 6.

Again I ask you to please forgive me.

Now I just have learn to use the HTOP.

Thanks a lot to everyone.


All times are GMT -5. The time now is 10:46 AM.