LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   installing GRUB (https://www.linuxquestions.org/questions/linux-newbie-8/installing-grub-77319/)

Interceptor 07-30-2003 11:00 AM

installing GRUB
 
HELP!!!!!!!!!!!!!
I am terribly confused, I've read through the GNU GRUB manual, three different magazine tutorials (Linux Journal, Linux Format, Linux Magazine {i think it was}), an article titled: GRUB in Debian HOWTO (linuxorbit.com), and lastly, www.linuxgazette.com/issue64.
Darn, I'm still confused, so I'll ask for help here.
This is a new machine with just being brought up:
Tyan S2468UGN m/b, 2@ AMD Athlon 2400+ MP, 1gig registered ram, 5@ Quantum Atlas III 18.2g scsi hd's, etc....
Hard drives appear (Linux) as: sda-sde
Just installed Debian 3.0r1 on sde. Partition table for sde:
sde1 /boot: sde2 /: sde5 /home: sde6 /usr: sde7 /var: sde8 swap: sde4 swap.
lilo installed into sde1 (boot) which of course means that I need to use a floppy to boot, which I made at install. Yes it boots just fine (X is a royal mess but that will be sorted later , when I compile a kernel with smp etc..). Okay so far, so I setup APT and install aptitude and do the apt-get install grub.
My confusion is as to how to proceed to install grub into the MBR of the first (sda) hard drive and still use my /boot partition (sde1) to boot from. I am thinking that grub-install (hd0,0) will get it on the MBR, but I need to somehow tell grub that sde1 (hd4,0)=/boot and that root of the Linux installation is sde2 (hd4,1). I think that is what needs to be done. Am I correct or muddled as I fear?
If that is correct what commands do I use. Also, I notice that the GRUB Manual seems to indicate the the grub-install command is not to be trusted, so I assume that installing from the grub command prompt is the preferred method? Sorry this is so wordy. tia, matt

youngstorm 07-30-2003 04:35 PM

Hi,
While I can't answer your question, I can send your here .
Try sending your question to them if you have not already.
Sorry I can't do more.

Interceptor 07-30-2003 06:47 PM

Thank you, but I don't think my difficulty understanding the proper configuration that I need should qualify as a "bug".

captainstorm 07-31-2003 02:05 AM

You've already installed LILO? Where did you install it? Which partition is your boot partition?

/////////from redhat.com RH9 reference guide
The following command installs GRUB to the MBR of the master IDE device on the primary IDE bus: /sbin/grub-install /dev/hda

youngstorm 07-31-2003 11:20 AM

go here. http://www.gnu.org/software/grub/
scroll down to the topic "Contact us" then read the 6th paragraph.


All times are GMT -5. The time now is 09:05 PM.