LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-30-2016, 06:55 PM   #1
zillur
Member
 
Registered: Apr 2015
Posts: 217

Rep: Reputation: Disabled
Installing gridengine in centos 7


Hi there,
I was trying to install gridengine in my centos 7 server. I have downloaded all the rpm files and run
Code:
yum install *.rpm
Code:
gridengine-8.1.8-1.el6.x86_64.rpm            gridengine-execd-8.1.8-1.el6.x86_64.rpm    gridengine-qmon-8.1.8-1.el6.x86_64.rpm
gridengine-debuginfo-8.1.8-1.el6.x86_64.rpm  gridengine-qmaster-8.1.8-1.el6.x86_64.rpm
Then I installed the gridengine running sripts at /opt/sge ;
Code:
install_execd  install_qmaster  inst_sge
And finally got:
Code:
/home/zillur/Desktop/zillur/phd/gridengine/sge
[zillur@genomics sge]$ ps -ef | grep sge
zillur   17809  8994  0 19:50 pts/45   00:00:00 grep --color=auto sge
zillur   29491     1  0 Dec29 ?        00:00:29 /opt/sge/bin/lx-amd64/sge_qmaster
zillur   30216     1  0 Dec29 ?        00:00:20 /opt/sge/bin/lx-amd64/sge_execd
But if I run qsub:
Code:
bash: qsub: command not found...
If I want to restart the daemon:
Code:
[zillur@genomics sge]$ service sgeexec.p6444 stop && sgeexec.p6444 start
Redirecting to /bin/systemctl stop  sgeexec.p6444.service
Failed to stop sgeexec.p6444.service: Unit sgeexec.p6444.service not loaded.
Any help with the installation?

Best Regards
Zillur
 
Old 12-30-2016, 07:22 PM   #2
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 4,237

Rep: Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653
What do you get if you:

Code:
cd /opt/sge
find . -name qsub*
systemctl list-unit-files | grep sge
 
1 members found this post helpful.
Old 12-30-2016, 07:40 PM   #3
zillur
Member
 
Registered: Apr 2015
Posts: 217

Original Poster
Rep: Reputation: Disabled
Thank you very much for your reply. Here is the output:
Code:
[zillur@genomics ~]$ cd /opt/sge/
[zillur@genomics sge]$ find . -name qsub*
./man/man1/qsub.1
./bin/lx-amd64/qsub
[zillur@genomics sge]$ systemctl list-unit-files | grep sge
[zillur@genomics sge]$
The last command didn't give anything. Thanks again.

Best Regards
Zillur
 
Old 12-30-2016, 08:29 PM   #4
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 4,237

Rep: Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653
Ok. Lets find the name of the service file that was supposed to be installed and its filename.

Code:
for p in $(rpm -qa | grep gridengine); do
rpm -ql $p | grep service
done
 
1 members found this post helpful.
Old 12-30-2016, 09:17 PM   #5
zillur
Member
 
Registered: Apr 2015
Posts: 217

Original Poster
Rep: Reputation: Disabled
Thank you very much for your reply. Here it is:
Code:
[zillur@genomics sge]$ for p in $(rpm -qa | grep gridengine); do
> rpm -ql $p | grep service
> done
/opt/sge/util/rctemplates/systemd/sgeexecd.service
/opt/sge/util/rctemplates/systemd/sgemaster.service
/opt/sge/util/rctemplates/systemd/sgeshadowd.service
Best Regards
Zillur
 
Old 12-30-2016, 10:03 PM   #6
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 4,237

Rep: Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653
Ok so lets add /opt/sge/bin/lx-amd64/ to the system path,. you can do this by user(add to .bash_profile) or system wide(add to /etc/environment).

Code:
echo "PATH=$PATH:/opt/sge/bin/lx-amd64/" >> /etc/environment
or
echo "PATH=$PATH:/opt/sge/bin/lx-amd64/" >> /home/YOURUSER/.bash_profile
Log out, log back in. 'qsub' should work as a command now.

And then use the correct systemd service to start, which looks to me like sgemaster, but might be one of the others according to your output above:

Code:
systemctl start sgemaster
systemctl status sgemaster

Last edited by szboardstretcher; 12-31-2016 at 02:05 PM. Reason: change semicolon to colon :/
 
1 members found this post helpful.
Old 12-31-2016, 12:25 AM   #7
zillur
Member
 
Registered: Apr 2015
Posts: 217

Original Poster
Rep: Reputation: Disabled
Thank you very much. Here is current situation:
Code:
[zillur@genomics ~]$ echo "PATH=$PATH;/opt/sge/bin/lx-amd64/" >> /home/zillur/.bash_profile
[zillur@genomics ~]$ logout 
Connection to 136.145.231.38 closed.
MacBook-Pro-55:final_project ZILLURRAHMAN$ sudo ssh zillur@136.145.231.38
zillur@136.145.231.38's password:
Last login: Sat Dec 31 01:15:02 2016 from 67.224.154.165
-bash: /opt/sge/bin/lx-amd64/: Is a directory
[zillur@genomics ~]$ qsub
bash: qsub: command not found...
[zillur@genomics ~]$ systemctl start sgemaster
==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===
Authentication is required to manage system services or units.
Authenticating as: Zillur (zillur)
Password: 
==== AUTHENTICATION COMPLETE ===
Failed to start sgemaster.service: Unit not found.
[zillur@genomics ~]$ systemctl status sgemaster
Unit sgemaster.service could not be found.
Then again:
Code:
[zillur@genomics ~]$ echo "PATH=$PATH;/opt/sge/bin/lx-amd64/" >> /etc/environment
-bash: /etc/environment: Permission denied
[zillur@genomics ~]$ sudo echo "PATH=$PATH;/opt/sge/bin/lx-amd64/" >> /etc/environment
-bash: /etc/environment: Permission denied
[zillur@genomics ~]$ sudo echo "PATH=$PATH;/opt/sge/bin/lx-amd64/" >> /etc/environment
-bash: /etc/environment: Permission denied
[zillur@genomics ~]$ su
Password: 
[root@genomics zillur]# echo "PATH=$PATH;/opt/sge/bin/lx-amd64/" >> /etc/environment
[root@genomics zillur]# exit
exit
[zillur@genomics ~]$ logout 
Connection to 136.145.231.38 closed.
MacBook-Pro-55:final_project ZILLURRAHMAN$ sudo ssh zillur@136.145.231.38
zillur@136.145.231.38's password: 
Last login: Sat Dec 31 01:16:36 2016 from 67.224.154.165
-bash: /opt/sge/bin/lx-amd64/: Is a directory
[zillur@genomics ~]$ qsub
bash: qsub: command not found...
[zillur@genomics ~]$ systemctl start sgemaster
==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===
Authentication is required to manage system services or units.
Authenticating as: Zillur (zillur)
Password: 
==== AUTHENTICATION COMPLETE ===
Failed to start sgemaster.service: Unit not found.
What should I do now?

Best Regards
Zillur
 
Old 12-31-2016, 08:56 AM   #8
MadeInGermany
Senior Member
 
Registered: Dec 2011
Location: Simplicity
Posts: 1,288

Rep: Reputation: 591Reputation: 591Reputation: 591Reputation: 591Reputation: 591Reputation: 591
There was a mistake in the advice given. Should have been
Code:
echo "PATH=$PATH:/opt/sge/bin/lx-amd64/"
Please change the semicolon to a colon! (with a text editor)
 
1 members found this post helpful.
Old 12-31-2016, 01:56 PM   #9
zillur
Member
 
Registered: Apr 2015
Posts: 217

Original Poster
Rep: Reputation: Disabled
Thank you very much. I think bash_profile related problem is solved. Now I have another problem:
Code:
Unable to initialize environment because of error: Please set the environment variable SGE_ROOT.
Exiting.
99 jobs submitted as array task
Job ID:
Thank you again. What should I do now?

Best Regards
Zillur
 
Old 12-31-2016, 02:07 PM   #10
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 4,237

Rep: Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653Reputation: 1653
You are going to have to read about the gridengine and how it works to decide where to put SGE_ROOT, i cannot do that for you. http://gridscheduler.sourceforge.net...e_shadowd.html

Setting it is as easy as the PATH variable, just throw it in bash_profile like:

SGE_ROOT=/some/path
 
1 members found this post helpful.
Old 12-31-2016, 05:41 PM   #11
MadeInGermany
Senior Member
 
Registered: Dec 2011
Location: Simplicity
Posts: 1,288

Rep: Reputation: 591Reputation: 591Reputation: 591Reputation: 591Reputation: 591Reputation: 591
I guess it is
Code:
export SGE_ROOT=/opt/sge
to be added to the bash_profile as well.
 
1 members found this post helpful.
Old 01-04-2017, 03:33 PM   #12
zillur
Member
 
Registered: Apr 2015
Posts: 217

Original Poster
Rep: Reputation: Disabled
Thank you very much for your kind suggestions. after
Code:
export SGE_ROOT=/opt/sge
I got a new problem. Here it is:
Code:
[zillur@genomics idmapping]$ perl split_blast_queries_edwardsSteve.pl -f /home/zillur/Desktop/zillur/phd/orthofinder/fasta/PlasmoDB-28_Pfalciparum3D7_AnnotatedProteins.fasta -db /home/zillur/Desktop/zillur/phd/blast/blast/db/nrdb -d output/ -n 100
Unable to run job: denied: host "genomics.rrp.campus" is not submit host
Exiting.
99 jobs submitted as array task
Job ID:
Here is my host:
Code:
[zillur@genomics idmapping]$ hostnamectl status 
   Static hostname: genomics
         Icon name: computer-server
           Chassis: server
        Machine ID: ****
           Boot ID: &*****
  Operating System: CentOS Linux 7 (Core)
       CPE OS Name: cpe:/o:centos:centos:7
            Kernel: Linux 3.10.0-514.2.2.el7.x86_64
      Architecture: x86-64
What should I do now?
Best Regards
Zillur
 
Old 01-04-2017, 04:37 PM   #13
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,465

Rep: Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605
you are aware that this is a CentOS 6 ( el6) rpm on CentOS 7 !

this will likely cause major problems
one being rhel6 uses systemV and rhel7 uses systemD

use the cent7 rpm ( el7 )

Last edited by John VV; 01-04-2017 at 04:38 PM.
 
1 members found this post helpful.
Old 01-04-2017, 04:58 PM   #14
zillur
Member
 
Registered: Apr 2015
Posts: 217

Original Poster
Rep: Reputation: Disabled
Thank you very much for your comments. How can I get el7 rpms? I got the latest rpm from here:
Code:
https://arc.liv.ac.uk/downloads/SGE/releases/8.1.9/
Best Regards
Zillur
 
Old 01-04-2017, 05:08 PM   #15
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,465

Rep: Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605
grab the source and build it

rhel6 and rhel7 ( or centos and sl ) are VERY VERY different operating systems
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Disabled ACPI while installing CentOS; now CentOS only uses 1 of 4 cores ChaoticShiny CentOS 5 05-26-2015 08:49 AM
combining servers (gridengine) best practice advice Reignfire Linux - Server 0 10-19-2012 09:44 AM
[SOLVED] Java access to Xhost on Gridengine markdibley Linux - Server 0 06-03-2011 01:32 PM
GridEngine cluster fatra2 Linux - Software 0 01-07-2010 10:54 AM
Installing R on CentOS 4.5 vital_101 Linux - Software 1 10-16-2007 11:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration