-   Linux - Newbie (
-   -   Installing Glib, ATK, GTK, Pkg Config, and Pango! (

LinuZ 07-26-2003 11:17 PM

Installing Glib, ATK, GTK, Pkg Config, and Pango!
Hey everyone. I have yet, another problem. I never liked the Kit AIM client, so I decided to download and install, "gaim". I went to and downloaded gaim. I started to install it, and it said I needed, "gtk". So, I downloaded it, and started to install it through Konsole. I need, "atk". Woo! And It doesnt say where atk is exactly, I think it means I have to create a directory somewhere :confused: I am running Mandrake 9.1.

I thought the error I'm getting when installing, "gtk" may help, so hear it is.

checking for pkg-config... /usr/bin/pkg-config
checking for glib-2.0 >= 2.1.4 atk >= 1.0.1 pango >= 1.0.1... Package atk was not found in the pkg-config search path.
Perhaps you should add the directory containing `atk.pc'
to the PKG_CONFIG_PATH environment variable
No package 'atk' found

Thanks a lot,

padlamoij 07-26-2003 11:35 PM

atk is an accesibility library to gtk. its should be a package. i don't use mandrake and the only reason i'm chirping up is that no one else seems to. and i don't really know where you get RPM's from when you use mandrake. probably who knows anyhow...

MasterC 07-27-2003 12:03 AM

Your install CD's:
urpmi gaim

Sorry, to clarify the above:
Open up a terminal, and as root type that in.

OR, if you are gung ho, you could go about getting the source of all the required apps and compiling them (I actually did this all for GTK2 the other night, it's not horribly bad if you know what you are doing, but it is surely time consuming).


End11 10-16-2003 10:17 PM

hmm i had the same problem, and did what master c said. got all the sources, installed them all through console (doing something wrong?) but when i went to install gtk2 it still said i didn't have atk. even though i just installed it, and can find the files it seems to be looking for....
is it possible i need to remove old versions first? i'm something of a newb. anyway this is what i get:
checking for glib-2.0 >= 2.1.4 atk >= 1.0.1 pango >= 1.0.1... Package atk was not found in the pkg-config search path.
Perhaps you should add the directory containing `atk.pc'
to the PKG_CONFIG_PATH environment variable
No package 'atk' found

configure: error: Library requirements (glib-2.0 >= 2.1.4 atk >= 1.0.1 pango >= 1.0.1) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

i certainly didnt change any of the default directories, and i found a file called atk.pc in /usr/local/lib/pkgconfig . do i need to adjust PKG_CONFIG_PATH ? what is that and how do i go about it?

anyway im running mandrake 9.2, and im a newb although not a complete moron (i like to think)

thanks for any help

Jefklak 10-23-2003 01:02 PM

edit your .bashrc file in /home/~

add "export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig"

And it's fixed :)

kaega2 10-25-2003 02:32 AM

All fixed is a very generalize term

Thank you jefklak, i did what you said and it now see's that I have glib 2.2.3. But, probably because of me trying to install glib so many times, it now also see's glib 2.2.1 as well at the same time

*** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.2.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files

Do you happen to know how to remove this program. I'm new to linux, so any help you can give is helpful. (I'm also very tired at the moment, so it's possible that I may figure it out myself)

kaega2 10-25-2003 02:34 AM

I must also add, I've searched for what's on my hard disk. I've found many files and directories for glib 2.2.3 but none for 2.2.1. So I'm convinced that pkg-config is correct

Jefklak 10-25-2003 04:31 AM

If it was an RPM, you can simply "deinstall" it using the command RPM -e [packagename], for example "rpm -e glib-2.2.1". If you don't know what the name of your package is, you can search/grep for it, using the command "rpm -qa | grep glib" and check the output.

If it was a TAR/GZ (source code) and you installed it by using make install, I don't think there's another option than removing all files made by the install script manually. In the /usr/local/lib/pkgconfig is usually a file called "glib-x.x.x" where x is your version. You should have 2 files, remove the oldest version and the installer won't detect your old glib (but it's still installed, so you should back the file up in case you need it for later or so)

pibby 10-26-2003 07:05 AM

I'm having the same problem when trying to install Gaim 0.71

checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.2.0, but GLIB (2.2.1)
*** was found!

I tried your last suggestion, here were the results:
[pibby@localhost pibby]$ rpm -qa|grep glib

I also tried going in to find the files manually and this is what is there in /usr/local/lib:
glib-2.0 Directory, pkgconfig Directory, and a bunch of and .so files

pkgconfig Directory has one file resembling "glib-xxx" which is glib-2.0.pc
Also in your last post you suggested removing the older of the glib files, however for some reason I only have one.

Why must it be so difficult just to be able to use a multi-protocal chat client.... *sigh*

kaega2 10-26-2003 02:58 PM

I just recently erased my drive and reinstalled mandrake. I setup to install glib first and it still gave me the same error. So I'm thinking it's either something that comes with the OS or a bad install file.

All times are GMT -5. The time now is 05:02 AM.