LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-28-2004, 04:20 PM   #1
smoerre
LQ Newbie
 
Registered: Apr 2004
Posts: 1

Rep: Reputation: 0
Installing GDlib2 on php4 not working


Hi,

Im using linux for a few days now and I found many helpful hints on this forum to get me started quite quickly. Thanks to everybody. Unfortunately there is still a very long way for me to go.

So far I managed to set up a distribution with apache1.3, mysql3.2 and php4.3 and I was quite happy to see my php-project I started on a windows-installation running well on it, only imagecreatefromjpeg() made a boo boo and why? Because I forgot GDlib2.

I didnt know it should be compiled and installed together with php and that I would run into that kind of problems when doing it later. (On windows it is just removing an asterisk in the ini-file to activate it.) So trying to install it was the beginning of a wonderful nightmare.

Im getting so frustrated at the moment, I need a little help or hint from a kind person to keep me going. I have absolutely no idea how to get GDlib working and Im stuck searching the internet for a clue.

I compiled and installed the most recent versions of zlib, pnglib, jpeg6b and freetype, then I compiled gd2 with the just installed modules as options, then php again --with-gd=/path --with-zlib=/path, etc. and all this worked with no errors. At least with no reported errors from the scripts.
"Configure" and "make" both found the GD-components and mentioned their presence positive, only "make install" kept the same output with or without previously using --with-gd. I did "make distclean", but the "make install" for php still comes up with mostly "already installed"-messages.

Im stuck with phpinfo not showing the gd section and GD not installed properly. Everything else is still running fine, just like before trying the GD-thingy. I did the above installation again, this time with the gd-folder from php4 instead of the downloaded version, no difference.

Maybe it didnt work because php was already installed and some components are now in the way? What do I have to delete to really reinstall it? Or do I think in the wrong direction? I can only guess and hope someone knows...

Thanks for reading all this, I would really appreciate some help. And sorry if I seem a little confused...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Postgresql and PHP4 not working on Debian tomj88 Linux - Software 4 10-12-2005 09:43 PM
Installing PHP4 saf4 Linux - Software 1 09-22-2005 08:44 AM
PHP4 not working with Apache2 in Mandrake 10.1 eikeland Linux - Software 2 01-17-2005 08:06 PM
HELP!!! PHP4.3.9 With Apache2 Not Working.. NEED ASSESTANCE eech55 Linux - Software 1 10-14-2004 08:19 AM
Installing php4 mindstormsguy Linux - Software 0 05-29-2003 06:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration