-   Linux - Newbie (
-   -   Installing from USB (

Asinine 09-13-2009 03:42 AM

Installing from USB
Hey all. I'm having a lot of issues with this; I've already followed four separate methods only to find out (usually after I'm almost done) that something I don't have is required (NSF), or the method I chose doesn't work (unetbootin).

I want to install Slackware 13 with nothing but a usb stick and the destination sd drive. I have a desktop I can load it all up with, but on the destination laptop, all I have to work with will be the 8gb usb (and the destination drive). I won't have an NSF, a cdrom drive, a hard drive, or anything to reference except for the drive on the laptop I'm wanting to install slack to, and the usb which I want to use for the installation. Once I get the network drivers working, I have a connection to the internet so I can download packages and whatnot.

I have the .iso for the dvd install; the size shouldn't be an issue since the usb stick is 8gb.

I just finished my last preparation only to find out that it's for the computer I set up the usb stick on, and it requires the original hard drive's boot files. :banghead:

If you could point out another thread, that'd be great too... I know there are a lot out there, but I've already spent the past two days trying to find something that actually works to help me figure this out, and I'm finally at the end of my rope.


pielas 09-13-2009 04:04 AM

on downloaded dvd in usb-and-pxe-installers folder is description how to make usb drive bootable.

onebuck 09-13-2009 08:51 AM


Or look at 'usb-and-pxe-installers'.

This link and others can be found at 'Slackware-Links'. More than just SlackwareŽ links!

Asinine 09-13-2009 10:48 AM

Thanks for the replies. Unfortunately I guess I wasn't clear: booting up to the usb isn't an issue (I've already used usb-and-pxe-installers). The problem is I cannot manage to reference the usb with the .iso on it; I had "unpacked" the .iso to the usb and that worked all great and dandy in theory, but I could not get setup to recognise the proper directory (that I had mounted).
I have no idea how I'd unpack the .iso from a usb to itself... and I know I can't put it on the drive I'm installing to.

So basically, I've tried using the unpacked image of the .iso (using , and I cannot figure how to refer to it in the installation. I've gotten it to acknowledge the mount directory I set it up as (mount /dev/sdc /mnt/usbinstall), but then it pops up with an error that results in retry/ignore (in the setup menu... not the stupid DOS abort/retry/ignore :)). Everything else I've tried just results in it not being able to read the source directory. (I tried this both as a hard drive partition and a pre-mounted directory.)
I'm not 100% sure what I'm doing (maybe more like... 23%).

onebuck 09-13-2009 11:08 AM


Please post what you have done. Where did you mount the 'ISO' and how, when? What about mounting the 'ISO' to the loop device? How do you point the source to 'setup'?


excerpt from 'README_USB.TXT';

If you want to install Slackware using a local hard
disk partition in case you copied the content of the Slackware CDROMs/DVD there already, that is also an option.

I think if you are trying to use the 'USB' as your source then you may need to create a partition on the 'USB' device then copy the ISO to that partition. You will need to use a ext2/3 filesystem so you don't have the size limitations of 'FAT'. Then mount the 'ISO' that is on the 'USB_Partition' or point to the partition as source if that is how it is stored on the 'USB'.

colorpurple21859 09-13-2009 11:21 AM

this may not be right way but it works.
1.format the drive partition you are installing to first.
2.mkdir /slack on the newly formated partition your are installing to and copy the files from slackware-13/slackware/* from a mirror or the iso's to the slack directory.
3.during setup where it ask you to formate the target partition you are installing to select no. a console in f2 and find where the target partition is mount so you can tell the installation where the /slack directory with the packages is located at.

Asinine 09-13-2009 11:47 AM


Originally Posted by onebuck (Post 3681076)
I think if you are trying to use the 'USB' as your source then you may need to create a partition on the 'USB' device then copy the ISO to that partition. You will need to use a ext2/3 filesystem so you don't have the size limitations of 'FAT'. Then mount the 'ISO' that is on the 'USB_Partition' or point to the partition as source if that is how it is stored on the 'USB'.

You're correct; that is what I'm trying to do. I think I'm hitting a glass ceiling simply for the fact that I don't know things well enough to get it to work.

I'd unpacked the .iso file and copied the entire thing to the usb. (I had thought about trying colorpurple's idea... but then I got caught up in the fact that my original attempt didn't work and forgot haha).

My main problem with anything copied to the usb is that when I try to select my source, choosing either "install from a hard drive partition" and "install from a pre-mounted directory" seem to give me the same results.
Prior to running setup, I

mkdir /mnt/usbcd
mount /dev/sbc /mnt/usbcd

Then when I choose either of those options, I'm shown:

OK, we will install from a directory within the current filesystem...
I choose "/slackware" and get "Sorry - the directory you specified is not valid". When I copy the entire .iso, the directory (afaik) should be /dev/sdc/slackware. I enter this in (using "/slackware".) I've tried it a number of times with various directories, and once when I inputted "/slackware", I got another prompt for another directory. I was so excited, but after reading it, it was just another question as to where the repositories are (I think?). I didn't write down the dialog, and I haven't gotten it back since... anyway, I tried "/slackware" (since that's where the stuff was!) and got the invalid directory with only an OK that sends me back to the menu.

Colorpurple: I'm going to try that after I'm done trying to follow

I'm currently stuck trying to wade through the grub loader on that website since I've got lilo on here. :scratch: Can't be that hard though, right?

<edit>Sorry, forgot to mention that my USB is indeed ext2.</edit>
<edit2>Gahhh... so when I said I would use "/slackware" as my installation directory, I actually meant "/dev/sdc/slackware" and "/usb/slackware", because I remembered seeing a tutorial on how to change the directories (unfortunately on another website that I have no remembrance about) doing something like that.</edit2>

colorpurple21859 09-13-2009 12:04 PM

/mnt/usbcd/slackware would be the location of the packages directory.

Asinine 09-13-2009 12:47 PM

Yes... so... update.
I followed that website (minus the grub bit; got a bootloader installed).

I've gotten back to that part "OK, we will install from a directory within the current filesystem... " and I put /dev/sbc1/slackware (somehow I've lost a sbX drive and the usb got bumped up... which is odd since the sdrive that I'm installing to is sba, the boot usb is sbb... and some mystery was previously taking up sbc til now).

Now it said "Now we need to know the full path on this partition to the slackware/ directory where the directories containing installation files and packages to be installed are kept". That's the one I was talking about earlier.

I figure my installers are in the previously mentioned directory, so I tried these combos:
/dev/sbc1 | /slackware
/dev/sbc1 | /32/slackware
/dev/sbc1/32 | /slackware
(check out the website for the whole /32 thing)

All I'm getting is

There was a problem mounting your partition. Would you like to:

Then I get the restart/ignore error. Neither option makes puppies smile or rainbows fly.


colorpurple21859 09-13-2009 01:05 PM

on the usb do you have the iso in a /slackware directory or the individual files from the iso copied to the usb /slackware directory.

Asinine 09-13-2009 01:16 PM

I've got the files unpacked there with dd.

colorpurple21859 09-13-2009 01:27 PM

do you have directories a, ap, d, and so forth in the usb /slackware directory or are they in a subdirectory? and you tried

mount /dev/sbb -t ext2 /mnt/usbcd

Asinine 09-13-2009 02:16 PM

Crap, hit the wrong button and my post was erased before I could post it...

I can't seem to mount the usb with the .iso file ahead of time. Doing so (with the -t ext2 tag, which I hadn't tried before) gives:

mount:wrong fs type, bad option, bad superblock on /dev/sdc, missing codepage or helper program, or other error
In some cases useful info is found in syslog - try dmesg | tail or so

dmesg | tail says it can't find an ext2 filesystem on dev sdc... which is total crap cuz I got the message, cfdisked it, tried again and no change.

colorpurple21859 09-13-2009 03:13 PM

try mount /dev/sda /mnt/usbcd. then if that works and I understand right you will have to create another /mnt/newdirectory to mount you iso file to with the following:

mount -o loop <name of iso file> /mnt/newdirectory
and your package location would be in /mnt/newdirectory/slackware/
never did usb way before so just tried the beginning steps to see what happens.

Asinine 09-13-2009 03:22 PM

I can't seem to mount the usb with the .iso on it. I get the "can't read superblock" crap. And so I can't figure how to mount the .iso... (which is on the usb now)

Maybe a better question would be: how do I set up this desktop so I can run an NFS for the laptop? This whole ordeal is starting to irk me. Fortunately it's getting late. Maybe I'll just go sleep on it.\

Edit: btw, thanks for your suggestions colorpurple. I'm really hoping to get this down since I love the challenge of Slackware, and my laptop is something I'd just enjoy messing around with. I'm gonna try rebooting it again in hopes that something fubar'd in the meantime. Otherwise, I'll be back in 8 hours. :)

All times are GMT -5. The time now is 09:07 PM.