-   Linux - Newbie (
-   -   installing flash player (

Pup 12-28-2005 10:06 PM

installing flash player
how do you uncompress a file? I downloaded the Flash Player 7 to install on my Mandriva Linux system and the ReadMe files says to Uncompress the file. Can you tell I am new yet? many thanks!

XavierP 12-28-2005 10:13 PM

If the file ends in .tar.gz, run this[code]tar zxvf <filename>.tar.gz/code]and the file will uncompress.

Welcome to LQ :D

kvnband 12-28-2005 10:14 PM

What is the file extension? (If I remember right, it's tar.gz, right?)

So cd to the directory where your file is at (in console) and issue a

tar -xvf filename.tar.gz That will create a directory. CD into that directory and run the installer. If I'm not mistaken, macromedia has some great instructions on how to install.

xine_luo 12-28-2005 10:26 PM

Of course,If the file ends in .zip, run this

unzip <filename>.zip
and the file will uncompress

Pup 12-28-2005 10:43 PM

thanks, but now what
kevin,and everyone else
appreciate the quick resposne and I was able to do everything but run the installation. I get a prompt telling me my architecture, \'x86_64\' is not supported by the macromedia flash player installer. what a wonderful world I just encountered. I will saty with it, but I have got a lot to learn with linux.

kvnband 12-28-2005 10:46 PM

See posts below...

kvnband 12-28-2005 10:53 PM

See post below......

kvnband 12-28-2005 10:58 PM

After a bit of searching, I've found the following:

According to the last post in the thread, the flash player plugin works fine on 64 bit, it's just the install script that doesn't work. According to that thread, you need to


You have to do a manual install. Find the "flashplayer.xpt" and "" files from the "install_flash_player_7_linux" directory where you extracted the tarball. Copy these 2 files into your browser's /plugins/ directory and you'll be good to go!

this is just a fact of the install script only works on 32bit platforms, the plugin works fine.
My mandriva install installed firefox 1.0.6 to the following location


So you should copy flashplayer.xpt and to

(This is assuming that your firefox is located in the same place mine is)

Pup 12-29-2005 06:55 AM

copying the .xpt and .so fiels
I don't know the command prompts to copy and paste these files you mentioned. I am able to get to them and have found where my mozzilla firefox is at
/usr/bin/mozilla-firefox . This forum is great, but hence the newbie title.I'm learning :study:

kvnband 12-29-2005 09:25 AM

First off, you're looking for your mozilla-firefox directory, not the actual program. /usr/bin/mozilla-firefox would be the actual application. You should look to /usr/lib/ and look for firefox there.

Secondly,there are a couple of things you could do. First off, you could open up a new konqueror window and go your plugins directory. Then open up a new konqueror window and go to your flash directory. Then you could just drag the two files from flash directory to plugins directory

OR you could open up konsole and type
cp /home/user/Desktop/install_flash_player_7/flashplayer.xpt /usr/lib/mozilla-firefox/plugins
cp /home/user/Desktop/install_flash_player_7/ /usr/lib/mozilla-firefox/plugins

Of course, you would substitute the first path for your flash path and the second path for your firefox plugins path.

Note: You may have to be root to write to /usr/lib. I'm not 100% sure. If you do have to be root, the use the second method of copying, but before typing the cp commands, issue a



Pup 12-31-2005 11:25 AM

Hey I appreciate your last on the the flashplayer. I found that my directory was /usr/lib64/mozilla-firefox-1.0.6/plugins

after following your previous, I literrally saw the files transfered on the konqueror, however, they flash player still didn't run. So I rebooted my computer, thinking that had something to do with it, but it still doesn't. what am I missing. I am on a 64bit computer and I did have to be root in order to cp the .xpt and .so files.

many thanks!

kvnband 12-31-2005 11:28 AM

Well, you've tried everything I know of. I am not on a 64bit computer, so can't give you anymore insight. Perhaps go to that thread that I mentioned above and PM or email one of the posters and see if they can help you out a little more.

Sorry I can't get it totally solved for you.

All times are GMT -5. The time now is 11:42 PM.