-   Linux - Newbie (
-   -   Installing applications locally (

Master_9 11-05-2009 09:53 AM

Installing applications locally
I probably sound like a noob, but that's why I'm posting in the newbie section. If I have a source tarball source.tar.gz, I do

tar -xvf
source.tar.gz. When I do

make configure
, is there a flag I can set so it installs to /home/Master_9/bin? Thank you.

emmalg 11-05-2009 10:23 AM

Hi Master_9

Makefiles can be a bit of black magic even to those of us who have written our own!

If the program and makefile have been well written you can probably move the binary to your desired location after compilation with no adverse effects, but I make no guarantee. I've certianly been able to do this with a huge project I worken on (and I never had a configure option in my makefile!).

You make also find that /usr/local/bin is a better place for the binary, it is usually already in your path, therefore if you need to run that binary or call it from a script you don't need to mess around adding to your path.

Alternatively, make it somewhere like /opt and make a link to the binary in /home/Master_9/bin (or /usr/local/bin).

Sorry I haven't been able to help more. If you need help making the links, just let us know.


knudfl 11-05-2009 10:43 AM

Most source code have a 'configure' file letting you do :
./configure --prefix=/home/Master_9/<new- folder>

If you only have a 'Makefile' it can hopefully be edited
to the preferred install location.

If you want a precise answer, may be you can tell which
application, you want to install.
P.S. : .. At least 5 other methods are used to build software ..
post # 4.

chrism01 11-06-2009 01:44 AM

If you've got source.tar.gz, you need

tar -zxvf source.tar.gz

the -z un-gzips it

Nylex 11-06-2009 03:21 AM


Originally Posted by chrism01 (Post 3746662)
If you've got source.tar.gz, you need

tar -zxvf source.tar.gz

the -z un-gzips it

Newer versions of tar don't require the 'z' (or 'j' for bzip) option when extracting.

Master_9 11-06-2009 01:34 PM

Thanks knudfl :), it worked.

All times are GMT -5. The time now is 01:09 PM.