-   Linux - Newbie (
-   -   installing adsl modem in ubuntu (

banerjeemono 09-06-2008 06:26 AM

installing adsl modem in ubuntu
well my linux ubuntu is up and running. i thought that it would be a great task but it was nothing.
anyway my new problem is that i cannot connect to the internet using linux. i dont know how to connect my ADSL Modem in ubuntu.
your help will be most appreciated

camorri 09-06-2008 07:09 AM

Please post the make and model of the 'modem'. Is it just a modem, or is it a router/modem? The configuration can be different. Ubuntu, what version?

pinniped 09-06-2008 07:27 AM

Has the modem been configured yet? Does the modem store your user and password information and make an internet connection on its own, or is the computer meant to initiate the connection?

banerjeemono 09-06-2008 07:45 AM

well my modem is a adsl dial up modem. the computer stores the username and password of the modem and everytime to connect to the net i have to initiate the connection.
well i did a modem scan using scanModem but it didnot recognise the modem. i cannot send in the report as microsoft is not able to read it i think coz its looks a lot different than it did in linux. i am using ubuntu-8.04.1-desktop-i386. thanks for the concern:D

pinniped 09-06-2008 08:05 AM

'scanmodem' is to detect dial-up WinModems.

For ubuntu you want to install 'pppoe' and 'pppoeconf'; then at a command line:

sudo pppoeconf

It will ask you a few questions and set up pppoe correctly (well, as long as you gave it the correct answers). If it asks you if you want a 'persistent' connection, tell it 'yes'; otherwise you have to start the connection yourself with 'pon'.

banerjeemono 09-06-2008 10:10 AM

to pinniped
ppoeconfig is returning a message that command not found. i tried pppconfig which i saw in an article in ubuntu geek. i followed all the details but its simply not working.
seriously i am tried restarting my computer jumping from windows xp to ubuntu and back. so plz help me.

jailbait 09-06-2008 02:04 PM

What command was not found, pppconfig? It may not be on your PATH of executable commands. Use the which command to see if the command is on your PATH:

which pppconfig

If the command is not found by which then use the find command to see if the command exists in some directory not on your PATH:

find / -iname "*pppconfig*"

You may also have the problem that the pppconfig command is not executable by user but it can be executed by root. You could try using sudo to execute the command:

sudo pppconfig


man which
man find
man sudo
man pppconfig

Steve Stites

pinniped 09-06-2008 06:44 PM

pppoeconfig is not installed by default; you need to install it using your package manager and the install CD

john test 11-08-2008 05:40 PM

Doesn't the OP need to define what the scenario is?
PPOECONFIG would be for a DSL connection
PPPCONFIG would be for a Dialup connection

Tinkster 11-08-2008 05:51 PM


Originally Posted by banerjeemono (Post 3271531)
to pinniped ...

Please don't do that kind of thing - just carry on in the
thread where he had helped you. I've merged the two
threads so others can follow what this was all about.


Aleks` 11-08-2008 06:01 PM

It's pppoeconf and it comes with the default ubuntu install, just run the wizard (its a next, next, finish one) and you are ready to go.

All times are GMT -5. The time now is 04:48 PM.