LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Installing a LAMP server on slackware 14.1 (https://www.linuxquestions.org/questions/linux-newbie-8/installing-a-lamp-server-on-slackware-14-1-a-4175529512/)

Johnn0 12-29-2014 09:51 PM

Installing a LAMP server on slackware 14.1
 
Hi there,

I'm running slackware 14.1 as a VMWare virtual machine and I wanted to get a LAMP server up and running. I've been following the steps in this tutorial here:

http://www.unixmen.com/easy-steps-to...lackware-14-0/

When I run the commands "slackpkg install httpd", "slackpkg install mysql", "slackpkg install php" I receive the following message:

***
Looking for php in package list. Please wait... DONE

No packages match the pattern for install. Try:

/usr/sbin/slackpkg reinstall|upgrade
***

I have two mirrors uncommented in /etc/slackpkg/mirrors and I've been able to run slackpkg update and slackpkg upgrade-all.

What do I need to do to be able to install the packages using slackpkg in slackware?

frankbell 12-29-2014 10:56 PM

Slackware includes all you need for a LAMPP server out-of-the-box. From this Slackware box I'm using right now:

Code:

~/ $ whereis httpd
httpd: /usr/sbin/httpd /etc/httpd /usr/lib/httpd /usr/include/httpd /opt/lampp/bin/httpd /usr/man/man8/httpd.8.gz /usr/share/man/man8/httpd.8.gz /usr/X11/man/man8/httpd.8.gz
~/ $ whereis mysql
mysql: /usr/bin/mysql /usr/lib/mysql /usr/X11R6/bin/mysql /usr/bin/X11/mysql /usr/X11/bin/mysql /usr/include/mysql /usr/share/mysql /opt/lampp/bin/mysql.server /opt/lampp/bin/mysql /usr/man/man1/mysql.1.gz /usr/share/man/man1/mysql.1.gz /usr/X11/man/man1/mysql.1.gz
~/ $ whereis perl
perl: /usr/bin/perl /usr/X11R6/bin/perl /usr/bin/X11/perl /usr/X11/bin/perl /opt/lampp/bin/perl /usr/man/man1/perl.1.gz /usr/share/man/man1/perl.1.gz /usr/X11/man/man1/perl.1.gz
~/ $ whereis php
php: /usr/bin/php /etc/php /usr/lib/php /usr/X11R6/bin/php /usr/bin/X11/php /usr/X11/bin/php /usr/include/php /opt/lampp/bin/php /usr/man/man1/php.1.gz /usr/share/man/man1/php.1.gz /usr/X11/man/man1/php.1.gz

You may find this tutorial more useful: http://slackware.ponce.cc/blog/2011/...omment-page-1/

I took a look at that Unixmen link and couldn't figure out, for the life of me, why they wanted you to reinstall stuff that was already there.

Johnn0 12-30-2014 12:29 AM

I think I'd already tried running the mysql setup earlier and became bogged down. From the tutorial frankbell posted above; when I try to run mysql_secure_installation it asks me for the current password for root. I try no password, and passwords I think I may have set and it gives this error and keeps prompting me.

ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysql/mysql.sock' (2)

It also throws an error when I attempt mysql_install_db --user=mysql.

Is there a way I can start again on my mysql setup, such as uninstalling and reinstalling the application, or is there a process I can reset the password?

peonuser 01-01-2015 06:40 AM

Can not wait to try this on my old P1. Speed is not critical. The machine is for learning.


All times are GMT -5. The time now is 03:27 AM.