LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Installed SUSE now Vista won't boot - mountpoint removed when not properly shutdown (https://www.linuxquestions.org/questions/linux-newbie-8/installed-suse-now-vista-wont-boot-mountpoint-removed-when-not-properly-shutdown-592069/)

Retrofill 10-15-2007 07:06 PM

Installed SUSE now Vista won't boot - mountpoint removed when not properly shutdown
 
I have messed up the install on my laptop quite badly :p

I have installed gnome SUSE Linux 10.3, the default partition settings wouldn't work, it said that the windows partition was not shut down properly, that i should shut it down if i have windows (i have windows vista). I only read this on the second attempt; when the damage was already done. What i did on the first install to get it to install, was remove the 'mount point' for the windows partition. This made Linux install, but although windows was on the boot loader, it did not run properly. Now I have no possible way to 'shutdown' windows properly.

I have tried doing a windows repair from the disk, but it can't repair because it can't detect it.

Any help or suggestions would be appreciated.

AceofSpades19 10-15-2007 08:03 PM

I don't understand what you mean by "mountpoint"

Retrofill 10-15-2007 08:15 PM

the mount point, i changed it in the partition editor in SUSE installer. Its where the boot loader loads the OS... it think.

By default, SUSE tried to set it to /windows/c/ to load vista there (linux root is usually set to '/' etc).

larkl 10-16-2007 07:34 AM

If you mean you still have a partition with a full previously working WIndows system and that you need something off of it or you want to dual-boot to it, then one option is to put the Windows MBR back on the drive, then do what ever shutdown command you need. Not really following the shutdown error problem, can SUSE tell if a windows partition wasn't shutdown properly? As far as the mountpoint, do you mean that you didn't allow SUSE to put grub or lilo on the MBR? Usually, you would allow this, unless you really know what you're doing.

CouchMaster 10-16-2007 07:44 AM

Vista won't let you do things like that! In the name of SECURITY...
Read this thread: http://forums.techguy.org/unix-linux...ng-ubuntu.html

Retrofill 10-16-2007 08:12 AM

Trying to understand
 
Yeah I have Windows Vista that needs dual booting, its already trying to load on Grub, but when you startup Windows it says this:
<code>
Windows Boot Manager----------------

windows failed to start. a recent hardware or software change might be the cause. to fix the problem:

1. insert your windows installation disc and restart your computer.
2. Choose your language settings, and then click "next."
3. Click "Repair your computer."

If you do not have this disc, contact your sysstem administrator or computer manufacturer for assistance.

File: \windows\system32\winload.exe

Status: 0xc000000e

Info: The selected entry could not be loaded because the application is missing or corrupt.
</code>


I have no idea if i've changed the MBR (Master Boot Record I assume), or how to change it or use it to do a windows shutdown command. If thats the same as the mount point, then i would like to change it but don't know how.

It seems evident that the SUSE installer can tell if windows wasnt shutdown properly, because i tested it on my other PC and it wouldn't sort out the partitions before install, unless I went back into windows and turned it off properly. I can't try and do this on my laptop where the problem is however, because when i try and startup, that error above comes up.

I'm not sure if i allowed SUSE or grum on the MBR, its on the list of options for boot. All i know is that i removed the '/windows/c/' mount point that SUSE planned to put on the disk, and continued to install SUSE, at which point windows stopped coming up.

Is there something that I can do to rectify this, either in SUSE or by using a bootable program of some sort?

I read that forum CptBlack, not entirely sure I understand it, should I try and change the mount point with these commands?

sudo su
mkdir /mnt/sdb1
mount /dev/sdb1 /mnt/sdb1

bigrigdriver 10-16-2007 08:41 AM

Quote:

I'm not sure if i allowed SUSE or grum on the MBR, its on the list of options for boot. All i know is that i removed the '/windows/c/' mount point that SUSE planned to put on the disk, and continued to install SUSE, at which point windows stopped coming up.
It appears that you have installed grub's first stage to the MBR. That in itself will not disable windows boot. Installing any part of Suse to the windows partition probably would kill windows.

Suse wasn't going to put /windows/c on the disk; windows was already there. Suse was going to use that information to write /etc/fstab to show a device (the windows partition) and the mount point for that partition in the directory tree.

If you removed that mount point in the partition editor, you may well have removed the windows partition itself!

To confirm or deny my conclusion, you would need to boot a liveCD distro. Mount the Suse partition and copy /boot/grub/menu.lst (just the menu entries for operating systems), copy /etc/fstab, and show those copies here. Also, in a console, run 'fdisk -l | tee fdisk-list.txt' to get the output of fdisk to a text file and show that here.

oskar 10-16-2007 08:48 AM

Well that's easy to find out... Boot to suse and open the terminal, or start with a live cd if all else fails, and write
Code:

$ su
# fdisk -l

That should show you if sda1 is still formatted as ntfs.

Here is a nice and straight-forward howto: http://apcmag.com/5046/how_to_dual_b...nstalled_first

Retrofill 10-16-2007 11:36 AM

Yeah it seems to be still there, under NTFS, and will boot, but just show that error and not be detected by Vista repair (on DVD)

Here is the fdisk -l output:
Code:

Disk /dev/sda: 60.0 GB, 60011642880 bytes
255 heads, 63 sectors/track, 7296 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000f1a8d

  Device Boot      Start        End      Blocks  Id  System
/dev/sda1              1        5355    43014006    7  HPFS/NTFS
/dev/sda2            5356        5617    2104515  82  Linux swap / Solaris
/dev/sda3            5618        7296    13486567+  f  W95 Ext'd (LBA)
/dev/sda5            5618        6289    5397808+  83  Linux
/dev/sda6            6290        7296    8088696  83  Linux

Now, this does not show the mount points, but /etc/fstab does:
Code:

/dev/disk/by-id/scsi-SATA_FUJITSU_MHV2060_NW18T6229HCW-part5 /                    ext3      acl,user_xattr        1 1
/dev/disk/by-id/scsi-SATA_FUJITSU_MHV2060_NW18T6229HCW-part6 /home                ext3      acl,user_xattr        1 2
/dev/disk/by-id/scsi-SATA_FUJITSU_MHV2060_NW18T6229HCW-part2 swap                swap      defaults              0 0
proc                /proc                proc      defaults              0 0
sysfs                /sys                sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts              /dev/pts            devpts    mode=0620,gid=5      0 0

You can see that ext3 mount point is set to '/' etc.

I was thinking of adding

Code:

/dev/disk/by-id/scsi-SATA_FUJITSU_MHV2060_NW18T6229HCW-part1 /windows/c/        ntfs      defaults                  1 1
To try and get windows to be recognized. Just a total guess so I'm not going to do it unless I'm sure.

Is there some way to stop windows from showing up as being corrupt? If not I'll just give up and format the windows partition and re-install.

oskar 10-16-2007 12:22 PM

The mountpoint has nothing to do with the system being able to boot At boot up the mount point is nothing but numbers and letters in a text file on the ext3 partition.

After you added that line to fstab, you can go back to the console and type "mount -a" as root, then you should be able to access the partition at /windows/c.
This is completely unrelated to the boot problem though.

Retrofill 10-16-2007 12:47 PM

oh dear, when i type 'mount -a' it says /windows/c/ does not exist :(. Looks like my partition is corrupted and I'll have to format.


Thanks for your help guys, especially oskar :)

The_JinJ 10-16-2007 12:55 PM

Maybe I missed something but could you not reinstall the Vista bootloader - shutdown cleanly etc then reinstall GRUB?

Retrofill 10-16-2007 01:04 PM

Well it boots windows, but says its corrupted. Will changing the boot loader do anything?

If so, i've no idea how to just install the boot loader.

If not, thanks for suggestion :p

The_JinJ 10-16-2007 01:18 PM

Ok try this - first result from a Google :)

Retrofill 10-16-2007 02:45 PM

Tried, that, the windows install did not appear in the repair list.

So I've formatted and re-installed vista, thanks for your help though.

:)


All times are GMT -5. The time now is 07:40 AM.