LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Installed Fedora 17 on old HP laptop and graphics are terrible (https://www.linuxquestions.org/questions/linux-newbie-8/installed-fedora-17-on-old-hp-laptop-and-graphics-are-terrible-948047/)

veeruk101 06-01-2012 06:03 PM

Installed Fedora 17 on old HP laptop and graphics are terrible
 
I was running CentOS 6.2 just fine on my old HP dv5117 laptop, and the graphics looked good. But now on Fedora 17 everything looks off, the screen resolution is bad (I tried changing it), and I'm not sure what to try next. Do I need some kind of drivers? (I tried installing the following Catalyst driver from the AMD website but got errors during installation. http://support.amd.com/us/gpudownloa...5&lang=English)

Doing a "lspci | grep VGA" I get "VGA Compatible Controller: ATI Technologies Inc Radeon XPRESS 200M 5955 (PCIE)". Is there any other information I could provide about my video card that might help determine what I should do?

When I look at one of the detail screens it says my graphics is "Gallium 0.4 on ATI RS480".

What could I try to get it working? Thanks.

TobiSGD 06-01-2012 06:30 PM

There is no proprietary driver for your card that works with Fedora 17. Also, the free radeon drivers are known to have problems with Gnome 3. Nothing you can do at this time but changing to a different desktop environment.

veeruk101 06-01-2012 06:34 PM

So if I change to a different desktop environment, would the free radeon driver you mentioned (the one known to have problems with Gnome 3) work on my system? I looked around but all I could find is the one in my original post.

Would this free radeon driver work if I downgrade from Gnome 3 to Gnome 2, if it's even possible to do that in Fedora 17?

TobiSGD 06-01-2012 06:48 PM

it should work with any other desktop environment. I am not sure if Gnome 2 is available in Fedora 17, may be Mate (a Gnome 2 fork) is. I would go for XFCE, it somewhat resembles Gnome 2 and will work.

veeruk101 06-01-2012 06:52 PM

Ok thanks, I'll give it a try with another desktop environment. Would you know which is the free radeon driver you were mentioning? I've looked at so many pages online describing different things, like doing something like "yum install akmod-catalyst xorg-x11-drv-catalyst xorg-x11-drv-catalyst-libs", or by installing the driver at http://support.amd.com/us/gpudownloa...5&lang=English, or other things. If you could point me in the right direction of where I can find the driver you were mentioning I'd really appreciate it :)

TobiSGD 06-01-2012 07:03 PM

The free radeon driver comes pre-installed by default, you are already using it, Gallium is a part of it, this is why you get that info for your graphics driver. The Catalyst driver is the proprietary driver, this will not work with your system.


All times are GMT -5. The time now is 10:13 PM.