LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   installed as root, running as non-root? (https://www.linuxquestions.org/questions/linux-newbie-8/installed-as-root-running-as-non-root-90897/)

daniela 09-09-2003 10:51 AM

installed as root, running as non-root?
 
Hello...

well...i had a problem with licq. it didn't wanna run at all. so i removed it & tried to install it again from cd. it didn't work (i can't figure out why but it doesn't matter anymore). so i downloaded a new version (1.2.7) & finally succeeded to install it & the gt-guy.
obviously i had to install it as root. my problem is that i can't run it when i'm not superuser. it always says:

[dan@x1-6-00-30-84-2b-42-91 dan]$ licq
17:47:22: [WRN] Licq: Ignoring stale lockfile (pid 22701)
17:47:22: [ERR] Unable to load plugin (plugins): /usr/local/lib/licq/licq_plugins.so: cannot open shared object file: No such file or directory.

when i run it as root, i don't get any errormessage.

does anybody have an idea how to fix it, so that i'm able to run it as "dan"?

thanks in advance
daniela

hexbit 09-09-2003 11:17 AM

Check the permissions on /usr/local/lib/licq and make sure you're able to read it as "dan" .. it sounds like your permissions are set wrongly .

daniela 09-09-2003 01:05 PM

ok, i changed permissions so that i'm able to read it as dan, then it told me

19:58:09: [WRN] Licq: Ignoring stale lockfile (pid 29467)
19:58:09: [ERR] Unable to load plugin (plugins): /usr/local/lib/licq/licq_plugins.so: cannot open shared object file: Permission denied.
19:58:09: [WRN] This usually happens when your plugin
is not kept in sync with the daemon.
Please try recompiling the plugin.

i recompiled it & still get the same error...(but no problem to run it as root)

it seems very strange to me because the file licq_plugins.so doesn't even exist so why does it only say "permission denied"...?

& i have no idea what "kept in sync with the daemon" means...does it mean the permissions aren't the same?

h/w 09-09-2003 04:07 PM

lot of apps keep a 'lock file' that, if present, prevent another instance being started (mozilla/netscape..)
if there is a .licq dir under ur home dir, chk for a lock file, and delete it. then try. but anyway, this is just a warning.

the error message is about the plugin. if licq plugins are like mozilla's, why dont u make a link to '/usr/local/lib/licq/licq_plugins.so' in licq plugins folder in ur home dir?

im just guessing, hope it works.

daniela 09-09-2003 04:41 PM

i ignored the lockfile yet. i tried the link thing. but it didn't help at all. i'm receiving the same error message as usual...
but thanks for trying...


All times are GMT -5. The time now is 01:54 PM.