-   Linux - Newbie (
-   -   installation problems with slackware 9.1 (

introuble 04-22-2004 10:35 AM

installation problems with slackware 9.1
Right now I have 2 operating systems:

1) WinXP
2) Fedora Core 1

boot loader: GRUB

I have tryed to install Slackware 9.1 two times and failed . I can not figure out why .

I'm trying to install the sistem using the CDs

boot: bare.i
login: root

I run "CFDISK" and create 2 PRIMARY partitions , destroying the ones on wich I have Fedora

1- SWAP (82) partition , size: aprox. 240 MB
2- normal linux (83) partition , size: aprox. 16 GB

I "write" them both and continue with "Setup"

I activate the SWAP partition , format the / partition (I do this in "slow mode - check for bad blocks") .. everything seems to be ok ..

the first time I tryed this , I chose "Install LILO"
the second time I chose "Don't install LILO"

(in both cases , GRUB remains . how do I fix this "problem" ?)

I chose the installation type: "FULL"

the install process seems to run without problems , I create a boot disk , eject the cd .. reboot

1) GRUB doesn't "SEE" any operating systems and there is no sign of LILO
2) I insert the boot disk and try to boot from it -> ERROR .. replace disk and try again

I try "mount root=/dev/hda4 rw" -> ERROR
( /dev/hda4 is the / partition )

Where am I going wrong ? What must I do ?

Chris H 04-22-2004 10:43 AM

After cfdisk you may have to reboot to get the install to see your partitions.

When you get to the lilo config do you go 'expert'? It's always worked for me. And where do you install the bootloader?

Dunno about grub, my install never had the option.

Andrew Benton 04-22-2004 12:20 PM

Don't install lilo. Add an entry to your /boot/grub/menu.lst

title Slack
root (hd0,3)
kernel /boot/vmlinuz root=/dev/hda4 vga=788

introuble 04-22-2004 01:19 PM

Chris H - well , I installed GRUB when I installed Fedora ; no , I didn't go "expert" mode when installing LILO as I never used this boot loader before - I'll try "expert" mode the next time though , thanks

Andrew - the problem is that the GRUB "splash" image and everything is on the Fedora /boot partition , wich is destroyed when I create the partitions needed for Slackware to install
+ even if I wouldn't 'destroy' the /boot partition , there is no way I could access it - thanks for replying !

Andrew Benton 04-22-2004 03:23 PM

Sorry I misunderstood. I thought you meant you had Fedora and Windows installed and wanted to add Slack to the list. In my experience it's very difficult to get lilo to boot two different types of linux and Windows (which is why I like Grub so much) but if you just want Windows and Slack then if I were you I would go round the install process again and put lilo on the master boot record (MBR). If that fails then you could either reinstall Fedora or boot with the Windows CD and use that to fixmbr

Chris H 04-22-2004 03:50 PM

'expert' mode is quite simple.

detpenguin 04-22-2004 03:57 PM

using a windows bootdisk, reboot your pc and at a prompt, type fdisk /mbr
that will remove the grub stuff...

introuble 04-23-2004 06:54 AM

well .. thanks for your suggestions .. I'll try again to install Slackware in a few hours and I'll let you know if I succeed or not

introuble 04-23-2004 08:22 AM

haha! I'm prowd to announce I have SUCCESFULY installed SLACKWARE 9.1

special thanks goes to Chris H , Andrew Benton and detpenguin: wouldn't have done it without you guys , thanks a lot and take care :>

All times are GMT -5. The time now is 04:11 PM.