LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-15-2019, 05:59 AM   #1
NoBillYouCantHaveMyCCNo
LQ Newbie
 
Registered: May 2019
Posts: 10

Rep: Reputation: Disabled
Installation Problems UBuntu 18.04 on Lenovo Flex11


Howdy Yall,

I have a small problem, but please read to the end.

TLDR:I need to repackage and ISO that I have made almost no modifications too, or copy and rename a single file in the same location that it is currently within the unmodified ISO. Maybe.

Context: I will not go back to Windows. I just purchased a new Convertible Laptop, did the research to be sure that I could figure out how to get Ubuntu to do what I need(Touchscreen without major fixes), and WAS going to install it alongside Windows 10....but this POS has "S mode"...and to install Firefox, Opera, LibreOffice, or anything I have been using for the past 3 years...I had to give Microsoft my info. To make a very long story short, the option of keeping Windows 10 went out the Window (pun intentionally left unavoided) when Microsoft asked for my CC# to verify my age. (Created a fake acct... used wrong age...couldn't fix it...etc...etc....Factory Reset)

I didn't buy this laptop as an invitation into my home...I bought it with the same thoughts you have when you buy a hammer, "this will be MY tool, and buying it will conclude our business"...Not, "Should I Mary old Al the Ace Hardware Owner's Daughter?"

So its time to cripple this crappy spyware...

I attempted to install Ubuntu 18.04 on my brand new Lenovo Flex 11, when I ran into what is apparently a common problem with 18.10. I started the installation, it crashed, and after restarting(because everything became very buggy) I received this error:

Failed to open \EFI\BOOT\mmx64.efi - Not Found
Failed to load image \EFI\BOOT\mmx64.efi - Not Found
Failed to start MokManager: Not Found
Something has gone seriously wrong: import_mok_state() failed
: Not Found


Here is some context and the information that I have found that has brought me the furthest.

https://bugs.launchpad.net/ubuntu/+s...2/+bug/1798171
[URL="https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1798171"]

Now this will show my general lack of experience, but here is what I have done:
1. Re"burn" the ISO
2. Wipe the Thumbdrive and repeat step 1(assuming that it had been corrupted, since it apparently is missing a file).
3. Turn off Secure Boot
4. Find out that UEFI is the only option I have on my new laptop.
5. Extract the ISO Files.
6. Copy grubx64.efi and rename mmx64.efi in the location that it will be looked for(the same file directory)...see context, someone else made this work.
7. Compress the files back into an ISO(Yes you can laugh, I am using 16.04 and I right clicked to accomplish that)....Didn't work.

Now I have a problem. I have no idea how to repackage the ISO. Frankly everything I have read is over my head. I knew very little about how to do any of the things that I listed above, and my GoogleFu just isn't strong enough to know how to do what I need to. I added exactly one file, and this has been done as a patch by others.

My question is; How can I reach into the unmodified version of the ISO make a copy of the file and rename it? OR...How can I repackage what I have done (that same thing, just after extracting the files) without learning another tool(or fixing the computer I am using that I cannot install anything on)

I think this is the next step, but there are some steps after this if it doesn't work, its also some of the reading I have done:

https://askubuntu.com/questions/7899...llation-target

https://help.ubuntu.com/community/UE...stem_Partition

Thanks in advance guys!
 
Old 05-15-2019, 10:09 AM   #2
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 8,528

Rep: Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739
I would suggest that you read the Ubuntu documentation at the link below on dual booting UEFI with windows 10 to start. You need to turn off hibernation/fastboot in window and shrink your windows partition using Disk Management to create free/unallocated space on which to install Ubuntu. This and more detailed instructions at the link below. If you have problems, post specific problems and/or warning messages you receive.

https://help.ubuntu.com/community/UEFI
 
1 members found this post helpful.
Old 05-15-2019, 04:18 PM   #3
NoBillYouCantHaveMyCCNo
LQ Newbie
 
Registered: May 2019
Posts: 10

Original Poster
Rep: Reputation: Disabled
Quote:
I would suggest that you read the Ubuntu documentation at the link below on dual booting UEFI with windows 10 to start. You need to turn off hibernation/fastboot in window and shrink your windows partition using Disk Management to create free/unallocated space on which to install Ubuntu. This and more detailed instructions at the link below. If you have problems, post specific problems and/or warning messages you receive.
Thanks Yancek,
It took me a little while to find the settings in Windows but I have turned off Fastboot and Hibernate. I am curious is this just so that I can get to the boot order? The Flex 11 literally has a recessed button for accessing the Bios and system recovery.

The other question I have at this point is about modifying the system partitions, do I need to do this if I am wiping the drive and not setting up dual boot? I really don't want windows any longer, not since "S mode".
 
Old 05-15-2019, 04:32 PM   #4
linus72
LQ Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: Slack14.2/Many
Posts: 5,478

Rep: Reputation: 446Reputation: 446Reputation: 446Reputation: 446Reputation: 446
If you're sure you dont want windows in the ubuntu installer itll ask if you want to use the whole disk or boot alongside windows, choose whole disk and itll auto partition for you.
If you want to boot different flavors of linux you need to make as many partitions as you want then tell ubuntu in install mode to use expert/manual partitioning and choose a partition.
For now just choose whole disk and itll be installed.
 
1 members found this post helpful.
Old 05-15-2019, 04:45 PM   #5
NoBillYouCantHaveMyCCNo
LQ Newbie
 
Registered: May 2019
Posts: 10

Original Poster
Rep: Reputation: Disabled
Ok Update:

I am getting the same error.

Here are the settings I have changed:

Secure Boot (Disabled)
Intel Platform Trust Technology (Diabled)
Boot Priority Changed so that my USB is on top.

UEFI is my only option in BIOS, there is no Legacy option.

I guess the easier (maybe) question is, how do I modify the ISO to patch the problem (Copy grub64x.efi and rename it mmx64.efi) Since this has worked for others?
 
Old 05-15-2019, 04:46 PM   #6
NoBillYouCantHaveMyCCNo
LQ Newbie
 
Registered: May 2019
Posts: 10

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by linus72 View Post
If you're sure you dont want windows in the ubuntu installer itll ask if you want to use the whole disk or boot alongside windows, choose whole disk and itll auto partition for you.
If you want to boot different flavors of linux you need to make as many partitions as you want then tell ubuntu in install mode to use expert/manual partitioning and choose a partition.
For now just choose whole disk and itll be installed.
Thanks Linus,
The problem right now is that I tried that, and it crashed, and now I cannot boot from the USB.
 
Old 05-15-2019, 04:48 PM   #7
linus72
LQ Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: Slack14.2/Many
Posts: 5,478

Rep: Reputation: 446Reputation: 446Reputation: 446Reputation: 446Reputation: 446
ok so the step youre at right now is trying to recreate the iso after you edited it?
 
Old 05-15-2019, 05:00 PM   #8
NoBillYouCantHaveMyCCNo
LQ Newbie
 
Registered: May 2019
Posts: 10

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by linus72 View Post
ok so the step youre at right now is trying to recreate the iso after you edited it?
Yes. Either that or modifying the intact ISO in the same way that I modified the one that I extracted. (I have 2 Copies)
 
Old 05-15-2019, 05:08 PM   #9
linus72
LQ Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: Slack14.2/Many
Posts: 5,478

Rep: Reputation: 446Reputation: 446Reputation: 446Reputation: 446Reputation: 446
ok here's a script that'il do it for you, put the modified iso contents in a folder, named whatever, for this example we'll name it ISO
copy/paste this code below into a empty file and save it as geniso.sh then as root open a terminal in same folder you have the ISO folder and the script named geniso.sh, become root with sudo su, then make the script executable with chmod +x geniso.sh
Then run the script with ./geniso.sh

Note you must edit the script for location, name, etc of the ubuntu iso, so just make it say what the original iso says.

Code:
cd /home/your_name/ISO/ && /usr/bin/genisoimage -o /home/ubuntu-name.iso -v -J -R -D -A Ubuntu -V Ubuntu -no-emul-boot -boot-info-table -boot-load-size 4 -b isolinux/isolinux.bin -c isolinux/isolinux.boot .
Note- does the ubuntu modified iso have a isolinux folder in it?
Hit me back if you encounter any issues
 
Old 05-15-2019, 05:13 PM   #10
linus72
LQ Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: Slack14.2/Many
Posts: 5,478

Rep: Reputation: 446Reputation: 446Reputation: 446Reputation: 446Reputation: 446
You may have to install mtools, syslinux, and genisoimage or mkisofs if you dont already have them...i believe ubuntu uses genisoimage like debian...
 
Old 05-15-2019, 08:01 PM   #11
NoBillYouCantHaveMyCCNo
LQ Newbie
 
Registered: May 2019
Posts: 10

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by linus72 View Post

Note- does the ubuntu modified iso have a isolinux folder in it?
Yes it does.
 
Old 05-15-2019, 08:07 PM   #12
linus72
LQ Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: Slack14.2/Many
Posts: 5,478

Rep: Reputation: 446Reputation: 446Reputation: 446Reputation: 446Reputation: 446
then use the script above and itll make iso
 
Old 05-15-2019, 08:33 PM   #13
NoBillYouCantHaveMyCCNo
LQ Newbie
 
Registered: May 2019
Posts: 10

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by linus72 View Post
then use the script above and itll make iso
Well surprisingly it ran the first time, and looks like it did what it was supposed to.

I feel really dumb about this next part, but the new ISO is no where to be found.
 
Old 05-15-2019, 08:52 PM   #14
linus72
LQ Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: Slack14.2/Many
Posts: 5,478

Rep: Reputation: 446Reputation: 446Reputation: 446Reputation: 446Reputation: 446
its in the top layer of your system, open a file manager and use up arrow to go to root /
or use terminal as root to go there
cd /
ls
ls shows all files. ls -al shows also hidden files
 
Old 05-26-2019, 11:44 AM   #15
NoBillYouCantHaveMyCCNo
LQ Newbie
 
Registered: May 2019
Posts: 10

Original Poster
Rep: Reputation: Disabled
Ok, so I have tried this on a couple different computers. There is no file being generated in the home dir.

There are two things that are happening. The terminal provides no feedback when I enter "chmod +x", and I am receiving this note when the program starts:

I: -input-charset not specified, using utf-8 (detected in locale settings)
genisoimage 1.1.11 (Linux)

Seems unimportant, but maybe not.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lenovo G470 aka LENOVO 20078 (laptop) ; Essential IdeaPad www.rzr.free.fr Linux - Laptop and Netbook 4 06-16-2013 07:52 AM
installation of Ubuntu Linux 11.4 Beta 2 onto a lenovo R61i laptop FUNnLIFE Linux - Software 6 04-23-2011 01:18 AM
LXer: Get a Lenovo computer cheap - and from Lenovo LXer Syndicated Linux News 1 01-07-2010 08:23 PM
moved harddrive from t61 lenovo to t60 lenovo, now cpu freezes Peter Shepard Ubuntu 3 10-26-2009 06:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration