-   Linux - Newbie (
-   -   install skype on debian sid x86_64 (

brucehinrichs 05-26-2010 01:56 PM

install skype on debian sid x86_64
Seems I have three choices:
1) Force the install of 32-bit arch using skype-debian_2.1.0.81-1_i386.deb

2) Install the 64-bit ubuntu package skype-ubuntu-intrepid_2.1.0.81-1_amd64.deb

3) Build from the source package skype-

I'm leaning toward building from source, and would like to build a deb package from the source and use gdebi or dpkg to install.

So, I have two questions:

1) If anyone has installed skype on 64-bit sid, what method worked for you?

2) Does anyone have a good link for making a deb package from source? (I have googled this and found several howtos, just want to know if someone has a favorite. ;) )

Any other thoughts on the subject are welcome!

brucehinrichs 05-26-2010 05:01 PM

Well, the first two options result in an install that crashed when I tried to sign in.

The third option worked, only I didn't have to compile anything or make a .deb package. I just extracted the .tar.bz2 and created a shortcut to the binary location. I had to do one workaround this way (from the README file in the extracted directory):

* On Debian amd64 version Skype crashes on startup with the message:
"Inconsistency detected by dl-open.c: 623: _dl_open: Assertion
`_dl_debug_initialize (0, args.nsid)->r_state == RT_CONSISTENT' failed!"
This seems to be Debian only issue with 32 bit PulseAudio libraries being
installed even if PulseAudio is not active, a workaround can be:
- Debian Lenny:
sudo chmod a-r /usr/lib32/libpulse{,.so.0.4.1}
- Debian Squeeze:
sudo chmod a-r /usr/lib32/libpulse{,.so.0.8.0,}

Bolding is mine; it is what I did for my Sid install.

Hope this helps others. :)

EDIT: The quoted workaround may work on the other two methods. I didn't find the workaround until after I tried the first two methods, therefore I didn't test it with these.

All times are GMT -5. The time now is 06:46 AM.