LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Install questions (https://www.linuxquestions.org/questions/linux-newbie-8/install-questions-227686/)

Sovetskeey 09-07-2004 09:58 AM

Install questions
 
First thing's first: :newbie: .

I've downloaded both Firefox and TeamSpeak but I have a few questions regarding installing both of them...

With Firefox, I've figured out how to get the GUI setup going but how do I make it register in the system properly? I'm assuming all the packages that are installed officially go in /etc but I can't create a Firefox folder in there. I'd like to have it in the internet folder on the start menu (or whatever it's called in Linux) and be able to set it as my default browser.

With TeamSpeak, I'm having a slightly different problem... The readme file tells me to run setup.sh and it should have a graphical setup but when I double-click on setup.sh it doesn't do anything. I also wan't TeamSpeak to show up in the Internet folder on the start menu if possible.

Any help would be greatly appreciated :) .

scuzzman 09-07-2004 10:32 AM

as for firefox, im not sertain on this, but untar it and you should be set.
as for the setup.sh - is it executable?

masand 09-07-2004 10:35 AM

hi
go to ur flder where u have ur setup.sh

like
cd /home/abcd/team

then
run
./setup.sh
and u will be up with the setup

and for ur internet menu problem
either after running the setup ,the icon may appear automatically or u need to right click on the menu start button,look for some menu-config optiona and ad the button along wiht the command and path of the executable

regards

regards

Sovetskeey 09-07-2004 10:37 AM

I realized that File Roller doesn't keep the folder structure by default... I extracted it with keeping the folder structure and the install went fine for TeamSpeak.

bruno buys 09-07-2004 10:44 AM

"With Firefox, I've figured out how to get the GUI setup going but how do I make it register in the system properly?

The package won't "register in the system", in the sense of win registry. There is no such thing in linux.

The packages also don't go to /etc. Each file inside the package go to a different place, including but not only, /etc.

To edit the start menu, assuming you use kde, right click the K icon and choose the menu editor.

To run the setup.sh you have to:

Check if it has exec permissions. right click on it, ask for the properties and go to advanced tab.
If it does, open up a terminal, "cd" to the dir, and type ./setup.sh


Post again if you get stuck.

Sovetskeey 09-07-2004 10:55 AM

I've pretty much figured out my question, except for getting it to show up in the menu... I'm using Gnome and when I right click on the Red Hat icon only Help and Unlock are available for me to click.
Is there a place to install things that has developed into a standard in the Linux community (like the Program Files folder in Windows)?

bruno buys 09-07-2004 10:58 AM

The place to install things is standard, you don't have to change it. Inside each rpm there are already paths to save the files.

Sovetskeey 09-07-2004 10:59 AM

But what about when they come as tarballs?

bruno buys 09-07-2004 11:13 AM

For tarballs it depends. Could you run the setup.sh, in the end?

Sovetskeey 09-07-2004 11:32 AM

Yeah, I just had to extract the tarball for TeamSpeak (and Firefox as well) with directories.

Rather than start a new thread, I'll just ask in this one...
I'm looking for a media player that will actually play MP3s. XMMS and the Gnome media player won't play MP3 files... I'm using MPlayer right now but I'm not exactly liking because it doesn't have shuffle...

bruno buys 09-07-2004 11:50 AM

But can you run the program, now? I mean, you extracted the tarball and installed it?

This mp3 issue with redhat is incredible! Even suse and mandrake, which are also companies, ships their systems with mp3 support.

You can add mp3 support to xmms, in order to make it play mp3. google for "mp3 redhat" and take a look. Its just a matter of installing one or two libs. I did it once, some time ago, but I don't recall the steps. But its easy.

This will help you:
http://www.techonthenet.com/linux/mp3.htm

scuzzman 09-07-2004 12:01 PM

Actually my mandrake version of xmms won't play mp3's either. Although I think it may be broken, because it really won't play crap :/.

Sovetskeey 09-07-2004 12:03 PM

Yeah, I ran Firefox a couple times, it worked fine, same with Teamspeak.
Thanks. I searched Google for "MP3 Fedora" and managed to get to this site: http://tettnang.freshrpms.net/rpm.html?id=294 .

bruno buys 09-07-2004 01:20 PM

Redhat was afraid of being sued by i-dont-know-who (riaa, i guess), if it included mp3 support in the distro. But xmms can play mp3 if you guys install one or two libs in your system. Its rather easy, in fact. Just download the correct rpm and install it.

Scuzz: xmms being broken is another thing, of course. Just reinstall it, shouldn't be difficult.

masand 09-07-2004 01:55 PM

hi there
get urself a new 1.2.10 xmms rpm from xmms.org

install it by

rpm -ivh --force xmms-1.2.10-i386.rpm

regards


All times are GMT -5. The time now is 06:29 PM.