LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-07-2006, 03:48 PM   #1
canuck_barlow
Member
 
Registered: Dec 2004
Distribution: Fedora Core 5
Posts: 64

Rep: Reputation: 15
Install Problem


Hey,

I'm trying to install GTK+ because I believe its required to run Azureus (when I tried to run it I got the following exception "Exception in thread "main" org.eclipse.swt.SWTError: No more handles [gtk_init_check() failed]"). Before I tried to install GTK+, I installed what it said it needed (glib, atk, pango, cairo). Once those were installed I tried to install GTK+ but I got an error during ./configure saying "Requested 'glib-2.0 >= 2.7.1' but version of GLib is 2.6.1". I just installed glib 2.8.5 without any problems so I don't know where to go from here.

Thanks
 
Old 01-07-2006, 03:56 PM   #2
BinJajer
Member
 
Registered: Sep 2005
Location: Warsaw, Poland
Distribution: Slackware 10.2, Caldera OpenLinux 3.1, Corel Linux (Thanks xhi!), Debian GNU/HURD etc...
Posts: 296
Blog Entries: 1

Rep: Reputation: 30
No. Not glib again. I have to report this to the creators. I had a similar dependency problem (with another package, tho) on HURD. And Slack. Hmmm....
 
Old 01-08-2006, 05:07 PM   #3
canuck_barlow
Member
 
Registered: Dec 2004
Distribution: Fedora Core 5
Posts: 64

Original Poster
Rep: Reputation: 15
k so is there anything I can do to fix it then? really all I want is azureus...
 
Old 01-09-2006, 07:37 PM   #4
leontini
Member
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Fedora Core 8-10
Posts: 61

Rep: Reputation: 15
Hey,

You seem to be having a similar problem upgrading Glib as I did. I got around it by setting the prefix for the Glib install to /usr, ie; ./configure --prefix=/usr. Then, to help out the package manager tool, I set an environment variable as follows:

setenv PKG_CONFIG_PATH /usr/lib/pkgconfig:/usr/local/lib/pkgconfig

Glib was then picked up by everything that needed it.

Hope that helps,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound Card problem(every time i install linux i have diffirent hardware problem) jacka1l Linux - Newbie 7 08-11-2005 06:10 AM
Slack 10.1 Install Problem(During Package Install) terdbird Slackware - Installation 2 04-22-2005 02:18 PM
Install problem davidjk Linux - General 10 12-24-2004 02:19 PM
problem after problem with kopete 0.8.4 install starking Linux - Software 0 08-13-2004 08:11 AM
dhcp problem in Debian netinst install..Help !! install. copter Linux - Networking 11 06-30-2004 01:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration