LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-09-2011, 01:42 AM   #1
jeethu
LQ Newbie
 
Registered: Oct 2009
Posts: 13

Rep: Reputation: 3
Install perl packages in Red-Hat


Can someone give me the command list that will install

Perl IO::Pty and Perl IO::Tty modules in RED HAT

Im trying to install a rpm package but I get the following error

Code:
perl IO::Pty  need by perl-Expect-1.17-1.rh9.rf.noarch.rpm 
perl IO::Tty  need by perl-Expect-1.17-1.rh9.rf.noarch.rpm
 
Old 08-09-2011, 02:02 AM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
First of all: upgrade your machine; RH9 is so obsolete that even
dinosaurs barely remembered it when they still roamed this earth.

2ndly: both packages come available via EPEL for current versions
of RedHat/Centos....


Cheers,
Tink
 
Old 08-09-2011, 02:13 AM   #3
jeethu
LQ Newbie
 
Registered: Oct 2009
Posts: 13

Original Poster
Rep: Reputation: 3
Quote:
Originally Posted by Tinkster View Post
First of all: upgrade your machine; RH9 is so obsolete that even
dinosaurs barely remembered it when they still roamed this earth.

2ndly: both packages come available via EPEL for current versions
of RedHat/Centos....


Cheers,
Tink
Im having RD linux server 5.5 Beta (Tikanga)

DO I need to look for 5.5 rpm packages only ?
 
Old 08-09-2011, 05:25 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2017 CentOS6.9 CentOS7.4 + 50+ other Linux OS, for test only.
Posts: 16,755

Rep: Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329
The perl modules IO::Pty and IO::Tty are in the EL5 package 'perl-IO-Tty'

Setup the EPEL.repo https://fedoraproject.org/wiki/EPEL

And install all the packages with : # yum install perl-Expect

..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can I install packages from the Red Hat DVD? katerine Red Hat 5 12-15-2009 11:11 PM
can i install software packages for Red Hat Enterprise Linux 5 from fedora CD's sagitalk Linux - Newbie 4 08-05-2008 08:39 PM
red hat 8 instillation packages? crypto2phreak Linux - Newbie 0 03-26-2004 02:22 AM
Red Hat 9 Packages helenvale Linux - Newbie 3 07-09-2003 09:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration