LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-11-2005, 08:54 PM   #1
wfstanle
LQ Newbie
 
Registered: Dec 2005
Distribution: Suse Linux Pro 9.2
Posts: 12

Rep: Reputation: 0
Install of fglrx (Radeon 9800)


Sorry for having to start a new thread but I did not find the original thread to continue it...

On Saturday I posted a question about 3D drivers for the ATI Radeon 9800 graphics card. I had a reply from wolorf with some useful information. I sucessfully downloaded the drivers ( fglrx_4_1_0-10.20.8-1.i386.rpm ) and
as instructed ran rpm to install the drivers. This is where things I ran into problems.

I was running with root priveleges so this is not the problem. Here is the output that I recieved


spark:/home/bill # rpm fglrx-4.3.0-3.7.6.i386.rpm
RPM version 4.1.1
Copyright (C) 1998-2002 - Red Hat, Inc.
This program may be freely redistributed under the terms of the GNU GPL

Usage: rpm [-aKfgpqV] [-aKfgpqVcdilPs] [-aKfgpqVcdilPsaKfgpqV] [-aKfgpqVcdilPsaKfgpqV] [-aKfgpqVcdilPsaKfgpqVK] [-aKfgpqVcdilPsaKfgpqVK] [-aKfgpqVcdilPsaKfgpqVKi] [-aKfgpqVcdilPsaKfgpqVKiv] [-aKfgpqVcdilPsaKfgpqVKiv] [-aKfgpqVcdilPsaKfgpqVKiv?] [-a|--all] [-f|--file] [-g|--group]
[-p|--package] [--specfile] [--whatrequires] [--whatprovides]
[-c|--configfiles] [-d|--docfiles] [--dump] [-l|--list] [-P|--patches]
[--queryformat=QUERYFORMAT] [-s|--state] [--nomd5] [--nofiles]
[--nodeps] [--noscript] [--addsign] [-K|--checksig] [--import]
[--resign] [--nodigest] [--nosignature] [--initdb] [--rebuilddb]
[--aid] [--allfiles] [--allmatches] [--badreloc]
[-e|--erase <package>+] [--excludedocs] [--excludepath=<path>]
[--force] [-F|--freshen <packagefile>+] [-h|--hash] [--ignorearch]
[--ignoreos] [--ignoresize] [-i|--install] [--justdb] [--nodeps]
[--nomd5] [--noorder] [--nosuggest] [--noscripts] [--notriggers]
[--oldpackage] [--percent] [--prefix=<dir>] [--relocate=<old>=<new>]
[--repackage] [--replacefiles] [--replacepkgs] [--test]
[-U|--upgrade <packagefile>+] [-D|--define 'MACRO EXPR']
[-E|--eval 'EXPR'] [--macros=<FILE:...>] [--nodigest] [--nosignature]
[--rcfile=<FILE:...>] [-r|--root ROOT] [--querytags] [--showrc]
[--quiet] [-v|--verbose] [--version] [-?|--help] [--usage]
[--scripts] [--setperms] [--setugids] [--conflicts] [--obsoletes]
[--provides] [--requires] [--basedon] [--info] [--changelog]
[--triggers] [--last] [--filesbypkg] [--fileclass] [--filecolor]
[--buildpolicy=<policy>] [--with=<option>] [--without=<option>]
spark:/home/bill #



I was not able to proceed any farther. The output appears to be the same as when I run rpm without any parameters. I believe that this is just the
standard rpm "help screen".

I need some help in getting the drivers installed. What am I doing wrong?
 
Old 12-13-2005, 07:19 AM   #2
philipvarghese
Member
 
Registered: Dec 2005
Posts: 36

Rep: Reputation: 21
please use

to install

# rpm -ivh fglrx*

to upgrade

# rpm -Uvh fglrx*

to remove

# rpm -e fglrx*(without .rpm )
 
Old 01-05-2006, 09:23 PM   #3
43r05p4c3
Member
 
Registered: Mar 2005
Location: Ontario, Canada
Distribution: Mandrake 10.0/XP Dual Boot Desktop & Gentoo 2005.1 Laptop
Posts: 79

Rep: Reputation: 15
Typically, the ATI drivers also need a --force added in there (otherwise the MESA drivers refuse to let ATI install thus causeing problems and unhappiness)
This is now:

rpm -Uvh --force fglrx*
or
rpm -ivh --force fglrx*

Steve
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
agpgart, fglrx, radeon 9800 sinistre Slackware 7 12-14-2004 09:13 AM
Radeon 9800 Install rhraz Linux - Newbie 0 03-15-2004 09:15 AM
Radeon 9800 drivers won't install iceaway Linux - Hardware 3 10-16-2003 01:23 PM
I Cant Install my New Radeon 9800 SE Help please TiMo Linux - Software 10 09-12-2003 02:23 AM
DRI not initializing on Radeon 9800 with fglrx Jawoota Linux - Hardware 0 07-23-2003 02:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration