LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Install Fluxbox (https://www.linuxquestions.org/questions/linux-newbie-8/install-fluxbox-40031/)

IeU 07-05-2003 12:14 PM

already tryed mandrake . . .

and it really suxs . . .

i think slack is a lot better to learn , to play with , to work . . . and go on . . .


some1 can help me with the up questions ?
thanks

IeU 07-05-2003 06:03 PM

up

KptnKrill 07-05-2003 06:55 PM

fluxbox ./configure errror
 
I type:
$ ./configure
and get this.
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
/home/coma/fluxbox-0.1.14/missing: Unknown `--run' option
Try `/home/coma/fluxbox-0.1.14/missing --help' for more information
configure: WARNING: `missing' script is too old or missing
checking for gawk... gawk
checking whether make sets ${MAKE}... yes
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... gcc3
checking for a BSD-compatible install... /usr/bin/install -c
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for ld used by GCC... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependant libraries... pass_all
checking command to parse /usr/bin/nm -B output... ok
checking how to run the C++ preprocessor... g++ -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for ranlib... ranlib
checking for strip... strip
checking for objdir... .libs
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... no
checking if we can lock with hard links... yes
checking if gcc supports -fno-rtti -fno-exceptions... yes
checking whether the linker (/usr/bin/ld) supports shared libraries... yes
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking whether -lc should be explicitly linked in... no
creating libtool
checking for sed... sed
checking for ANSI C header files... (cached) yes
checking errno.h usability... yes
checking errno.h presence... yes
checking for errno.h... yes
checking ctype.h usability... yes
checking ctype.h presence... yes
checking for ctype.h... yes
checking dirent.h usability... yes
checking dirent.h presence... yes
checking for dirent.h... yes
checking fcntl.h usability... yes
checking fcntl.h presence... yes
checking for fcntl.h... yes
checking libgen.h usability... yes
checking libgen.h presence... yes
checking for libgen.h... yes
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
checking nl_types.h usability... yes
checking nl_types.h presence... yes
checking for nl_types.h... yes
checking process.h usability... no
checking process.h presence... no
checking for process.h... no
checking signal.h usability... yes
checking signal.h presence... yes
checking for signal.h... yes
checking stdarg.h usability... yes
checking stdarg.h presence... yes
checking for stdarg.h... yes
checking stdio.h usability... yes
checking stdio.h presence... yes
checking for stdio.h... yes
checking time.h usability... yes
checking time.h presence... yes
checking for time.h... yes
checking for unistd.h... (cached) yes
checking sys/param.h usability... yes
checking sys/param.h presence... yes
checking for sys/param.h... yes
checking sys/select.h usability... yes
checking sys/select.h presence... yes
checking for sys/select.h... yes
checking sys/signal.h usability... yes
checking sys/signal.h presence... yes
checking for sys/signal.h... yes
checking for sys/stat.h... (cached) yes
checking sys/time.h usability... yes
checking sys/time.h presence... yes
checking for sys/time.h... yes
checking for sys/types.h... (cached) yes
checking sys/wait.h usability... yes
checking sys/wait.h presence... yes
checking for sys/wait.h... yes
checking whether time.h and sys/time.h may both be included... yes
checking for basename... yes
checking for getpid... yes
checking for setlocale... yes
checking for sigaction... yes
checking for strftime... yes
checking for strcasestr... yes
checking for snprintf... yes
checking for vsnprintf... yes
checking for catopen... yes
checking for catgets... yes
checking for catclose... yes
checking for t_open in -lnsl... no
checking for socket in -lsocket... no
checking for X... no
configure: error: Fluxbox requires the X Window System libraries and headers.
sorry folks, I know that was long. :|
What does it mean X is not installed. X is definately installed. I'm in KDE right now. How can I get this to compile? Thanks.

---------------------------------------------
KptnKrill

IeU 07-06-2003 02:24 AM

i think its thoses packages from xdevelopment . . . ( redhat , or sources , not sure)

KptnKrill 07-06-2003 09:42 AM

Thanks IeU, I installed all of the X developement packages and it compiled flawlessly. The problem is that I can't access Fluxbox. :(
I used the instructions at this site: http://anyweb.kicks-ass.net/linux/rh9/index.html
Does anyone know what is wrong. I don't think that ¨exec fluxbox¨ is right. Thanks in advance.

KptnKrill 07-07-2003 07:48 AM

more specific.
When I try to go into fluxbox from login > sessions. This little message pops up and says ¨Your X session lasted less than 10 secs blah blah. See ~/.xsession-errors¨. I'll get back to you with that log file but in the mean time does anyone know why Fluxbox only blinks on my screen for a second then disappears?

quietguy47 07-10-2003 05:24 PM

I got fluxbox installed but am having a heck of a time getting it to show up as an option for xwindow manager when I type xwmconfig.
I tried this,
Quote:

4 -
If you're using GDM as a graphical login, create a new file called fluxbox in /etc/X11/gdm/Sessions .
Then, you have to write in it the path of Fluxbox :
/usr/local/bin/fluxbox
5 -
Save and close the file.

6-
chattr +i fluxbox
and this,
Quote:

exec /usr/bin/fluxbox
this second one just kicks me back to login.
If anyone can point me in the right direction, it would be greatly appreciated.

slakmagik 07-10-2003 05:41 PM

I haven't read this thread and I'm running Slack9 so sorry if this is off.

What docs were you quoting? I looked and couldn't find anything especially relevant in zillions of files. I'm sure I did it "wrong" but it works, though some parts of it may be unnecessary.

My default runlevel is 3 but I was just testing, so I ran 'init 4' and got dumped into gdm. I added a file to /etc/X11/gdm/Sessions that is a copy of the other files in the directory, but with a new name and 'fluxbox' subsituted in the file. That added it to the menu but just brought up XFCE when I selected it. So I went to /etc/X11/xdm/Xsession and backed that up and wrote in an 'exec fluxbox' option and saved it. For whatever reason, when I brought gdm back up and selected the menu option that time, it loaded fluxbox.

If this is ot, ignore me, but how do I add an 'exit' option - ctrl-alt-backspace just respawns gdm. I saw an option in... gdm.conf maybe? Some file. But I wasn't sure. And I thought about just adding an 'init 3' instead of an 'exec foo' as an entry. I dunno.

Anyway - that's how I got flux to load from gdm. :rolleyes:

But having my ~/.xinitrc pointed to fluxbox and doing startx from runlevel 3 is no problem. I was just curious about getting a menu of all wm's and ide's.

quietguy47 07-10-2003 05:57 PM

The quotes in my post are from other posts on this site.

slakmagik 07-10-2003 07:20 PM

Other posts on this thread even. :)

So the idea of messing with xdm's Xsession wasn't inspiring? ;)

quietguy47 07-10-2003 09:53 PM

It was inspiring:)
I have it listed in xwmconfig now. But when I select it and type startx, I get /root/.xinitrc: startfluxbox: command not found

slakmagik 07-10-2003 10:15 PM

startfluxbox? Hm. I didn't mess with xwmconfig... although that probably *is* the right file after all. :) I have
Code:

fluxbox)
        exec fluxbox
        ;;

in /etc/X11/xdm/Xsession and
Code:

/etc/X11/xdm/Xsession fluxbox
in a file called /etc/X11/gdm/Sessions/FluxBox.

Sounds like it's looking for 'startfluxbox' rather than 'fluxbox'. And that's just for showing up on gdm's menu. If I want to type startx from runlevel 3 I get fluxbox automatically because it's written into my ~/.xinitrc instead of any session manager or other wm.

I dunno. This is the first distro I've ever had with Gnome and only the second with KDE so it's all weird to me. I'm just used to an .xinitrc file with something substituted for twm. :D

quietguy47 07-11-2003 11:20 AM

I figured it out, the last line in /etc/X11/xinit/xinitrc.fluxbox is supposed to be exec fluxbox, not startfluxbox( I was using kde's an an example).
I have a new problem now:D
I get this error when trying to start fluxbox
Quote:

fluxbox: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: no such file or directory
How do I fix this?

quietguy47 07-11-2003 01:03 PM

I figured it out. I needed to upgrade to gcc-3.2.3.
I am now using fluxbox.:D

slakmagik 07-11-2003 07:42 PM

Cool. Glad you got it worked out. No one should be forced to do without fluxbox. :D


All times are GMT -5. The time now is 06:38 AM.