LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Install Fluxbox (https://www.linuxquestions.org/questions/linux-newbie-8/install-fluxbox-40031/)

snocked 01-02-2003 12:36 AM

Install Fluxbox
 
I've had SuSE 8.1 installed for about a week. Can anyone pretend they're explaining something to a child and tell me how to install Fluxbox and get it in the sessions list at the graphical login? I've searched this forum and several others. People are talking about writing scripts and editing things with certain tools that I know nothing about. I downloaded the tarball and source.rpm.

hfawzy 01-02-2003 03:28 AM

Here's the instructions for installing Fluxbox :

1 -
tar -xvzf fluxbox*
2 -
cd fluxbox*
3 -
Run the configure script :
Quote:

./configure
then,
Quote:

make
finally,
Quote:

make install
4 -
If you're using GDM as a graphical login, create a new file called fluxbox in /etc/X11/gdm/Sessions .
Then, you have to write in it the path of Fluxbox :
/usr/local/bin/fluxbox
5 -
Save and close the file.

6-
chattr +i fluxbox

I don't know how to add sessions in other login managers like kdm or xdm :(

Hope that helps,
hfawzy

MasterC 01-02-2003 04:33 AM

Cool, nice instructions :)

fyi kdm uses the settings from xdm.

snocked 01-02-2003 06:06 AM

I'm stuck in step 4. KDM does use xdm, but once I get to file:/etc/X11/xdm there's no Session directory. There's a bash Xsession file, but running that just logs me out and bring graphical login back up.

MasterC 01-02-2003 06:32 AM

Nah, if you are using kdm you create an entry in:
/etc/X11/wmsession.d

Mine looks like this in Mandrake:
Code:

root@masterc:/etc/X11/wmsession.d# ls
01KDE  02GNOME  03WindowMaker  04Enlightenment  05blackbox  06XFce  16fluxbox

And if I open up the text file 16fluxbox it looks like this:
Code:

root@masterc:/etc/X11/wmsession.d# cat 16fluxbox
NAME=FluxBox
ICON=fluxbox.png
EXEC=/usr/X11R6/bin/startfluxbox
DESC=A Light and nice looking window manager
SCRIPT:
exec /usr/X11R6/bin/startfluxbox

And then:
Code:

root@masterc:/usr/X11R6/bin# cat startfluxbox
/usr/X11R6/bin/bsetroot -solid Black
exec /usr/X11R6/bin/fluxbox
root@masterc:/usr/X11R6/bin#

HTH

Cool

snocked 01-02-2003 06:45 AM

No /etc/X11/wmsession.d

file:/etc/X11

dirs:
fs
kd3
lbproxy
proxymngr
rstart
susewm
twm
xdm
xinit
xkb
xserver
xsm

textfiles:
qtrc
XF86Config
X86Config.saxsave
Xmodmap
Xmodmap.remote

snocked 01-02-2003 07:00 AM

I searched for that file and it doesn't exist.

snocked 01-02-2003 07:04 AM

Umm okay. I saw fluxbox in the list of sessions at login and chose it. It works fine. I don't understand how I didn't have to do anything and everyone else had to create and edit files. Weird.

Thanks for your help anyhow guys! I appreciated it.

MasterC 01-02-2003 07:08 AM

.... Hmmm ....

So:
updatedb &&
locate wmsession.d

Brought up nothing, and the directory is non-existent. Very odd indeed. I can only guess it's not KDM you are using? You don't have gdm there either though? How odd indeed. Can you post here what's in your xdm directory?

To paste from a terminal:
highlight the text to be posted, click inside the browser, and then press the middle button to paste the highlighted information.

Cool

MasterC 01-02-2003 07:10 AM

:D

It probably depends on what file version of flux you install. If it's a SuSE specifc rpm I'd think that it might create the necessary entries for you. But it looks like it wasn't one, yet it still worked. SuSE really does a decent job at doing things for you. This can be good, or bad, depending on how you look at things.

At least you've got it running! Flux rocks :)

Cool

snocked 01-02-2003 07:22 AM

snocked@linux:/etc/X11/xdm> ls
BackGround RunChooser Xresources Xsetup chooser xdm-errors
GiveDevices TakeDevices Xservers Xstartup pixmaps xdm-pid
README.SuSE Xaccess Xservers.fs Xwilling sys.xsession
README.security Xreset Xsession authdir xdm-config

macewan 01-02-2003 07:31 AM

just switch to using gdm - it's easier

mp- 01-14-2003 06:43 PM

How do I switch to gdm?

macewan 01-14-2003 07:34 PM

what distro are you using?

Panorama 02-01-2003 06:09 PM

Sorry to bring this up but I'm a newb at this. I have RedHat 8.0 installed and when I try to configure it I get:

Code:

[root@localhost fluxbox-0.1.14]# ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
/home/Admin/Duvien/Downloads/LinuxShell/fluxbox/fluxbox-0.1.14/missing: Unknown
`--run' option
Try `/home/Admin/Duvien/Downloads/LinuxShell/fluxbox/fluxbox-0.1.14/missing --help' for more information
configure: WARNING: `missing' script is too old or missing
checking for gawk... gawk
checking whether make sets ${MAKE}... yes
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
[root@localhost fluxbox-0.1.14]#

Can anyone help me?


All times are GMT -5. The time now is 05:24 AM.