-   Linux - Newbie (
-   -   Inspiron 2600 install success (finally) - Dual boot now gone bad (

Stavrowsky 04-29-2011 02:28 PM

Inspiron 2600 install success (finally) - Dual boot now gone bad
Dual Boot Gone Bad

I have been trying to set up a dual boot laptop on an old Dell Inspiron 2600. I got the machine cheap, and it is in excellent condition. I have upgraded the Bios to A11 (it was A4 when I got it) and put in a 40 Gig HD. It is maxed-out in memory at 360 Mb. It has the awful (by today’s standards) Intel i810 video mess.

I created an NTFS (primary) partition on the first half of the drive and installed XP, updated through SP3. I then attempted to install Debian 6 (squeeze) on the second half.
I was unable to get anywhere with an installation using a squeeze Live CD. The screen just goes blank about 60 seconds into the installation, and everything freezes up. In rescue mode, I can get some screen play, but the rendering is awful and half of what you do is actually off the screen and you can’t see what it is you are doing.

I hooked up a separate monitor, and was able to watch the installation just fine until it reached a certain point in the boot-up, then everything again went blank and the machine again froze up. I tried Ubuntu 10.10, Ubuntu 10.04 LTS, Mint 10, and Ultimate Edition 10.10 with varying degrees of success, but none completing and working.

The Ubuntu 10.04 LTS actually installed, but I could not get sufficient graphics in either a terminal (entered at the end of the install process just before re-booting) or booting to text only mode to sudo a change to the xorg.conf file that was native to the system, rather than to the installation package itself (which goes away when you reboot).

I was able to install ‘squeeze’ using the ‘expert graphical install’ mode under ‘advanced options’ (it lets you select a screen resolution when it starts the install), and when I got to the end of the installation, before re-booting, I told the system to open a monitor as ‘root’, and wrote what I thought would have been an appropriate xorg.conf file in the /etc/X11 subdirectory using nano (monitor and driver specs, as well as suggested xorg.conf entries obtained elsewhere on the web).


Section “Device”
        Identifier        “Intel i830”
        Option                “UseFBDev” “true”
        Driver                “i810”
        BusID                “PCI:0:2:0”

Section “Monitor”
        Identifier        “Generic Monitor”
        Option                “DPMS”
        HorizSync        28-49
        VertRefresh        43-72

Section “Screen”
        Identifier        “Default Screen”
        Driver                “i810”
        Monitor        “Generic Monitor”
        DefaultDepth        24

        SubSection “Display”
                Depth        24
                Modes        “1024x768” “800x600” “640x480”

The installation seemed to go well using the ‘expert graphical install’ mode of the ‘advanced options’ installation option, and I installed the above-listed xorg.conf file in the system’s /etc/X11 subdirectory…. Then rebooted.

Nothing. The machine freezes up, I think before it even reads the xorg.conf file. It is noteworthy, I think, that squeeze does not normally use an xorg.conf file at all. It gets it’s X loading instructions elsewhere, and though I have inserted an xorg.conf file in the past to get squeeze to set up for a desktop monitor I was using on a different system (successfully), on this little Dell it never seems to get that far.

So…… next step was to scotch the directories containing the squeeze installation, and install lenny in its place (which DOES normally use an xorg.conf file). Again in expert graphical install mode (so that you can select your res going in). At the end of the installation I modified the xorg.conf file as before, finished the ionstallation, rebooted, and violla! Success! Everything seemed to be working just fine until I tried again to reboot into XP.

GRUB lists the windows option, but when I try it, I get a message that says:


Booting ‘Microsoft Windows XP Home Edition’
error: no such partition
Press any key top continue

If I go back, highlight the XP option and enter ‘e’, I get a screen that says I am in an emacs-like line editor, but with even more limited function.

The code on the screen is:


set root= (hd0,0)
chainloader +1

If I edit it to:


set root = (hd0,1)
chainloader +1

and hit C-x, it boots directly to XP. However, the change is apparently not saved (and I cannot figure out how to save it), so that during any subsequent reboots, GRUB again tells me that the XP partition doesn’t exist.

I’M SO CLOSE! Can somebody help me and tell me how to edit GRUB so it again recognizes the partition… or reinstall GRUB…. or let me know if the problem is with the XP MBR…. And if so, maybe hopefully lead me to how to fix THAT issue without screwing up the Debian install (I know this isn’t an “UGH”- Windows forum). If worst come to worst, I can delete all the Linux partitions, use my Windows install disk to repair the MBR, and reinstall lenny…. Hopefully with GRUB not losing XP this time. I hate to do it because it has taken me a couple of days to get ANY form of Linux actually working right on this machine….. but at least I know how to do it now and what distro will actually work.

Also, anybody with a clue as to why squeeze won’t boot after what appears to be a successful installation (with the above-listed xorg.conf file in place) and what I can do to fix that issue would also be appreciated. It will be nice to have a system installed that has current support next year.


TobiSGD 04-29-2011 02:38 PM

Just boot into Debian and edit the file /boot/menu.lst. You have to do this as root, or you won't be able to save your changes.
Squueze uses KMS (kernel mode setting) by default, that may be your problem. Try if it works when you add nomodeset to the kernel line in Grub.

Stavrowsky 04-29-2011 03:10 PM


Originally Posted by TobiSGD (Post 4341094)
Just boot into Debian and edit the file /boot/menu.lst. You have to do this as root, or you won't be able to save your changes.
Squueze uses KMS (kernel mode setting) by default, that may be your problem. Try if it works when you add nomodeset to the kernel line in Grub.

There is no 'menu.lst' file in the /boot subdirectory to edit.

Would this perchance be a file somewhere on the ntfs partition? Debian won't let me mount the partition to inspect it.

TobiSGD 04-29-2011 03:12 PM

Sorry, I gave you the wrong path. You will find the file in /boot/grub/.

Stavrowsky 04-29-2011 03:53 PM


Originally Posted by TobiSGD (Post 4341129)
Sorry, I gave you the wrong path. You will find the file in /boot/grub/.

Nope. No menu.lst file. HOWEVER.... I did find a grub.cfg file with about 67 lines of code and a BIG BOLD STERN WARNING to 'DO NOT EDIT THIS FILE', as it is automatically generated. I found an entry near the end of the file that said

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda1
menuentry "Microsoft Windows XP Home Edition" {
        set root=(hd0,0)
        chainloader +1

I ignored the stern warning and edited the set root line to:

  set root=(hd0,1)
saved it, and rebooted.

It worked, and for now everything is right with the world.

Thanks for the help!

We can mark this issue as "solved".

TobiSGD 04-29-2011 04:32 PM

If you have a grub.cfg instead a menu.lst then you are using Grub2. Lenny has used Grub1, the change to Grub2 came with Squeeze. Are you sure that you have installed Lenny?

By the way, the DON'T EDIT-warning is there for a reason. That file is auto-generated. The next time a system update launches the command update-grub your changes will be lost.

Stavrowsky 04-30-2011 12:23 PM

The installation is definitely lenny. When I came to the portion of the installation for installing Grub (2nd to last step), there was the option of installing Grub 1 or Grub 2 (beta). It seems to me the default was Grub 2 (with a warning that it was the latest iteration of Grub and would be incorporated as standard on the next Debian release and may change by the time that modification comes out in final stable edition), and since it was, as I recall, the default, I went with it.

Hopefully the 'stable' release will fix whatever issue caused it to lose my XP partition in the first place, and any updates won't sandbag me. I hope not anyway. I intend this laptop as a present for a nephew who lives about 1200 miles away, so I won't be there to re-assert any needed changes if it glitches again.

On the other hand, he'll have the XP installation disk, so if worst comes to worst, he'll be able to scrub the disk and at least re-install that for his use. I'm putting Linux on it in dual boot mode just to introduce him to Linux. Who knows.... if he likes it and uses it (how can he not? Right?), maybe he'll come back to this site and figure out how to fix any glitches himself.

All times are GMT -5. The time now is 06:39 AM.