-   Linux - Newbie (
-   -   INIT: Id "X" respawing too fast: disabled for 5 minutes (

aaronruss 12-03-2004 12:10 AM

INIT: Id "X" respawing too fast: disabled for 5 minutes
I got a problem. I did some update's and every thing went well but later that night the power went out and when it come on it boots up and says

INIT: Id "X" respawing too fast: disabled for 5 minutes

every 5 minutes it says the same thing. how do I run the X config again I can get to a command line. what is the command and where is it at.

I running Fedora core release 3 (Heidelberg) Kernel 2.6.9-1.681_FC3 on an i686

What should I do to get this fixed?

zhangmaike 12-03-2004 01:07 AM

Try running "X -configure", that'll generate a config file for you... providing X is in your path, of course. If it isn't... I think it's usually in /usr/X11R6/bin

Hope this helps.

aaronruss 12-03-2004 07:03 PM

I tried using X -configure and it tried running and told me what lines in my /root/ file to edit so i did. after that I run it again and it started up to a blank black screen.

I had to use the reset button to get out of it.

I have never had linux act like this over the power going out. What changed with this version?

I don't know what else to do!

zhangmaike 12-03-2004 07:15 PM

Hmmmm... Are you sure it was the power going out and not the updates that is causing X to not work?

You might want to try copying your file over the old one (cp /etc/X11/xorg.conf) so that the respawning X will load it automatically. I'm not sure, but I'm thinking that maybe X isn't starting up properly (black screen) because you already have it running (the respawning process).

Also, if that was the case, "X -configure" might not have detected things properly... (I remember something similar happening to me at one time). So, if there's a way to do so, you may want to boot into a login shell instead of X as it might make troubleshooting / fixing the problem easier.

By the way, I'm not sure how unresponsive your computer was at the time of the latest crash, but usually, when X stops working properly, you can force it to exit (or in your case, restart) with Ctrl+Alt+Backspace without having to reboot your computer.

aaronruss 12-03-2004 10:36 PM

OK I edited my inittab file so my Box will boot in run level 3.
and I copied the /root/ to /etc/X11/ I also copted it to /X11/xorg.conf just in case.

when I run the command startx I get this error:

hostname unknown host

Xauth: error while loading shared libraries: cannot open shared object file: no such file or directory

Xauth: error while loading shared libraries:
cannot open shared object file: no such file or directory

What do I do now?

zhangmaike 12-03-2004 10:47 PM

Try "locate libXmuu" and post the results. Run "updatedb" (as root) first, if necessary, to build the locate database.

aaronruss 12-03-2004 11:25 PM


I deleted xorg.conf and and run X -configure after that I had to edit the file /root/ manualy when I was done I run X -config /root/ and the screen went blank with a X for the mouse. The mouse can be moved around but Gnome never did load I also copied /root/ to /etc/X11/xorg.conf but when I run startx I get the same error.

zhangmaike 12-03-2004 11:34 PM

"X -config /root/" only runs the X server, it doesn't startup gnome. However, the fact that the X cursor comes up means that it's working fine. If you want to test it without overwriting your old file, try this:

/usr/X11R6/bin/xinit /usr/bin/gnome-session -- /usr/X11R6/bin/X -config /root/

Change the paths if yours are different.

That should run gnome after X starts up with your new config file.

EDIT: Corrections made.

aaronruss 12-04-2004 12:00 AM

I tried running /usr/X11R6/bin/xinit /usr/bin/gnome-session --

and got this error:

Xinit: error while loading shared libraries:
cannot open shared object file: no such file or directory

I located it at /usr/X11R6/lib/

Remember I can only get X to come up now by running /usr/X11R6/bin/X -config /root/

startx gives errors:

Xauth: error while loading shared libraries: cannot open shared object file: no such file or directory

Xauth: error while loading shared libraries:
cannot open shared object file: no such file or directory

zhangmaike 12-04-2004 12:16 AM

Hmmm... Since you have the library and X insists that it can't find it, maybe the path variable isn't set right? Try running:


and post the result from that.

aaronruss 12-04-2004 12:32 AM

OK I used YUM to update from the command line and it updated a lot of xorg stuff xorg-lib was one of them.

after that I rebooted and my box come up in runlevel 5. I did not change it to that level I had it in 3 it change on its own after the updates. the splash screen come up showing the bar loading the box froze. I had to reset it and noticed the next time it froze the last thing loaded was

starting HAL daemon OK
after that it locked up

It does not give me an option for text mode. How can I get it back to runlevel 3 so I can get the info you asked for?

zhangmaike 12-04-2004 12:41 AM

Now that X starts up by itself, the info I wanted is irrelevant - the libraries are apparently being loaded.

Unfortunately, at this point, I don't have any more advice to give since I do not use Fedora myself, I use Slackware.... so anything Fedora specific is alien to me.

If you want to get back into runlevel 3, you'll have to edit inittab like you did before. Since Fedora is locking up, you might need to use a boot disk to do that...

Perhaps you should post in the Fedora forum.

They can probably be of greater help.

aaronruss 12-04-2004 12:48 AM

Thanks For all your help.

wmakowski 12-04-2004 08:49 AM

With Fedora you can use the install CD to boot up in rescue mode. After ISOLINUX comes up and you get to the initial screen enter linux rescue at the boot prompt. It will then ask you for your language and search for your Linux installation. Once it finds the installation it will mount to /mnt/sysimage. The rescue mode then puts you into a shell. At this point you are running as root and have a stripped down version of linux where you can run several utilities, even rpm. This will allow you to change /mnt/sysimage/etc/inittab so the next time you boot it will go to the command line. While in rescue you can also chroot /mnt/sysimage /bin/bash to set your root directory to its normal place.

Now for the bad news, I made some updates to my RedHat 7.3 system a while back and ran into the same problem you did with the respawning too fast: disabled for 5 minutes. I also recall seeing the error on My upgrade was from glibc 2.2 to glibc 2.3 which involved about 7 packages. I did this because I wanted to upgrade another package which had dependencies on the newer version of glibc. Things were fine until I rebooted and X had issues.

These updates also had an effect on rpm causing it to segfault when I would execute an update or install. I tried using rescue mode to put the packages I had upgraded back to their original version. However, after endless googles and repair attempts I never did get things working again. As a final solution I ended up performing a reinstall. I seriously hope you have better luck than I did. Looking back I should have known better since any applications with ties to glibc 2.2 would end up malfunctioning without remorse.


fortezza 12-04-2004 04:22 PM

I have this problem when I update the kernel via Yum but forget to reinstall the NVidia drivers before rebooting. Here are a few related tips:

After X is disabled for 5 minutes, you can login as root and reinstall NVidia Drivers to match your new kernel ( assuming this is the problem )

If you can not get to the command prompt in the default terminal, try pressing and holding <ctrl> and <alt> keys simultaneously, and then press and release the <f2> key. This will switch you to the second terminal session ( by default Fedora runs 6 terminal sessions, keys <F1>-<F6> , and maps the X Server started in each terminal to the terminal Function key Number + 6, so if you type "startx" in terminal 1, <ctrl>+<alt>+<F7> will switch you to that X Server window )

At the command line, as root, you can type "init 3" or "/sbin/init 3" to switch to run level 3. To make this the default runlevel, edit "/etc/inittab" file so that the default run level is 3.

If you want to change the graphics driver ( module ) XServer uses., you can edit ( for Xorg ) "/etc/X11/xorg.conf" driver section to change driver it loads. The generic Nvidia drive module name is "nv", which you have to manually change to read "nvidia" to us NVidia's closed source driver.

Hopefully some of this is useful, I do not know the cause of the problem, but if you use an Nvidia card, most like this will help.

All times are GMT -5. The time now is 08:51 AM.