Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 11-23-2003, 12:51 AM   #1
LQ Newbie
Registered: Nov 2003
Distribution: Ubuntu, CentOS, FreeNAS
Posts: 26

Rep: Reputation: 15
Unhappy incorrectly configured video at installation

I installed debian 3. woody and incorrectly configured my video as ati. It should have been vesa vga. this is my first linux install outside of messing around a bit with knoppix. is there a config file i can edit or something? thanks in advance.
Old 11-23-2003, 02:52 AM   #2
Senior Member
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,690
Blog Entries: 9

Rep: Reputation: 45
When I tried to install debian, it was "MEGA" hassle. I couldn't startx it wouldn't let me config my graphics card - I found out that it's because the driver for it is openly available, but not gpl and hence not included with woody (also the driver would only work with a 2.4.xx kernel, and not the default 2.2.xx kernel that I'd installed with woody).

I did eventually sort this out, but as I'm a bit of a glutton for punishment, and never managed to get the graphic interface looking anywhere as near as nice as the default mandrake system I'm used to, I cheated.

The cheat - well, if you found that everything (well nearly everything) worked with knoppix from a cd then the cheat is to just install the knoppix cd to your hard drive - it becomes a debian unstable/testing install (basically) and don't forget that debian developers are pretty conservative people - it takes ages to have an "unstable" package moved to "stable" - the unstable and testing might have a few minor "hiccups", but are very much more up to date than stable debian. (if it worked from a knoppix cd, it should work from your hard drive!)

If you did install the knoppix to hard drive, you will find that it is nearly as easy as a mandrake install. Have a good look through the knoppix forums, you should be able to find all the stuff you need there - then just follow instructions for debian unstable.

You would have to do a few things like creating a proper user account, proper root and passwords, but from memory, that's pretty straight forward.



Last edited by bigjohn; 11-23-2003 at 02:56 AM.
Old 11-23-2003, 03:42 AM   #3
Senior Member
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Yeah. I assume you're referring to the X Window System setup. There are three common way to edit the preferences:

1. Edit the /etc/X11/XF86Config-4 file. This requires a little experience but it's the best way.
2. Run xf86config. It's a script that comes with xfree86 so all distros have it if xfree86 is installed. This is entirely text based.
3. Use dpkg to reconfigure it. To reconfigure any installed package you type dpkg-reconfigure <package name>. In this case the package name would be "xserver-xfree86". This is ncurses (dialogue) based.
Old 11-23-2003, 05:28 PM   #4
Bruce Hill
HCL Maintainer
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Gentoo (all servers at work are openSUSE)
Posts: 6,937

Rep: Reputation: 128Reputation: 128
Re: incorrectly configured video at installation

Originally posted by fgw
I installed debian 3. woody and incorrectly configured my video as ati. It should have been vesa vga. this is my first linux install outside of messing around a bit with knoppix. is there a config file i can edit or something? thanks in advance.
This is easily done. Here's how ->

You get to a console by pressing Ctrl+Alt+Backspace. You may already be there if the X server doesn't work because of the wrong video driver. Then make sure you have a prompt that ends with # which means you are root. If not, type su and then enter your password. Then type ->
# nano /etc/X11/XF86Config-4
which will open this file in a nano text editor. Once this happens, use the arrow keys on your keyboard to move to the line that says ->
Driver "ati"
and change it to
Driver "vesa"

If memory serves me correct, that's all you will need to do to use the vesa driver rather than the ati driver.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
df reporting incorrectly bigtl Linux - General 2 06-23-2005 06:47 AM
intalling rpms incorrectly icanspellnew Linux - Newbie 1 07-15-2004 04:17 PM
Pages served incorrectly jeffpoulsen Linux - Software 6 04-03-2003 08:34 PM
No Configured Video davidb Linux - Software 2 02-15-2001 01:23 PM
Xconfigurator probes AGP video incorrectly ryan Linux - Software 2 12-20-2000 11:25 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:17 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration