LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   I'm not successing to install mouse (https://www.linuxquestions.org/questions/linux-newbie-8/im-not-successing-to-install-mouse-117091/)

rytrom 11-17-2003 01:32 PM

I'm not succeeding to install mouse
 
I've been trying to install a mouse to a fresh installed RD9 for last two days. I checked the forums and found a lot of recomendations and advice how to resolve mice problems but still no success - my mouse (logitech, 2buttons and whell, optical, ps/2) is jumping on X screen and out of control. I played with XF86Config and tried "auto" and PS/2 in Protocol - no reaction.

What to check else?

my config contains:

Section "Input device"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "4 5"
EndSection

druuna 11-17-2003 01:47 PM

Which X version are you using??

I'm not entirely sure, but this should work (for version 4):

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Device" "/dev/psaux"
Option "Name" "Autodetection"
Option "Protocol" "imps/2"
Option "ZAxisMapping" "4 5"
EndSection

Not sure about this one: Option "Protocol" "imps/2"
That could also be: Option "Protocol" "ps/2"

rytrom 11-17-2003 01:59 PM

I'm using version 4.3.0
I tried your configuration - the same result. In the log I see nothing suspicious. Other ideas?

druuna 11-17-2003 02:13 PM

Did you try the imps/2 and the ps/2 version?
Did you look in both (~/.X.err and /var/log/XFree86.0.log) logfiles?
Was your mouse working during install or in a none GUI environment?
What mouse is it. A mouseman, USB or PS/2 things like that.

rytrom 11-17-2003 02:23 PM

- I tried imps/2 and ps/2 and auto.
- XFree86.0.log contains no lines with (EE) or (WW) [should I look for smth. else?]
- I didn't find ~/.X.err file [does it exist?]
- In a non GUI console the mouse is not functional (the same jumping) and during installatino I don't remember already whether it was functioning
- the mouse is Logitech optical ps/2 mouse with 2 buttons and wheel

I'm a newbie in Linux and maybe don't pay attention to something important. Pls. give even very obvious recomendations.

druuna 11-17-2003 02:55 PM

Did you try these options too:

Option "Emulate3Buttons" "off"
Option "Buttons" "4"

The 4 could be a different number.

Config should look like this:

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Device" "/dev/psaux"
Option "Name" "Autodetection"
Option "Protocol" "imps/2" (<< or ps/2)
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "off"
Option "Buttons" "4" (<< or other number [5])
EndSection

Are there any lines in the XFree86.0 file mentioning mouse/inputdevice (even 'correct' ones)??

PS: It is possible that you do not have a ~/.X.err file.

rytrom 11-18-2003 02:32 AM

whell, I put all parameters as you supposed - the same.
what I have in a log regarding mouse:
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.0.3, module version = 1.0.0
Module classL XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.4
.....
(==)ATI(0): Silken mouse enabled

These are all lines containing word 'mouse'

druuna 11-18-2003 02:01 PM

I do have more in my logs, but that was to be expected :(

(**) |-->Input Device "Mouse[1]"


(**) Option "Protocol" "imps/2"
(**) Mouse[1]: Protocol: "imps/2"
(**) Option "CorePointer"
(**) Mouse[1]: Core Pointer
(**) Option "Device" "/dev/psaux"
(**) Mouse[1]: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) Mouse[1]: ZAxisMapping: buttons 4 and 5
(**) Mouse[1]: Buttons: 5

(II) XINPUT: Adding extended input device "Mouse[1]" (type: MOUSE)

Except the last one, all taken from the config file.

I don't think I can help you any further. Only advice I've left:

- Disable your mouse in the non-GUI environment, I've heard stories about these drivers interfering with eachother.
- Try defining your mouse as a 'simple' 2 button mouse, get that working a go from there.

rytrom 11-18-2003 02:50 PM

thank you for your help!


All times are GMT -5. The time now is 01:41 PM.