LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Closed Thread
  Search this Thread
Old 02-23-2011, 01:17 AM   #1
savio84
LQ Newbie
 
Registered: Feb 2011
Posts: 2

Rep: Reputation: 0
Identifier spec problem in bison 2.4.1


hi

Iam writing compiler for ada

i have a problem with identifier spec.

For example

procedure average(a,b,c :in Float32;z ut Float32) is
begin
z:=(a+b+c)/3.0;
end average;


identifier_spec :
identifier_list
{
if(trace) printf("Identifier_spec 1\n");
$$.st_ptr=mknode1("identifier_spec",NULL,$1.st_ptr,NULL,NULL);
}
|identifier_spec COMMA_TOK identifier_list
{
if(trace) printf("Identifier_spec 2\n");
$$.st_ptr=mknode1("identifier_spec",NULL,$1.st_ptr,$3.st_ptr,NULL);
}
;

identifier_list :
IDENTIFIER_TOK
{
if(trace) printf("Identifier_list\n");
$$.st_ptr=mknode1("identifier_list",NULL,mknode1("IDENTIFIER_TOK",NULL,mknode1($1.name,NULL,NULL,NUL L,NULL),NULL,NULL),NULL,NULL);
}
;


then in identifier list i should get a,b,c
but iam only getting a in identifier list b in mode c in type mark.

Can anybody please help me to sort out this problem?
 
Old 02-23-2011, 04:15 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
Please post your thread in only one forum. Posting a single thread in the most relevant forum will make it easier for members to help you and will keep the discussion in one place. This thread is being closed because it is a duplicate.
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with bison 2.4.1 savio84 Programming 1 03-25-2011 08:55 PM
Is there any support for bison-bridge and bison-locations in flex on windows systems? rami alkhateeb Linux - Software 0 12-29-2010 10:10 AM
Problem installing Bison 2.4.1 on Suse 11.1 Takuan Linux - Newbie 1 10-13-2009 11:59 AM
Bison and Yacc Compatibility Problem oulevon Programming 1 10-23-2005 11:56 PM
bison, flex and make problem ChimpFace9000 Programming 4 05-19-2002 08:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration