LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-12-2009, 03:14 PM   #1
auclark@wsu.edu
LQ Newbie
 
Registered: Dec 2009
Posts: 2

Rep: Reputation: 0
ICP raid controller, no automatic rebuild of raid 5 after replacing bad disk


Hi;
I have a 5 disk raid 5 array that is composed of SATA A:0,1; SATA B: 0,1, and SATA C:0, and one of the disks (SATA A:0) recently went bad on me. I have an ICP raid controller that is about 5 years old. I replaced SATA A:0. After rebooting, i went into the controller and verified that it saw the disk in the hard-disk info section...there i noticed that in the "status" section, that the SATA C:0, SATA B:1 disks were listed as being "in array", the SATA A disks were blank, and the SATA B:0 disk was listed as "fragment". When I go into the "repair array" section, the controller tells me that there are no arrays that are in failure, error, or need to be rebuilt. This puzzles me, as I thought the controller would know that the array needs to be rebuilt after replacing the disk and I don't see a way to initiate a rebuild.

If i just let the server boot after replacing the disk, then I get back that there are the correct number of disks in the raid 5 and that it is ready, however, the screen then goes blank and i get a blinking cursor and the system seems to hang. There are no activity lights on any of the drives associated with the raid 5, which makes me think that the system is not rebuilding the array at this point.

Any information would be greatly appreciated as I am at the end of my experience level on this one.

Thank you;
Aurora
 
Old 12-13-2009, 10:20 AM   #2
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,237

Rep: Reputation: 121Reputation: 121
Did you add the new disk to the array before trying to repair the array?
 
Old 12-14-2009, 08:12 AM   #3
auclark@wsu.edu
LQ Newbie
 
Registered: Dec 2009
Posts: 2

Original Poster
Rep: Reputation: 0
I have never tried to "repair the array" at all, actually. But something automatic may have happened that I am not aware of.

To give you a better timeline, when I first had the disk error and I rebooted the system, the server was able to "recover the journal" with the bad disk intact. After a couple of days, when I got the good disk in from the vender, I rebooted the server and went into the raid configuration utility and see what the serial number was on the bad disk, then i powered the server down again and pulled out the disks to correlate to their SN's. I then rebooted with the bad disk still in the array, b/c i wanted to look more online about what I needed to do once the disk was replaced. The server booted fine, then after about an hour it started throwing out errors and while users could log on, they could not access all or part of their home directories.

At this point, i went back to the server and the interface screen had a bunch of errors on /sda which is where the bad disk was. So, I powered down the server and replaced the disk and that is where I got to the point of my original email, with no rebuild occurring.

A
 
Old 12-14-2009, 10:54 AM   #4
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,237

Rep: Reputation: 121Reputation: 121
Well, it sounds like you have a motherboard RAID aka FAKERAID. If that's the case, go into the BIOS and add the new disk to the array. There should probably be a place to repair the array if adding it doesn't make it go through the repair procedure. It may take a long time, so don't get discouraged and shut it down in the middle of the repair.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RAID controller - problem with automatic synchronisation dlugasx Linux - Server 2 07-16-2009 02:17 AM
disk attached to builtin- raid controller Ammad Linux - General 3 02-21-2009 01:46 AM
replace failure disk and rebuild RAID with mdadm ufmale Linux - Software 0 11-15-2007 02:24 PM
RAID controller card override onboard RAID controller? Dr. Psy Linux - Enterprise 1 05-30-2005 10:35 AM
ICP Vortex SATA RAID on OpenBSD 3.4 DraconianTimes *BSD 1 12-25-2003 01:47 AM


All times are GMT -5. The time now is 04:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration