LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-18-2009, 09:50 PM   #1
lovenyah
LQ Newbie
 
Registered: May 2009
Posts: 5

Rep: Reputation: 0
Unhappy Ibuntu 8.1 Can not figure out how to connect to high speed internet


We just switched from Xp to Ibuntu. We have been through so many threads on how to hook the internet up to it, but have failed. I can not figure it out for the life of me. We use a wired high speed internet called Road Runner. The interent worked fine on XP, but now we can't seem to figure it out. Any help would be great.

Annie

Last edited by lovenyah; 05-18-2009 at 09:51 PM.
 
Old 05-18-2009, 11:51 PM   #2
tuxtroll
LQ Newbie
 
Registered: May 2009
Posts: 11
Blog Entries: 1

Rep: Reputation: 0
can you provide more info..is it ethernet/wifi , what network interfaces you are using, config you used on XP etc.
 
Old 05-19-2009, 12:10 AM   #3
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Yeah this information is not enough to help you out. Could you tell how did you connect to net in Xp? Did yo dial for it? Or just connect the cable? Is it wired or wireless? Any information regarding ip addresses you configured in Xp.
 
Old 05-19-2009, 08:04 PM   #4
lovenyah
LQ Newbie
 
Registered: May 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Question As mentioned before

I mentioned before it's wired connect with high speed. Ethernet is what we use. We use a router also, not sure if that matters. We can connect from xp no problem.. but ibuntu has been a hassle for us. I'm not sure what else to do but give up. There doesn't seem to be an option we can use for our internet.
 
Old 05-19-2009, 08:10 PM   #5
dxqcanada
Member
 
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
You have a wired connection to a switch port on the Router (the Road Runner is connected to the Router's WAN port) ?
If so, is the Windows PC also connected to the switch ports ?
 
Old 05-20-2009, 12:09 AM   #6
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Quote:
Originally Posted by lovenyah View Post
I mentioned before it's wired connect with high speed. Ethernet is what we use. We use a router also, not sure if that matters. We can connect from xp no problem.. but ibuntu has been a hassle for us. I'm not sure what else to do but give up. There doesn't seem to be an option we can use for our internet.
Ok. So can you ping your router from Ubuntu? If not then boot into windows, go to run type cmd. Then on the prompt type ipconfig and then see what ip address is configured.
Configure your Ubuntu to have similar ip address and see if there is internet in Ubuntu.
I use Ubuntu as well and I never had issues connecting to internet with adsl modem / router.
 
Old 05-23-2009, 04:11 PM   #7
lovenyah
LQ Newbie
 
Registered: May 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Unhappy Ibuntu 8.1.

We do not have windows on the computer any more. We used the reformat option when we loaded Ibuntu 8.1 and Linux. I'm not sure how to ping the router?

We tried to reinstall the driver for the ehternet card for Linux thinking that was the problem, but it didn't solve anything. Is it possible his computer is not compatible with this program?
 
Old 05-25-2009, 12:07 AM   #8
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Ok. On Ubuntu type

ifconfig -a
and post the output.
 
Old 05-25-2009, 01:18 AM   #9
lovenyah
LQ Newbie
 
Registered: May 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Ifconfig -a log

Here is the log, Thanks!



-----------------------------

eth0 Link encap:Ethernet HWaddr 00:40:ca:98:c3:af
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:23 Base address:0xc000

eth1 Link encap:Ethernet HWaddr 00:1e:e5:d6:90:d7
inet6 addr: fe80::21e:e5ff:fed6:90d7/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:246248 errors:0 dropped:0 overruns:0 frame:0
TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:15313695 (15.3 MB) TX bytes:5940 (5.9 KB)
Interrupt:18 Base address:0xbc00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:276 errors:0 dropped:0 overruns:0 frame:0
TX packets:276 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:17248 (17.2 KB) TX bytes:17248 (17.2 KB)

pan0 Link encap:Ethernet HWaddr ca:7a:4b:d2:bc:f5
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
 
Old 05-25-2009, 03:49 AM   #10
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
You have got two network cards as per the output you have posted but none of them have any ip address. Either enable dhcp server in your router or provide a valid ip address to the network card that is connected to the router.
 
Old 05-25-2009, 03:51 PM   #11
lovenyah
LQ Newbie
 
Registered: May 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Hm..

That makes sense, however I have no idea how to do that!

When it wasn't working on one network card, he ended up trying the other. I think that is where the problem came from!
 
Old 05-26-2009, 12:14 AM   #12
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
By default the router should have 192.168.0.1 or 192.168.1.1 as the ip address. And if you have not changed the settings for the router one of these should be your router's address as well. You can assign some ip address in the range of one of the network and you should be ok.
 
Old 05-26-2009, 01:20 AM   #13
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 3,013

Rep: Reputation: 518Reputation: 518Reputation: 518Reputation: 518Reputation: 518Reputation: 518
To access the router config, type: '192.168.0.1' in a web browser. If that doesn't work, try '192.168.1.1'. Most home networking routers use one of these addresses. For some reason your router is not giving the linux machine an IP address. That is one of the things a router such as yours is supposed to do.

The router gets it's IP from Road Runner. You can also check this in the router config web interface program.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting up High Speed Internet with Slackware 10. RoaCh Of DisCor Slackware 4 09-30-2004 10:08 AM
Getting Comcast High Speed Internet gnu noob Linux - Software 7 04-29-2004 06:53 PM
High speed internet & Linux? gulo General 17 03-12-2004 04:30 PM
installed redhat 9, can't figure out how to connect to internet. nate2000 Linux - Newbie 1 11-11-2003 08:29 PM
Mandrake 9.1 can't configure high speed internet bolinux Linux - Networking 3 10-09-2003 05:02 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration