LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-20-2006, 04:01 PM   #1
itz2000
Member
 
Registered: Jul 2005
Distribution: Fedora fc4, fc7, Mandrake 10.1, mandriva06, suse 9.1, Slackware 10.2, 11.0, 12.0,1,2 (Current)]
Posts: 732

Rep: Reputation: 30
I would like to change screen refresh rate to 75Hz


I would like to change screen refresh rate to 75Hz, and when I click on (right click) -- > Configure Desktop--> Display --> Refresh Rate there's only 60HZ without option to change!


I use Mandriva 2006 (KDE at the moment), my screen is Philips LCD 17" 170B, my Graphic card ABit Radeon 9600XT 256MB....
I think Xorg 6.9
Latest Radeon drivers are installed.


suggestions?
 
Old 01-20-2006, 04:09 PM   #2
saman007uk
Member
 
Registered: Dec 2003
Location: ~root
Distribution: Debian
Posts: 363

Rep: Reputation: 33
You need to enter the correct vertical and horizontal refresh rates into the xorg config file.
 
Old 01-20-2006, 05:05 PM   #3
itz2000
Member
 
Registered: Jul 2005
Distribution: Fedora fc4, fc7, Mandrake 10.1, mandriva06, suse 9.1, Slackware 10.2, 11.0, 12.0,1,2 (Current)]
Posts: 732

Original Poster
Rep: Reputation: 30
where is that... and can I have an example for a settings for 75hz??
 
Old 01-20-2006, 05:16 PM   #4
Lordandmaker
Member
 
Registered: Sep 2005
Location: London, UK
Distribution: Debian
Posts: 258

Rep: Reputation: 38
Config file's at /etc/X11/xorg.conf (note capital X).

No idea on settings for 75Hz, though.
 
Old 01-20-2006, 06:52 PM   #5
itz2000
Member
 
Registered: Jul 2005
Distribution: Fedora fc4, fc7, Mandrake 10.1, mandriva06, suse 9.1, Slackware 10.2, 11.0, 12.0,1,2 (Current)]
Posts: 732

Original Poster
Rep: Reputation: 30
here's my xorg.conf...

what to change

Code:
# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Mandrake 6.0 and later now use a font server independent of
    # the X server to render fonts.
    FontPath "unix/:-1"
EndSection

Section "ServerFlags"
    #DontZap # disable <Crtl><Alt><BS> (server abort)
    AllowMouseOpenFail # allows the server to start up even if the mouse does not work
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx" # 3D layer
    Load "dri" # direct rendering
EndSection

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "keyboard"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us,il"
    Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll,compose:rwin"
EndSection

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/mouse"
    Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Plug'n Play"
    ModelName "Philips 170B"
    HorizSync 30-82
    VertRefresh 56-76

    # Monitor preferred modeline (60.0 Hz vsync, 64.0 kHz hsync, ratio 5/4)
    ModeLine "1280x1024" 108 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync

    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630

    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
    Identifier "device1"
    VendorName "ATI"
    BoardName "ATI Radeon (fglrx)"
    Driver "ati"
    Option "DPMS"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24

    Subsection "Display"
        Depth 8
        Virtual 1280 1024
    EndSubsection

    Subsection "Display"
        Depth 15
        Virtual 1280 1024
    EndSubsection

    Subsection "Display"
        Depth 16
        Virtual 1280 1024
    EndSubsection

    Subsection "Display"
        Depth 24
        Virtual 1280 1024
    EndSubsection
EndSection

Section "ServerLayout"
                                
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    Screen "screen1"
EndSection
what to change it to?

thanks
 
Old 01-21-2006, 05:14 PM   #6
itz2000
Member
 
Registered: Jul 2005
Distribution: Fedora fc4, fc7, Mandrake 10.1, mandriva06, suse 9.1, Slackware 10.2, 11.0, 12.0,1,2 (Current)]
Posts: 732

Original Poster
Rep: Reputation: 30
Please advise... my eyes are turnning red and I'm not joking!
 
Old 01-24-2006, 04:50 AM   #7
itz2000
Member
 
Registered: Jul 2005
Distribution: Fedora fc4, fc7, Mandrake 10.1, mandriva06, suse 9.1, Slackware 10.2, 11.0, 12.0,1,2 (Current)]
Posts: 732

Original Poster
Rep: Reputation: 30
guys? (random text to avoid message error)
 
Old 01-24-2006, 05:04 AM   #8
kassle
Member
 
Registered: Jan 2006
Distribution: bodhi
Posts: 44

Rep: Reputation: 15
wew ... think what you only need to set the correct monitor models
in the control panel ... duh ... dunno how in KDE, but in gnome it
is located in System Setting --> Display --> Hardware

after done back to the resolution setting, higher refresh rate
would be available

good luck
 
Old 01-24-2006, 06:39 AM   #9
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
These are the specs and your X configuration is correct from that perspective.

Use video timing calculator to calculate your modelines.
Select the resolution and click 'calculate' It will show a modeline under heading 4 that you can copy to your X config file (before the first modeline).
Let us know if it works.

Last edited by Wim Sturkenboom; 01-24-2006 at 07:12 AM.
 
Old 01-24-2006, 08:54 AM   #10
itz2000
Member
 
Registered: Jul 2005
Distribution: Fedora fc4, fc7, Mandrake 10.1, mandriva06, suse 9.1, Slackware 10.2, 11.0, 12.0,1,2 (Current)]
Posts: 732

Original Poster
Rep: Reputation: 30
thanks
I've changed xorg.conf to this (changed only 1 line... tell me if this correct)

Code:
# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Mandrake 6.0 and later now use a font server independent of
    # the X server to render fonts.
    FontPath "unix/:-1"
EndSection

Section "ServerFlags"
    #DontZap # disable <Crtl><Alt><BS> (server abort)
    AllowMouseOpenFail # allows the server to start up even if the mouse does not work
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx" # 3D layer
    Load "dri" # direct rendering
EndSection

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "keyboard"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us,il"
    Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll,compose:rwin"
EndSection

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/mouse"
    Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Plug'n Play"
    ModelName "Philips 170B"
    HorizSync 30-82
    VertRefresh 56-76
    
    # Monitor preferred modeline (60.0 Hz vsync, 64.0 kHz hsync, ratio 5/4)
    Modeline "1280x1024"   135   1280 1296 1440 1688   1024 1025 1028 1066  +hsync +vsync
       
    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
    
    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
    Identifier "device1"
    VendorName "ATI"
    BoardName "ATI Radeon (fglrx)"
    Driver "ati"
    Option "DPMS"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24
    
    Subsection "Display"
        Depth 8
        Virtual 1280 1024
    EndSubsection
    
    Subsection "Display"
        Depth 15
        Virtual 1280 1024
    EndSubsection
    
    Subsection "Display"
        Depth 16
        Virtual 1280 1024
    EndSubsection
    
    Subsection "Display"
        Depth 24
        Virtual 1280 1024
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    Screen "screen1"
EndSection
Shall I keep the first mode line or it does not matter?

After I went to (right click)--> Configure Desktop --> Display --> Refresh Rate was still only 60HZ... Was it because I havn't done restart since? or maybe because I deleted the first mode line? or maybe it will stay 60HZ but will actually do 75 HZ?

Thanks alot.
 
Old 01-24-2006, 09:00 AM   #11
Dtsazza
Member
 
Registered: Oct 2005
Location: Oxford, UK
Distribution: Debian Etch (w/ dual-boot XP for gaming)
Posts: 282

Rep: Reputation: 31
You will need to restart X for the changes to take effect.
 
Old 01-24-2006, 09:19 AM   #12
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 332Reputation: 332Reputation: 332Reputation: 332
itz2000,
I noticed that in your first post you said that you are using an LCD monitor. There is a good chance that your monitor will not support 75 Hz. If you have shopped for monitors lately you may have noticed that they are starting to list the time that it takes for a pixel to change from white to black. Older monitors didn't tell us that because they took a long time and because they were very similar. If you want an LCD that will support 75 Hz then you will need a monitor that can change pixels from white to black in 8ms. That happens to be the fastest rate that I've seen advertised on any LCD monitors.

Any time that you change the settings for your monitor you should read the monitor's user guide. It will tell you the refresh rate, RAMDAC setting, etc. that you need to create your XF96Config modelines. If you set the refresh rate or the modeline timings too high you can destroy your monitor.

Quote:
Please advise... my eyes are turnning red and I'm not joking!
I really can't believe that having an LCD monitor at 60 Hz is hurting your eyes. That might be true in a CRT because the pixels are constantly changing brightness but an LCD doesn't do that. In an LCD all of the pixels remain at a constant brightness until the graphic card tells the pixel to change. So 60 Hz on your LCD isn't hurting your eyes. I have my LCD monitors set at 60 Hz and I use them all day without any problems.

Last edited by stress_junkie; 01-24-2006 at 09:26 AM.
 
Old 01-24-2006, 09:30 AM   #13
mr_coffee
Member
 
Registered: Jan 2006
Location: PA
Distribution: Mandriva Power Pack 2006
Posts: 146

Rep: Reputation: 15
me too! my LCD is @ 60Hz and looks saucey.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing screen resolution to 1024x768..refresh rate cannot change too stays 60hz Niceman2005 Linux - General 4 11-03-2005 11:00 AM
Change refresh rate :) Slackeriz Linux - Hardware 5 04-14-2005 03:01 PM
I can't change the refresh rate to make the screen normal in FreeBSD 5.3 Mr. Hill *BSD 4 03-23-2005 08:03 PM
How to change screen refresh rate? Melon Mandriva 13 12-29-2004 09:21 AM
how to change refresh rate Andrew McKinlay Linux - Newbie 4 12-04-2003 10:12 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration