LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   I would like the linux installation on my laptop to be gone. (https://www.linuxquestions.org/questions/linux-newbie-8/i-would-like-the-linux-installation-on-my-laptop-to-be-gone-774708/)

Robert.Thompson 12-10-2009 06:57 AM

I would like the linux installation on my laptop to be gone.
 
Lenovo x61 Laptop

Hello:

I plan to install an external USB hard drive on my laptop where I want my linux to live and boot from.

I have SUSE 11.2 installed on my internal hard drive at present. I would like the linux installation on my laptop to be gone before I try the external disk installation - how do I accomplish this?

Thanks,

Rob.

linus72 12-10-2009 07:04 AM

OK

i would first install whatever Linux to external usb hdd, make sure it works
then get rid of SUSE 11.2 on the lappy

but, you wanna do it the other way?

Mmmmm....

your BIOS supports booting from usb?
if so OK
but if not and you delete SUSE it wont boot the usb hdd...

so, questions:

your BIOS supports booting from usb/usb-hdd?

what linux you wanna put on usb hdd?

linuxlover.chaitanya 12-10-2009 07:10 AM

No questions asked. Most of them are already there on the post above.
Just boot from windows cd and recover your windows boot loader. Now, Linux should not boot and you should directly go into windows.
Using disk management utility of windows, now either delete the unknown partition or format it to the fie system for windows.

Robert.Thompson 12-10-2009 07:50 AM

Hello:

Yes, the laptop BIOS supports booting from usb/usb-hdd.

I was thinking of installing SUSE 11.2 GNOME or SIMPLYmepis 8.0 or both, if I can.

The main point would be that linux would only boot when and if the external is plugged in.

The reason I want to delete if first from the laptop is so that I will have less chance of being confused when I try to install 'only' on the external.

Rob.

linus72 12-10-2009 08:00 AM

OK

well, you could unhook the hdd from lappy before running install on usb-external

but, how big is the usb hdd?

you can install many if its big enough
or just install opensuse/mepis

I would install opensuse first, then mepis as mepis will
probably auto-detect opensuse

so, you could format the hdd
then boot off a livecd/usb and install both mepis and opensuse
right?

you got both open and mepis on cd?

Robert.Thompson 12-10-2009 08:54 AM

I am using Western Digital "My Passport Essential" USB 2.0 320GB.

I have Live CD's for both.

I don't think I can physically disconnect the laptop's internal drive. Can this be done through the Bios?

When you say I can format the external drive... I guess I can, but don't know how.

Rob.

yancek 12-10-2009 09:37 AM

If you are worried about installing to the wrong disk, just attach the empty external and login to Opensuse as root and run the command "fdisk -l" to get disk/partition information. Your internal will probably be sda and the external sdb which will show up in your install options with yast.

You will need to select Custom partitioning because the default will not do what you want. You will also need to specifiy where you want the bootloader during the install and this option is given.

During the install, you are asked if you want to format and if so, which filesystem. If you do not select format, you will get an error message.

I guess we are assuming you have another operating system (some version of windows) on the lap top??

Using the method you want, you understand that you will have to manually select which drive to boot from each time you want to boot the external. It's possible to put an entry in the windows bootloader to boot Linux on the external but the method varies depending upon which version of windows you have.

Robert.Thompson 12-10-2009 10:52 AM

Hello:

Here is my fdisk -l output:

linux-c18c:/home/rob # fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xed1f86f7

Device Boot Start End Blocks Id System
/dev/sda1 1 17042 136888888+ 7 HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2 18867 19457 4740120 12 Compaq diagnostics
Partition 2 does not end on cylinder boundary.
/dev/sda3 * 17042 18866 14659312+ 5 Extended
Partition 3 does not end on cylinder boundary.
/dev/sda5 18785 18866 658633+ 82 Linux swap / Solaris
/dev/sda6 17042 17738 5598589+ 83 Linux
/dev/sda7 17739 18784 8401963+ 83 Linux

Partition table entries are not in disk order

Disk /dev/sdb: 319.4 GB, 319370035200 bytes
255 heads, 63 sectors/track, 38827 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x002e2ec3

Device Boot Start End Blocks Id System
/dev/sdb1 1 38828 311885878+ 7 HPFS/NTFS
linux-c18c:/home/rob #


Why would I manually select which drive to boot from? I thought that if my external drive is attached, it would boot from there (linux) but if it is not attached, it would boot from the internal disk (windows). I have set the bios boot sequence to USB drive first, CD drive second and internal disk third.

Won't this do it?

Thanks,

Rob.

ronlau9 12-10-2009 11:37 AM

Why not CD drive first second USB drive third internal drive.
I would prefer that because if something went wrong all you have to do is to insert boot able CD in the drive to rescue you're system.
But you're option should work too.

Robert.Thompson 12-10-2009 11:39 AM

Thanks, that is a very good idea. Rob.

yancek 12-10-2009 01:04 PM

Quote:

I have set the bios boot sequence to USB drive first, CD drive second and internal disk third.
That will work, but I agree with ronlau suggestion.

So you want to make sure during the installation you install to sdb. You will need to select custom partitioning and I would read carefully during the installation, particularly when it comes to options regarding bootloader installation so you don't install to the master boot record of sda. Yast explains pretty well though.

You have your entire external hard drive formatted for windows (ntfs) which won't work but, you do have an option in Yast to format and be sure to select a Linux filesystem type, reiserfs, ext3 or ext4. Options should be available.

Robert.Thompson 12-10-2009 07:40 PM

Hello:

All the responses got me all fired up to proceed but when I booted from an XP CD to run FIXMBR it didn't work - when I re-started the PC I got the same OpenSUSE or Windows XP option. Did I miss something? Should I have used the XP disk manager to delete the linux partition first?

Thanks,

Rob.

linuxlover.chaitanya 12-11-2009 02:17 AM

Look Here if this helps. It talks of removing Lilo and reinstalling windows mbr.

Robert.Thompson 12-11-2009 07:02 AM

Thanks Chaitanya, my problem was that I did not type the word 'EXIT' after I ran FIXMBR - it's true, the Devil is in the details! Rob.

Robert.Thompson 12-11-2009 09:11 AM

Hello:

Well I tried 'exit' after FIXMBR, removed the XP CD and booted - nothing changed: Linux start up menu appeared.

Check other posts on FIXMBR and saw that I had to follow this command with FIXBOOT. I did this and I still get the Linux start up menu.

Will I ever be able to un-install SUSE 11.2 with its' dual-boot configuration from my Lenovo X61 Laptop?

I really want it gone before I re-install SUSE 11.2 on the USB (WD)external 320GB hard drive.

Any further advice would really be appreciated.

Thanks,

Rob.

yancek 12-11-2009 10:29 AM

Is your xp CD a full installation CD or a Recovery CD? My understanding is that it needs to be the Installation CD as the Recovery CD does not have the necessary files to repair boot record.

If you do have the full installation CD, the steps you indicate should work. Microsoft has a page dealing with this, go to support.microsoft.com and do a search 'removing Linux to install windows' or something similar.

Robert.Thompson 12-12-2009 03:48 PM

Hello:

It's gone!!!!

I got rid of it by using the XP's disk manager to blow out any partition of 'Unknown' type and then using the XP CD to start 'Repair' where I did an "FIXMBR" and then a "FIXBOOT C:" followed by "EXIT".

It seems that the 'order' in which the above is done really matters.

My system did not boot properly - it kept going into "GRUB" for some reason. I used a Gparted iso CD to boot and choose the 'Windows' option.
After that, I removed the Gparted CD and did a windows 'Shutdown'. The next time I started the PC, it went into the usual windows start up routine.

No more SUSE 11.2!!!

Thanks to all of you for your help.


All times are GMT -5. The time now is 07:07 AM.