LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-09-2005, 12:45 PM   #1
Orin
Member
 
Registered: Apr 2004
Location: North Carolina
Distribution: Ubuntu
Posts: 30

Rep: Reputation: 15
Couple of noobish questions.


I tried searching for the answers to my questions, really, I did. Spent 2 hours on it so far. They're simple questions and I'm getting annoyed, so I'll just ask here.

1. How do I exit the X window manager so I can install my video drivers?
2. How do I install soundcard drivers?
3. XMMS refuses to play anything, and when I log in as root I get this error message:
"Sound server informational message.
Error while initializing sound driver...."

Trying Linux 1 more time and this time around, I'm determined to figure it out.

Running FC4, btw.


Last edited by Orin; 08-09-2005 at 12:58 PM.
 
Old 08-09-2005, 12:49 PM   #2
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Not sure about the others, but for no. 1, you need to change to runlevel 3. Open a terminal:

$ su
Password: <enter root pass>
# init 3

That should give you a command line only.

Edit: for no. 3, you might wanna tell us what error message you're getting .

Last edited by Nylex; 08-09-2005 at 12:51 PM.
 
Old 08-09-2005, 12:50 PM   #3
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
Re: I tried. :|

1. How do I exit the X window manager so I can install my video drivers?

If your running in runlevel 5 which is X, you need to run init 3. ctrl-alt-F2 and then issue the command init 3 or reboot issuing the same command at the lilo or grub prompt. Or temporarily edit your /etc/inittab file to boot into runlevel 3. If you start X by issuing the command startx, simply logout or do a ctrl-alt-backspace to kill X running.

2. How do I install soundcard drivers?

Depends on what sound drivers they are and the type of card you have. Most likely your current kernel already supports your soundcard, providing such details will usually tell us otherwise.

3. XMMS refuses to play anything, and when I log in as root I get this error message.

Well, if you don't have sound configured, XMMS won't play sounds. Refer to your question #2.

And the future, please try to use more helpful descriptive thread titles, your's doesn't not describe your questions at all.
 
Old 08-09-2005, 12:57 PM   #4
Orin
Member
 
Registered: Apr 2004
Location: North Carolina
Distribution: Ubuntu
Posts: 30

Original Poster
Rep: Reputation: 15
Thanks for the quick responses. Guys...do me a favor, pretend you're talking to someone who's entire education when it comes to computers is Win-based. Actually...don't pretend.

"...issue the command init 3 or reboot issuing the same command at the lilo or grub prompt. Or temporarily edit your /etc/inittab file to boot into runlevel 3..." <-- Not English.

Let me give you a bit more information on what's up with my sound. I've got a 4.1 speaker setup going on, and it's pretty happy. Aside from the fact that since installing Linux, all the bass is being pushed through the speakers, rather than the sub. Now, being icky little speakers, they can't really handle it, and snap, crackle and pop constantly. I figured, updating the sound drivers will resolve the issue. Just before I went out looking for sound drivers, though, I get this error message that the sound card is busy with another application or is, for some other reason, unusable. It plays things when I'm logged in as root, but refuses to do so on a regular user.

Oh, and sorry about the title.
 
Old 08-09-2005, 01:10 PM   #5
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
About inittab:

Open a terminal and change to root with su and then the password. Then, open the file /etc/inittab with any text editor (eg. pico, emacs, or whatever editor is on your system):

$ su
Password: <root pass>
# emacs /etc/inittab

You should see lines like this (amongst others):

# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:

You need to change that 4 (or whatever number it is) to a 3 and save the file. Then, when you boot your machine, you'll boot to a command line and no X Windows. There is some info about the file itself here and also here if you want to read .

Last edited by Nylex; 08-09-2005 at 01:13 PM.
 
Old 08-09-2005, 01:20 PM   #6
Orin
Member
 
Registered: Apr 2004
Location: North Carolina
Distribution: Ubuntu
Posts: 30

Original Poster
Rep: Reputation: 15
Thanks, nylex. That was easy.

So I ran init 3 from the terminal, got out of X. All was well. Ran the driver installer. It tells me my driver sucks and isn't compiled for my system (no precomplied kernel for the interface) , or something along those lines. Asks me if I want to compile one. I say sure. It tells me I don't have gcc. Fine. I go install gcc. I come back. Go through the motions again, and now it says "Unable to find the kernel source tree for the currently running kernel."

Pleh.

Last edited by Orin; 08-09-2005 at 01:24 PM.
 
Old 08-09-2005, 01:23 PM   #7
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,014

Rep: Reputation: 115Reputation: 115
probably says the kernel headers are missing. You need to install the kernel source for your kernel version.
 
Old 08-09-2005, 01:25 PM   #8
Orin
Member
 
Registered: Apr 2004
Location: North Carolina
Distribution: Ubuntu
Posts: 30

Original Poster
Rep: Reputation: 15
Okie.

And where do I find out what my kernel version is and where do I find the kernel source to match it?
 
Old 08-09-2005, 01:27 PM   #9
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
You can find out your kernel version by typing "uname -r", without the quotes. The source should be on one of your FC 4 CDs.
 
Old 08-09-2005, 01:54 PM   #10
Orin
Member
 
Registered: Apr 2004
Location: North Carolina
Distribution: Ubuntu
Posts: 30

Original Poster
Rep: Reputation: 15
I've got the dvd of it. How do I install the source?
 
Old 08-09-2005, 02:00 PM   #11
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,014

Rep: Reputation: 115Reputation: 115
rpm -i kernel-source-(version).rpm
 
Old 08-09-2005, 02:15 PM   #12
Orin
Member
 
Registered: Apr 2004
Location: North Carolina
Distribution: Ubuntu
Posts: 30

Original Poster
Rep: Reputation: 15
[root@localhost ~]# rpm -i kernel-source-2.6.11-1.1369_FC4.rpm
error: open of kernel-source-2.6.11-1.1369_FC4.rpm failed: No such file or directory

One more thing. My cd-drive keeps freezing up when I try to install stuff. Just glitches out and won't eject the cd and won't continue with the installation.

Last edited by Orin; 08-09-2005 at 02:18 PM.
 
Old 08-09-2005, 02:22 PM   #13
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,014

Rep: Reputation: 115Reputation: 115
you did not tell it the actuall filename on the disk.
try copying the rpm to ~(home directory) first.
 
Old 08-09-2005, 02:32 PM   #14
Orin
Member
 
Registered: Apr 2004
Location: North Carolina
Distribution: Ubuntu
Posts: 30

Original Poster
Rep: Reputation: 15
I don't have the kernel-source-2.6.11-1.1369_FC4.rpm file. I checked redhat's ftp server, it's not in any of the distro rpm folders either.
 
Old 08-09-2005, 03:07 PM   #15
Orin
Member
 
Registered: Apr 2004
Location: North Carolina
Distribution: Ubuntu
Posts: 30

Original Poster
Rep: Reputation: 15
So this thread kind-of expired. Could someone please help me?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration