-   Linux - Newbie (
-   -   I think I killed my fc4-64 installation (

wjn 03-17-2007 01:57 PM

I think I killed my fc4-64 installation
It all started with a reboot that I did due to some wakky performance problems. Yeah, I know, rebooting is a Windows thing, but I thought I'd try it anyway.

Well, the system got to the Automount part of the boot and hung. I've had problems with the two SATA drives on my box so I thought, brilliantly, I'll just run fsck on it and everything will be great.

I read through some threads here and found somebody's opinion on how to do this (no names will be mentioned because I don't remember what thread this was) and as I attempted to follow those instructions the system asked me if I REALLY wanted to do this since the drives were mounted. "Severe file damage", I believe, was the warning. Well, I came back here and found instruction on how to unmount the drive. When I tried to do that, the system told me it couldn't unmount the drive because it was already unmounted.

So, I tried to run fsck again, this time ignoring the dire warning. Yeah, it fscked, all right. Now the computer boots up to a "kernal panic".

I have downloaded and burned a Kanotix bootable CD to see if there's any hope. It mounts the /boot drive, but there's nothing showing up in the folder except a grub file and a locked lost+found file. I unmounted the drive and tried to run fsck on it; it gave me the following message:


The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>
I realize this is probably my own fault for not reading the entire thread, because as I went back to it there was some further discussion about this procedure that indicated that people with good intentions vehemently disagreed on what to do about this.

So... does anybody has any suggestions as to how to proceed with this or is it a lost cause? I didn't have a whole lot of data on there but there are a couple of files I would like to recover if possible.

Thanks in advance,

Valkyrie_of_valhalla 03-17-2007 03:40 PM

A few questions to start with:
1. how did you reboot? normally (reboot command or with the GUI), or from the button? Anyway, most distros run fsck during the boot process, I think..
2. did you run fsck from the OS on the partition you fsck-ed? (just to see if I understood correctly)
3. what type of partition is it? (ext2?)

Generally, it's a bad idea to run fsck with the partition mounted, as it can really mess it up... But, I'm not an expert...
It is possible you have to format and reinstall everything... As for the files, you might be able to recover some with some apps, but I'll have to google that one...

wjn 03-17-2007 05:10 PM

Hi, thanks for responding...

Originally I rebooted by shutting down from the GUI... KDE.

When it came back up it never got back to the GUI (meaning the log in screen).

I don't remember what kind of filesystem it is (was). I think I used whatever the default filesystem is for Fedora Core 4.

jay73 03-17-2007 07:49 PM

So did you run the e2fsck or not, that's not entirely clear to me?

wjn 03-18-2007 10:12 AM

I have to apologize for not being more clear.

I also should apologize for not writing all of this stuff down while it was happening.

I believe that the only command I ran was fsck -A.

I can't exactly remember why I ran it with that switch.

On a hopefully related topic... should I try to run the FC4 rescue disc?

Thanks for trying to help me.

jay73 03-18-2007 02:16 PM

fsck -A will check the integrity of all your filesystems; if these are damaged, it will fail. I think that you should at least try to do what the system suggested by running, preferably from a floppy of a LiveCD:

e2fsck -f -b 8193 /dev/[partition]

or if you have ext3:

e3fsck -f -b 8193 /dev/[partition]

What makes these commands more powerful than plain fsck is that they will use a backup copy of the superblock instead of the superblock itself (which may be damaged).

The superblock, in case you wonder, is a location that stores vital information about the filesystem; if it gets hurt, the system may fail to mount. In order to minimize the risk, ext 2/3 filesystems create backup copies of this block at intervals on the filesystem, usually one per every 8192 blocks. So by issueing these emergency commands, you're going straight to the first superblock copy on you filesystem. If that fails, you may want to try the next one, which is at
8192 x 2 +1 = 16385:

e2fsck (or e3fsck) -f -b 16385 /dev/[partition]

You would have to do that for each FC4 partition, of course.

All times are GMT -5. The time now is 09:32 PM.