-   Linux - Newbie (
-   -   i received the message: adding read ACL for uid 1000 to '/media/david' failed (

xtrick 02-23-2013 04:48 AM

i received the message: adding read ACL for uid 1000 to '/media/david' failed
I'm stumped what command must i use in ubuntu please.
I feel embarassed about this as i read wiki for commands but exited none the wiser!
I guess this is rather basic but i''m stumped!


shivaa 02-23-2013 09:28 AM

What command(s) did you execute and where and how this error is generating? Please explain it little more, so we could help you.

xtrick 02-24-2013 02:59 AM

no command given
in fact i to get this message i did not enter any command. I simply go to my home folder where all partitions are listed and click any one of them and u get this error.
i suppose there is a system error in ubuntu and it is issuing some command.
If i use open suse (also on the same harddisk) it also sees all of the partitions and there if i click on them it automatically mounts the partition and presents the contents.
I suppose ubuntu is trying to do the same but using the wrong command. I am unable to say what command , i haVE TRIED MYSELF SETFACL AND CHMOD BUT I'M NOT AN EXPERT OR KNOWLEDEABLE WITH THESE COMMANDS AND THEIR DESCRIPTION IN WIKI LEAVES ME COLD.

shivaa 02-24-2013 06:49 AM

What does it say?

~$ df -h
~$ cat /etc/fstab

xtrick 02-24-2013 11:58 AM

info requested
Filesystem Size Used Avail Use% Mounted on
/dev/sda5 79G 2.9G 72G 4% /
udev 1.9G 4.0K 1.9G 1% /dev
tmpfs 757M 860K 756M 1% /run
none 5.0M 0 5.0M 0% /run/lock
none 1.9G 152K 1.9G 1% /run/shm
none 100M 40K 100M 1% /run/user

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda5 during installation
UUID=e087b5ed-bcc7-416c-a1fa-4c80bb3a1082 / ext2 errors=remount-ro 0 1
# swap was on /dev/sda8 during installation
UUID=76e9ae0e-167d-46a6-ae43-a982d9e7c301 none swap sw 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

----hoping this throws some light on it!

xtrick 03-06-2013 07:49 AM

this request is still not answered - i am desperate to resolve it
please help


shivaa 03-06-2013 08:14 AM


~$ mkdir /media/david
~$ chown david:david /media/david
~$ chmod 750 /media/david

~$ mount -t <fs-type> /dev/<device> /media/david

Then connect your HD or device again and try to boot.

chrism01 03-06-2013 05:49 PM

I think you need to check if acls are enabled on that partition eg

tune2fs -l /dev/sda1 | grep options
Amend /dev/sda1 to match your system

mandyapenguin 03-07-2013 12:07 AM

Are you trying to mount an external HDD to /media/david?
Can you post the output "sudo fdisk -l" command?
If External HDD is formatted using NTFS filesystem then you need ntfs-3g package to mount NTFS partitions. So check whether that package is installed or not using

sudo dpkg -l | grep ntfs-3g
If it is not installed, install it using below commands

sudo apt-get update
sudo apt-get install ntfs-3g

After installation you can mount that NTFS partition(which will be usually sdb* or sdc*) using below command

sudo mount /dev/sdb1 /media/david -o uid=1000,gid=1000,dmask=027,fmask=027
sudo mount -t ntfs-3g /dev/sdb1 /media/david -o uid=1000,gid=1000,dmask=027,fmask=027

dmask is the mask for directories and fmask is the mask for files.
Here you no need either extra ACLs or chmod/chown commands to give read/write permissions to uid=1000, From above command by default the user & group who is having uid & gid as 1000 will get read, write & execute and read & execute permissions respectively to /media/david folder including all sub folders and others won't be having any permission on /media/david.
You can change permissions according to your needs by calculating with umask i.e

7 7 7  ---> full permission for all
0 2 7  ---> umask of owner, group and others
7 5 0  ---> real permissions of files/folders of owner, group and otheres.
| | |-->Other don't have any permissions.
| |-->Group having read and execute permissions.
|-->Owner having full(read/write/excecute) permissions.

4 = read
2 = write
1 = execute
7 = rwx

If you are just trying to give access to /media/david folder without mounting any external HDD, then you can do it using chmod/chown only but ACL would be fine which can set particular permission to particular user even that directory is not owned by either his name/group. Before running setfacl command make sure whether acl package is installed.

sudo dpkg -l | grep acl
You can install ACL using

sudo apt-get install acl
If ACL is not enabled for / then open /etc/fstab file and add acl to the end of the 4th field in the / partion line. Then your root partition line looks like below

UUID=e087b5ed-bcc7-416c-a1fa-4c80bb3a1082 / ext2 errors=remount-ro,acl 0 1
Now remount / using

mount -o remount /
Check whether now ACL is enabled for /.

mount | grep acl
Now you can run setfacl command

setfacl -m u:username:rwx /path
setfacl --help
For example
setfacl -R -m u:david:rwx /media/david

All times are GMT -5. The time now is 04:52 AM.