-   Linux - Newbie (
-   -   I need to reallocate drive space from mount point / to /boot (

decampbell1 01-08-2004 10:43 AM

I need to reallocate drive space from mount point / to /boot
I have run out of space on my boot volume and I have 1.3 gb of free on another volume... my boot vol had 50 mb and I need to increase it's size... both vols are on the same physical drive. How can I do this without loosing data and reinstalling... this is Red Hat Linux 9... Thanks


@@@ 01-08-2004 11:34 AM

What do you mean with boot volume?
It depends on where you installed the bootloader.
a) MBS: Just do the usual stuff: boot from a cd or rescue system. mount the old volume read-only. mount the new volume and then tar it from the old place to the other. Read the man page of tar for preserving ownership and time.
b) same as above but you have to reinstall the bootloader...

decampbell1 01-08-2004 11:41 AM

It is the ext3 file system.... which has the label /boot... I hope that is more clear... thanks

TigerOC 01-08-2004 01:06 PM

I would suggest using rsync. Create a new directory /new_boot go out of gui and login as root and do init1 to get into single user mode. Mount the partition if it is not mounted. Do rsync -avH /boot/ /new_boot if the partition is mounted under /mnt then /mnt/new_boot. Go back into multiuser mode if you wish and rename /boot /old_boot and /new_boot /boot and then edit your fstab to reflect the directory change and reboot. If I was doing this I would have Knoppix handy in case something went wrong because you may not get the system to boot if it cannot find /boot.

decampbell1 01-08-2004 02:35 PM

ok... how do I shutdown gnome to get out of the gui?... I have tried loging out and I have the options of default (which is gnome) K or gnome... I have tried runing init1 from terminal and that hasnt worked... severe newbie here...

TigerOC 01-08-2004 03:07 PM

You should have an option to go into consol when you logout or in i.e. the command line

decampbell1 01-08-2004 03:31 PM

Not that I see... options on logout are logout... shutdown and restart..

at loging screen... I have the following options...
>language >session >reboot >shutdown

under session... I have the following options





the reboot and shutdown options are self explanitory...

I don't see any other options on the login screen except username


ac1980 01-08-2004 03:34 PM

To boot into single user mode, simply add single to your boot string...
ie if you boot with lilo and your boot string is Linux, at lilo prompt type Linux single
If you use grub, you may need to press 'c' to go to command line.
As an alternative, from within your system open a root shell and give the command "shutdown now" without -r nor -h... you'll go to single user.

However, unless you have problems related to 2GB boot boundary (i.e. old pc and big / partition) you can simply get rid of /boot partition:

umount /boot
mkdir /tmp/boot
mount /dev/hda1(or whatever) /tmp/boot
cp -a /tmp/boot/ /boot
umount /tmp/boot
rmdir /tmp/boot

Now remove your /boot entry from /etc/fstab
If you use lilo, remember to run "lilo" to complete work ;)

All times are GMT -5. The time now is 01:30 PM.