-   Linux - Newbie (
-   -   I need to install a new graphics card driver (

matuk_444 08-15-2005 07:17 AM

I need to install a new graphics card driver
Okay, so I am using SUSE 9.3 and I have just brought a nVIDIA GeFORCE 6 graphics card.

I go to the nVIDIA site and download the linux driver and I it's a shell script. Not a problem, I have installed from shell scripts before, all I do is sh *.run and bob's your uncle. Unfortunatly I get the following error message.

No precompiled kernel interface was found to match your kernel; this means that the installer will need to compile a new kernel interface.

What does this mean, in simple terms please...

I click on ok and I getthe following error message

Unable to find the kernel source tree for the currently running
kernel. Please make sure you have installed the kernel source files
for your kernel; on Red Hat Linux systems, for example, be sure you
have the 'kernel-source' rpm installed. If you know the correct
kernel source files are installed, you may specify the kernel source
path with the '--kernel-source-path' commandline option.

What does this mean and how can I get it working?

Thanks in advance.


Baldrick65 08-15-2005 07:20 AM

It's always best to install/upddate nVidia drivers (in SuSE) through the Yast Online Update. Very easy and painless.


matuk_444 08-15-2005 07:31 AM

In simple terms, how do I do this?

I have only ever used YAST for installing stuff from the DVD


reddazz 08-15-2005 07:45 AM

Run YOU and there is a patch to install the official nvidia drivers in the list of available patches.

Baldrick65 08-15-2005 07:48 AM

OK, open YAST Control Centre, under Software tab, click Online Update then select a mirror and hit next. In the Show Patch Category drop down box, select Installable and Installed patches. Right down near the bottom will be an entry Download NVIDIA Graphics Driver. Make sure that is ticked and click Accept.

Once that is done, fire up SaX2 and configure the driver, making sure you enable 3D acceleration ... then you're done (hopefully).


matuk_444 08-15-2005 08:26 AM


Thanks for that, very much appreciated. However when I start up some linux games (doom 3 and Devil's whiskey) I get a load of errors like

Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Video mode set failed: Couldn't find matching GLX visual

Is this a grpahics card problem?


reddazz 08-15-2005 09:04 AM

try doing the following, [list=1][*]"init 3" as root in a terminal window[*]run "sax2"[*]select "enable 3d"[*]save and exit from sax2[*]"init 5" as root[/list=1]

koodoo 08-15-2005 10:21 AM

Hi matuk_444,

I would like to add something here relating to the problem mentioned in the first post of this thread.

Yes sometimes the kernel does complain about kernel version and kernel headers. I've experienced this myself. I then read SBing's Slackware FAQ (posted in the Slackware forum)

Following the instructions there solved my problem.
Here's an excerpt of it that may be useful.


Excerpt from SBing's Slackware FAQ posted in the Slackware forum

1. Download NVIDIA driver from : (choose IA32 for Intel/AMD 32 bits processors, IA64 for Intel 64 bits, AMD64 for AMD 64 bits)

2. Install driver with :
exit X session if it is running
And follow the instruction

If install complains about kernel, indicate your kernel version to the installer (example for 2.6.7) :
sh -k 2.6.7]

Hope this helps.

matuk_444 08-15-2005 11:23 AM

Same old problem.

I ticked the enable 3D box in sax but I don't know how to restart the graphics engine. I tried the init 5 thing and that didn't work either.


Vgui 08-15-2005 12:22 PM

I don't know how extensive the SuSE installer is for the driver, but normally you have to update your xorg.conf file to use the true Nvidia driver instead of the generic nv one.

JimBass 08-15-2005 12:45 PM

You also need to stop the entire X windows system and restart it. Rebooting would work, but that is overkill. Just stop and restart X windows and see if that corrects the problem.


matuk_444 08-15-2005 03:03 PM

It works!!!

Thanks to all those who helped me.


All times are GMT -5. The time now is 12:39 PM.