LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-06-2010, 01:07 AM   #1
trist007
Senior Member
 
Registered: May 2008
Distribution: Slackware
Posts: 1,033

Rep: Reputation: 69
I need help setting up a pxe boot...


Here's my dhcpd.conf

Code:
# dhcpd.conf
#
# Configuration file for ISC dhcpd (see 'man dhcpd.conf')
#
option domain-name-servers 192.168.1.1;
default-lease-time 86400;
max-lease-time 604800;
authoritative;
allow booting;
allow bootp;

# global parameters
subnet 192.168.1.0 netmask 255.255.255.0
{
        range 192.168.1.100 192.168.1.254;
        filename "pxelinux.0";
        next-server 192.168.1.130;
        option subnet-mask 255.255.255.0;
        option broadcast-address 192.168.1.255;
        option routers 192.168.1.1;
}
Have tftpd setup from inetd

Code:
# Tftp service is provided primarily for booting.  Most sites
# run this only on machines acting as "boot servers."
tftp  dgram   udp     wait    nobody    /usr/sbin/in.tftpd  in.tftpd -s /tftpboot -r blksize
Also ran

Code:
mkdir -r /tftpboot/pxelinux.cfg
touch /tftpboot/pxelinux.cfg/default
I have a slackware 13.0.iso that I want my comp booting off pxe to boot to.

Here's my /tftpboot/pxelinux.cfg/default

Code:
default linux
timeout 0
prompt 1
display display.msg

label linux
  kernel vmlinuz
  append initrd=initrd.iso
I have vmlinuz and initrd.iso in /tftpboot/pxelinux.cfg

vmlinuz is linked to /boot/vmlinuz-huge-smp-2.6.29.6-smp
initrd.iso is linked to /tftpboot/slackware-13.0-install-dvd.iso

The pxe boot computer and the one booting to pxe are both connected to the same switch.

When I turn on the computer that is gonna logon to the pxe boot server, it gets assigned an IP from the DHCP server, then it says TFTP PXE-E11 ARP Timeout.

So I figured my in.ftpd server was not configured correctly. I checked lsof -i and udp *:tftp is there. However when I run grep -i tftpd /var/log/syslog, I get
Code:
Feb  4 23:38:53 server in.tftpd[27754]: recvfrom: Socket operation on non-socket
Is this because in.ftpd is running through inetd? I thought inetd uses sockets?

I'm confused about the purpose of what 'filename "pxelinux.0";' does in /etc/dhcpd.conf?

Any ideas on the problem?

Last edited by trist007; 02-06-2010 at 01:20 AM.
 
Old 02-06-2010, 01:32 AM   #2
snowtigger
Member
 
Registered: Mar 2005
Location: england
Distribution: slackware, win2k
Posts: 364

Rep: Reputation: 35
Can't remeber everything off hand, but i have a similar setup,
Do you have everything (i'm sure its everything) including /tftpboot readable by everyone.

 
Old 02-06-2010, 02:07 AM   #3
nodopro
Member
 
Registered: Oct 2008
Posts: 48

Rep: Reputation: 16
So your /tftpboot supposed to have these files:
/tftpboot/vmlinuz
/tftpboo/initrd.iso
/tftpboot/pxelinux.cfg/default
/tftpboo/pxelinux.0

I believe you are missing pxelinux.0 file. Also make sure to check the permission.
 
Old 02-06-2010, 06:45 AM   #4
trist007
Senior Member
 
Registered: May 2008
Distribution: Slackware
Posts: 1,033

Original Poster
Rep: Reputation: 69
I copied the pxelinux.0 file from /usr/lib/syslinux to /tftpboot. I even chmod 777 all the files in -r /tftpboot.

Here is what I see on the computer booting to the pxe server

Code:
client mac address xx:xx:xx:xx:xx:xx guid xxxxxxxx
client ip 192.168.1.103  mask 255.255.255.0  dhcp xx.xx.xx.xx
gateway ip 192.168.1.1
pxe-e11 arp timeout
I have a gateway/router at 192.168.1.1. Now surprisingly on the dhcp ip up on top, instead of xx.xx.xx.xx it actually shows my public ip(external) which is exposed to the wan instead of my lan. I'm thinking this is the problem. I'm going to mess around more with my dhcpd.conf file. The dhcp server ip is supposed to be 192.168.1.111.
 
Old 02-06-2010, 07:01 AM   #5
trist007
Senior Member
 
Registered: May 2008
Distribution: Slackware
Posts: 1,033

Original Poster
Rep: Reputation: 69
I changed my /etc/dhcpd.conf to:

Code:
# dhcpd.conf
#
# Configuration file for ISC dhcpd (see 'man dhcpd.conf')
#
ddns-update-style interim;
authoritative;
allow booting;
allow bootp;

# global parameters
subnet 192.168.1.0 netmask 255.255.255.0
{
        range 192.168.1.100 192.168.1.254;
        filename "pxelinux.0";
        default-lease-time 86400;
        max-lease-time 604800;
        option subnet-mask 255.255.255.0;
        option broadcast-address 192.168.1.255;
        option domain-name-servers 192.168.1.1;
        option routers 192.168.1.1;
}
Now my dhcp display as 192.168.1.113 on the computer that boots to pxe.

TFTP seems to be downloading file cause I can see '.' right after TFTP.

After about 15 mins I get a PXE-E32 TFTP open timeout. I'm going to check out my tftpd settings in /etc/inetd.conf. I am sure in.tftpd which is tftp-hpa 0.48(listed at the end of man page since in.tftpd -v or -version did not work) is good enough.

I ran lsof -i and saw that the tftp server was running as nobody. I edited the /etc/inetd.conf to have root run the tftp server. Isn't this risky?

Anyhow, it now works!! I get the boot: message, when I hit enter it says 'could not find kernel image'.

Update: It seems that pxe boot does not like symbolic links. I would have both slackware.iso and vmlinuz-huge-smp-2.6.29.6-smp in the /tftpboot dir. I had two files vmlinuz and initrd both linked to their respective files. This did not work. I simply moved the slackware.iso and vmlinuz-huge-smp-2.6.29.6-smp to initrd.iso and vmlinuz respectively. It works.

Update: After 15 mins, the as the initrd.iso was downloading, it just yacked. The screen was filled with weird symbols. Anyhow, I mouted that iso and put the initrd.img in /tftpboot and made the change to initrd.img in the default file.

It now works. Yaay!

Last edited by trist007; 02-06-2010 at 01:11 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting up PXE network boot for diagnostic tools mike34341 Linux - Networking 8 03-25-2013 02:20 PM
pxe boot "PXE-T01 file not found" ssharma_02 Linux - Networking 16 05-18-2011 03:21 PM
LXer: Setting Up A PXE Install Server On Ubuntu 9.10 LXer Syndicated Linux News 0 02-03-2010 05:50 PM
LXer: Setting Up A PXE Install Server For Multiple Linux Distributions On Debian Lenn LXer Syndicated Linux News 0 05-26-2009 11:20 AM
Setting up PXE via FC7 sscultima Fedora 3 06-29-2007 02:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration