-   Linux - Newbie (
-   -   i move my /etc folder in my /home folder (

Casanogab 03-31-2006 10:17 AM

i move my /etc folder in my /home folder
Hi all

i have 1200 users...
i do a real stoopid thing

i move my /etc into my /home folder ....

so now how do i move back to is original place ... im able to log in single mode but my drive is read-only ... icant mount with the command

mount -a
mount -uw
mount -o remount,rw
mount --move /home/etc /

i try to boot with knoopix and simply mepis CD
both of them dont see the content of my drive cause my /etc/fstab and my /etc/mtab are not at the good place....

how do i move back my /etc to return to the /


masonm 03-31-2006 10:21 AM

If you boot into a livecd, they should be able to mount the partition. If you're trying to boot your existing system with them, it won't work. Boot into the livecd system, then mount and edit the partition putting your /etc back where it belongs.

And yes, that was a dumb thing to do. LOL

nilleso 03-31-2006 10:36 AM

fstab on the liveCD doesn't know those partitions have been defined... you need the be more explicit when you mount

mount /dev/xxx /mnt/something

changing /dev/xxx to the actual device and partition# ie sda3 hda2 sdb1
the directory you mount to will have to exist as well. you can `mkdir -p /mnt/bkuproot`
mount /dev/xxx /mnt/bkuproot
cp -R /mnt/bkuproot/home/etc /mnt/bkuproot
then umount /dev/xxx
and probably restart the machine

you can remove your 2nd copy of etc from the home dir if all is okay

good luck - we all do stupid things !!!

Casanogab 03-31-2006 10:45 AM

ok i boot with knoppix again

i see on desktop 4 drive ...
sda1 = ramdisk (knoppix stuff)

normally i must have one drive not 3 im on linux server with raid but the 3 disk of 80 gig are configure to give me a big 320 gig of space....

so what can i do to see my data now ?

nilleso 03-31-2006 10:54 AM

you need to know your raid/lvm setup.

however, you should be okay... just go ahead and mount all three.

Locate the /home directory in (hopefully) just one of them. Make the changes as described.

Casanogab 03-31-2006 11:03 AM

where do i check my raid/lvm ?

I cant mount my drive ...
nilleso say to create a folder...
i create the folder /mnt/drive1

mount /dev/sdb1 /mnt/drive1
>>>> give me this error >>>
mount: you must specify the filesystem type

even if i try with /dev/sda2 or sdc1 its the same thing

THX a lot for your help !!!

Dtsazza 03-31-2006 11:33 AM

Did you google the error?

mount: you must specify the filesystem type
means exactly that. Read the man page for mount, then add the corresponding filesystem option to the mount command.

ethics 03-31-2006 11:46 AM


mount -t <filesystem_type> /device /mount point
Give that a shot

As the error says, give it a filesystem type. vfat for fat32, ext3, ext2, xfs, whatever

Tinkster 03-31-2006 02:21 PM

Please do not post the same thread in more than one forum. Picking the most relevant forum and posting it once there makes it easier for other members to help you and keeps the discussion all in one place.

All times are GMT -5. The time now is 11:36 PM.