Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 06-20-2012, 07:14 AM   #1
LQ Newbie
Registered: Jun 2012
Posts: 2

Rep: Reputation: Disabled
I made a mistake changing my /home/username/pubIic_html/ ownership to username:user

Please could someone help me. I do have a dedicated linux server and my root document is /home/melieco/public_html. I issued this command "chown -R melieco:melieco /home/melieco/public_html/ and after this I could not access my domain from the browser. I do have internal errors and php_admin_flag errors.
Old 06-20-2012, 09:09 AM   #2
LQ Newbie
Registered: Jun 2012
Posts: 10

Rep: Reputation: Disabled
If you are running apache, than it must be running under the username 'apache'. All the stuff that sits on '/home/melieco/public_html/' should be owned by apache username and apache group (If you are running apache httpd server)

Do the following on the command line: (If you have apache httpd server)

chown -R apache:apache /home/melieco/public_html/

Hope this helps
Old 06-20-2012, 09:25 AM   #3
Senior Member
Registered: Mar 2012
Posts: 1,876

Rep: Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643
It doesn't and shouldn't be owned by the webserver user.
It just needs to be readable by apache.
Old 06-20-2012, 09:28 AM   #4
Registered: Jun 2012
Location: Missouri, USA
Posts: 236

Rep: Reputation: 64
The following command will print out the user and group of the Apache web server:

egrep -i '^user|^group' /etc/httpd/conf/httpd.conf
egrep -i '^user|^group' /etc/apache2/apache2.conf
Then, execute

chown -R user:group /path/to/your/documentroot/directory/
Old 06-20-2012, 09:36 AM   #5
LQ Newbie
Registered: Jun 2012
Posts: 2

Original Poster
Rep: Reputation: Disabled
Hi Skipper123,
I do appreciate your help. I have done it and the error I received now is that " You have chosen to open
Which is a: application/x-httpd-php(111 bytes) from What should firefox do with this file?

My index file is a php file , I guess that why it requires the php application. I am using suPhP and suExec and it is being selected using the cpanel. May be I have to change the owner of cgi-bin and *.php files.

I do appreciate your suggestions.
Old 06-20-2012, 10:30 AM   #6
LQ Newbie
Registered: Jun 2012
Posts: 10

Rep: Reputation: Disabled
I would recommend you to check the following URL for troubleshooting the error:


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
fedora 8 asking username but during installation i dint give any username ?? herevenku Linux - Newbie 2 08-25-2008 04:37 AM
Made Username Same As Email Address - Much Spam Received razor813 LQ Suggestions & Feedback 20 07-20-2007 05:02 AM
Constrain user to /home/username directory General Linux - Security 3 04-05-2007 01:52 AM
Changing Super User Username bjmurph Linux - General 7 10-11-2004 03:52 PM
Something is Changing ownership for /home/user/.ICEauthority biscuitheadgrav Red Hat 1 10-08-2003 01:55 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:47 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration