LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   i have to disable my network card before dialing internet (https://www.linuxquestions.org/questions/linux-newbie-8/i-have-to-disable-my-network-card-before-dialing-internet-83200/)

crazycracker 08-18-2003 02:24 PM

i have to disable my network card before dialing internet
 
hi guys
i am trying to solve this problem 4 two days but no successed
thats y i am asking it solution


i set my Speedtouch ADSl modem in RH 9.0 . every thing is O.K. if my network cards r acctive and i try to connect internet it give me following output in /var/log/message
============================================
Aug 18 22:20:52 www pppd[6075]: pppd 2.4.2b3 started by root, uid 0
Aug 18 22:20:52 www pppd[6075]: Using interface ppp0
Aug 18 22:20:52 www pppd[6075]: Connect: ppp0 <--> /dev/pts/5
Aug 18 22:20:52 www pppoa3[6076]: pppoa3 version 1.2-beta2 started by root (uid
0)
Aug 18 22:20:52 www pppoa3[6076]: Control thread ready
Aug 18 22:20:52 www pppoa3[6076]: host --> pppoa3 --> modem stream ready
Aug 18 22:20:52 www pppoa3[6076]: modem --> pppoa3 --> host stream ready
Aug 18 22:20:56 www pppd[6075]: PAP authentication succeeded
Aug 18 22:20:56 www pppd[6075]: not replacing existing default route to eth0 [195.133.33.200]
Aug 18 22:20:56 www pppd[6075]: local IP address 213.130.x.x
Aug 18 22:20:56 www pppd[6075]: remote IP address 213.130.x.x
Aug 18 22:20:56 www pppd[6075]: primary DNS address 212.77.192.10
Aug 18 22:20:56 www pppd[6075]: secondary DNS address 212.77.192.13
===============================================
i try to browse or ping sites it doesnt work

if i enter "ifconfig" command it gives me following output


===============================================
eth0 Link encap:Ethernet HWaddr 00:C0:DF:0B:45:E5
inet addr:195.133.33.200 Bcast:195.133.33.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:181 errors:0 dropped:0 overruns:0 frame:0
TX packets:213 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:16422 (16.0 Kb) TX bytes:14824 (14.4 Kb)
Interrupt:5 Base address:0x6000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:14495 errors:0 dropped:0 overruns:0 frame:0
TX packets:14495 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:989827 (966.6 Kb) TX bytes:989827 (966.6 Kb)

ppp0 Link encap:Point-to-Point Protocol
inet addr:213.130.x.x P-t-P:213.130.x.x Mask:255.255.255.255 UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:5 errors:0 dropped:0 overruns:0 frame:0
TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:150 (150.0 b) TX bytes:54 (54.0 b)
================================================


here is the out of "route -n"

=================================================
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
213.130.x.x 195.133.33.200 255.255.255.255 UGH 0 0 0 eth0
213.130.x.x 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
195.133.33.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 195.133.33.200 0.0.0.0 UG 0 0 0 eth0
===============================================
i am able to browse sites when my network cards r disable
plz help me !!!!!!!!!!!

rahulsundaram 08-18-2003 02:37 PM

hi

check /etc/resolve.conf for the dns address.make sure your ethernet cards are not crosslinked or wrongly setup

crazycracker 08-18-2003 04:10 PM

yeah i checked both things both r correctly configured


there is some other problem




:confused: :confused:

stickman 08-18-2003 04:40 PM

Have you tried deleting the default route before dialing?

crazycracker 08-18-2003 04:55 PM

no i dont
hey check the line which i bold

============================================
Aug 18 22:20:52 www pppd[6075]: pppd 2.4.2b3 started by root, uid 0
Aug 18 22:20:52 www pppd[6075]: Using interface ppp0
Aug 18 22:20:52 www pppd[6075]: Connect: ppp0 <--> /dev/pts/5
Aug 18 22:20:52 www pppoa3[6076]: pppoa3 version 1.2-beta2 started by root (uid
0)
Aug 18 22:20:52 www pppoa3[6076]: Control thread ready
Aug 18 22:20:52 www pppoa3[6076]: host --> pppoa3 --> modem stream ready
Aug 18 22:20:52 www pppoa3[6076]: modem --> pppoa3 --> host stream ready
Aug 18 22:20:56 www pppd[6075]: PAP authentication succeeded
Aug 18 22:20:56 www pppd[6075]: not replacing existing default route to eth0 [195.133.33.200]
Aug 18 22:20:56 www pppd[6075]: local IP address 213.130.x.x
Aug 18 22:20:56 www pppd[6075]: remote IP address 213.130.x.x
Aug 18 22:20:56 www pppd[6075]: primary DNS address 212.77.192.10
Aug 18 22:20:56 www pppd[6075]: secondary DNS address 212.77.192.13
===============================================



i think this is sone soute problem but i dont know how to solve it


All times are GMT -5. The time now is 02:19 AM.