-   Linux - Newbie (
-   -   I have no sound in _SOME_ applications (

kevinbenko 05-03-2013 08:11 AM

I have no sound in _SOME_ applications
I am running under Debian Testing/Unstable under KDE.
I am using the proprietary Nvidia driver version 304.88.
I had all the sound on Wednesday, and then something "broke" and I am totally clueless.
I have sound in some applications, like Amarok and Juke, for example.
I have no sound in youtube and 3-D games, like Warzone2100 and Sauerbraten, for example.

Now, I had a stroke in 2011, so I cannot figure this out. However, I have executed "alsctl init", I have messed with "kmix" and the "phonon" settings. I have even uninstalled the "sound" packages executed "aptitude clean" and reinstalled the packages.

I suspect that the problem is with the Nvidia driver, but I cannot figure this out.

Ztcoracat 05-04-2013 01:18 AM

Hi: ;)

I'm the a sound expert but I'll share with you what worked for me.

Open the mixer and raise up the PCM & Master.

Try running:

alsa+1 init
Add yourself to the audio group log out and log back in again. (adduser yourname audio)
If that doesn't help--

Open the terminal and run:

You'll see a black/grey background with multiple columns. Taise all colums all the way up mute and un-mute each column.
Do a sound test which is file noise.wav.

[00] at the bottom of the column means un-muted-
[mm] at the bottom of the colum mean muted-

Make sure that you have th Linux Sound Architecture Driver-

Files that are associated with sound that you can look at:

/etc/init.d/alsa-utils (and)

After I adjusted all of those columns it worked for me; Hope it does for you as well-

redfox2807 05-04-2013 01:23 AM

you could also check that the correct device is chosen in every parameter of the sounds and multimedia section of systemsettings

kevinbenko 05-04-2013 12:29 PM

Nope, not working
I have sound in warzone2100, but I still have no sound in youtube, nexuiz, or sauerbraten.

kevinbenko 05-04-2013 07:51 PM

OK, I created another account. For whatever reason, all of the applications had sound, thus, the problem was something within my $HOME directory. Then I deleted my temporary account and started deleting all of my configuration files, {sorry, I had a stroke and I cannot think effectively anymore}.

After a re-boot, everything has worked, but I have no idea what I had needed to delete. After re-configuring KDE and my browsers, I am now playing with sound.

frankbell 05-04-2013 08:31 PM

Thanks for the update. I expect that your filling in the details will help someone down the road.

All times are GMT -5. The time now is 06:28 PM.